大智慧大通道主图指标公式

市值:=C*CAPITAL*VOLUNIT/100000000;
股本:=FINANCE2(35)/10000;
流通:=FINANCE2(37)/10000;
人均持股:=CEILING(CAPITAL*100/selfdata(‘shx’));
市盈率:=DYNAINFO(39);
市净率:=c/FINANCE2(4);
F:=COST(5 );J:=COST(95 );
M:=COST(15 );N:=COST(85 );
F1:=(J-F)/(F+J)*100;M1:=(N-M)/(N+M)*100;
成本集中度:=F1;
莸利比例:=WINNER(c )*100;
换手率:=vol/CAPITAL*100;
净资产:=FINANCE2(4);
净资收益率:=FINANCE2(5);
最新收益:=FINANCE2(3);
每股未分配:=FINANCE2(8);
毛利润率:=FINANCE2(12);
净利润率:=FINANCE2(33)/FINANCE2(27)*100;
股东权益比:=FINANCE2(9);
每股公积金:=FINANCE2(7);
DRAWTEXTABS(10,13,’市值:’+市值+’ ‘),LINETHICK1,Color00FF00;
DRAWTEXTABS(100,13,’股本:’+股本+’ ‘),LINETHICK1,Color00FF00;
DRAWTEXTABS(190,13,’流通:’+流通+’ ‘),LINETHICK1,Color00FF00;
DRAWTEXTABS(275,13,’市盈率:’+市盈率+’ ‘),LINETHICK1,Color00FF00;
DRAWTEXTABS(375,13,’市净率:’+市净率+’ ‘),LINETHICK1,Color00FF00;
DRAWTEXTABS(455,13,’成本集中度:’+成本集中度+’ ‘),LINETHICK1,Color00FF00;
DRAWTEXTABS(455,50,’莸利比例:’+莸利比例+’ ‘),LINETHICK1,ColorFFFF07;
DRAWTEXTABS(10,50,’日换手率:’+日换手率+’ ‘),LINETHICK1,ColorFFFF07;
DRAWTEXTABS(10,30,’净资产:’+净资产+’元 ‘),LINETHICK1,ColorFFFF07;
DRAWTEXTABS(230,30,’净资收益率:’+净资收益率+’% ‘),LINETHICK1,ColorFFFF07;
DRAWTEXTABS(110,30,’最新收益:’+最新收益+’元 ‘),LINETHICK1,COLOR00FFFF;
DRAWTEXTABS(110,50,’每股未分配:’+每股未分配+’元 ‘),LINETHICK1,COLOR00FFFF;
DRAWTEXTABS(455,30,’毛利润率:’+毛利润率+’% ‘),LINETHICK1,ColorFFFF07;
DRAWTEXTABS(230,50,’净利润率:’+净利润率+’% ‘),LINETHICK1,ColorFFFF07;
DRAWTEXTABS(335,30,’股东权益比:’+股东权益比+’ ‘),LINETHICK1,COLOR00FFFF;
DRAWTEXTABS(335,50,’每股公积金:’+每股公积金+’元 ‘),LINETHICK1,COLOR00FFFF;
DRAWTEXTABS(10,65,’所属板块:’+BKNAME),COLORFF50FF,linethick1;
VARBBB:=(HIGH+LOW+OPEN+CLOSE
+REF(HIGH,1)+REF(LOW,1)+REF(OPEN,1)+REF(CLOSE,1)
+REF(HIGH,2)+REF(LOW,2)+REF(OPEN,2)+REF(CLOSE,2)
+REF(HIGH,3)+REF(LOW,3)+REF(OPEN,3)+REF(CLOSE,3)
+REF(HIGH,4)+REF(LOW,4)+REF(OPEN,4)+REF(CLOSE,4)
+REF(HIGH,5)+REF(LOW,5)+REF(OPEN,5)+REF(CLOSE,5)
+REF(HIGH,6)+REF(LOW,6)+REF(OPEN,6)+REF(CLOSE,6)
+REF(HIGH,7)+REF(LOW,7)+REF(OPEN,7)+REF(CLOSE,7)
+REF(HIGH,8)+REF(LOW,8)+REF(OPEN,8)+REF(CLOSE,8)
+REF(HIGH,9)+REF(LOW,9)+REF(OPEN,9)+REF(CLOSE,9)
+REF(HIGH,10)+REF(LOW,10)+REF(OPEN,10)+REF(CLOSE,10))/46;
均线:
MA(VARBBB,60),COLORRED,DOTLINE;
通道上:季均线+2*STD(VARBBB,60),color00ff00;
季均线+1.7*STD(VARBBB,60),colorffff33;
通道下:季均线-2*STD(VARBBB,60),color00ff00;
季均线-1.7*STD(VARBBB,60),colorffff33;
ZDT:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDT>7.0,O,C,2,0),COLORYELLOW;
STICKLINE(ZDT<-9.8,O,C,2,0),COLOR00FF00;
涨停:=ZDT>7.0;
不破价:=REF(L,BARSLAST(涨停));
STICKLINE(C/REF(C,1)>=1.090,O,C,5,0),COLORYELLOW;

大智慧大通道主图指标公式

 

大智慧筹码线捉妖股主图指标公式

M1:MA(MA(L,3),3),COLORWHITE;
M2:HHV(M1,60),COLORWHITE;
M3:SQRT(M1*M2),COLORWHITE;
M4:SQRT(M1*M3),COLORWHITE;
M5:SQRT(M2*M3),COLORWHITE;
ZDT:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDT>5,O,C,2,0),COLORYELLOW;
STICKLINE(ZDT<-9.8,O,C,2,0),COLOR00FF00;
涨停:=ZDT>5;
不破价:=REF(L,BARSLAST(涨停));
{CZW-G}
{p1:3,0,30;p2:6,1,300;p3:18,1,300;p4:250,0,300}
if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
ee:=hhv(h,ddd);
TJTS:=BARSTATUS=2;
Var1:=(C+L+H)/3;
Var2:=eMA(Var1,6);
Var3:=eMA(Var2,5);
Var4:=eMA(Var3,12);
Var5:=eMA(Var4,5);
{红绿三角【副图】}
A10304:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B10304:=FILTER(A10304,3);
C10304:=BACKSET(B10304,3+1);
D10304:=FILTER(C10304,3);{高点}
A20304:=REF(LOW,3)=LLV(LOW,2*3+1);
B20304:=FILTER(A20304,3);
C20304:=BACKSET(B20304,3+1);
D20304:=FILTER(C20304,3);{低点}
E10304:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E20304:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H10304:=(D10304 AND NOT(D20304 AND E10304>=E20304)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
L10304:=(D20304 AND NOT(D10304 AND E10304=E20304));
X10304:=REF(BARSLAST(H10304),1)+1;
F10304:=BACKSET(H10304 AND COUNT(L10304,X10304)>0,LLVBARS(IF(L10304,LOW,10000),X10304));
G10304:=F10304>REF(F10304,1);
I10304:=BACKSET(G10304,2);
LD0304:=I10304>REF(I10304,1);{过滤后低点}
L20304:=LD0304 OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X20304:=REF(BARSLAST(L20304),1)+1;
F20304:=BACKSET(L20304 AND COUNT(H10304,X20304)>0,HHVBARS(IF(H10304,HIGH,0),X20304));
G20304:=F20304>REF(F20304,1);
I20304:=BACKSET(G20304,2);
HD0304:=I20304>REF(I20304,1);{过滤后高点}
UU0304:=BACKSET(BARSTATUS=2,BARSLAST(LD0304)+1);
VV0304:=UU0304>REF(UU0304,1);
UU20304:=BACKSET(BARSTATUS=2,BARSLAST(HD0304)+1);
VV20304:=UU20304>REF(UU20304,1);
{以下语句为三角形部分}
底:REF(L,BARSLAST(VV0304)),COLORred,LINETHICK1;
顶:REF(H,BARSLAST(VV20304)),COLORGreen,LINETHICK1;
{下跌三角形:绿色三角形画完介入}
StickLine(VV0304,顶,底,0,0),COLORGreen,linethick2;
DRAWLINE(VV20304,H,VV0304,L,0),COLORGreen,linethick2;{斜}
DRAWLINE(VV20304,H,VV0304,顶,0),COLORGreen,linethick2;
{上涨三角形:红色三角形画完出局}
StickLine(VV20304 ,顶,底,0,0),COLORred,linethick2;
DRAWLINE(VV0304,L,VV20304,H,0),COLORred,linethick2;{斜}
DRAWLINE(VV0304,L,VV20304,底,0),COLORred,linethick2;
{箱体}
TY309:=C;
HD309:=FILTER(BACKSET(FILTER(REF(TY309,10)=HHV(TY309,2*10+1),10),10+1),10);
LD309:=FILTER(BACKSET(FILTER(REF(TY309,10)=LLV(TY309,2*10+1),10),10+1),10);
A309:=REF(C,BARSLAST(HD309));
B309:=REF(C,BARSLAST(LD309));
T1309:=BARSLAST(HD309)<BARSLAST(LD309) AND NOT(HD309) ;
T2309:=BARSLAST(HD309)>BARSLAST(LD309) AND NOT(LD309);
波浪顶:IF(T1309,A309,A309),COLORCYAN,POINTDOT,LINETHICK2;
波浪底:IF(T2309,B309,B309),COLORMAGENTA,POINTDOT,LINETHICK2;

大智慧筹码线捉妖股主图指标公式

 

大智慧短线出击选股指标公式

A1:=REF(O=C,1) AND REF(H>O,1) AND REF(L<O,1);
A2:=C/REF(C,1)>1.05;{www.88gs.com}
A3:= CLOSE>REF(CLOSE,1)*1.03 ;
A4:=V<=LLV(V,5) OR V>=HHV(V,5);
A5:=MA(CLOSE,5);A10:=MA(CLOSE,10);
A20:=MA(CLOSE,20);A30:=MA(CLOSE,30);
XG1:=A5>A10 AND A10>A20 AND A20>A30 AND A5>REF(A5,1)
AND A10>REF(A10,1)AND A20>REF(A20,1) AND A30>REF(A30,1) ;
短线出击:A1 AND A2 AND A3 AND A5 AND XG1 ;

大智慧短线出击选股指标公式

 

大智慧RSI变指标公式

SSRCJL:=EMA(VOL,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=((SSRCJE / SSRCJL) / 100);
SSRGL:=(((CLOSE – SSRCBJX) / SSRCBJX) * 100);
短底:FILTER(SSRGL<(0-6),5),LINETHICK0;
STICKLINE((SSRGL<(0 – 6)),0,5,6,0),COLORWHITE;
好线:=38;
平线:=51;
OK:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
鱼:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORRED;
RSI4:=SMA(鱼,7,1);
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9;
A1:=MA(趋势A,7)*1.372;
A2:=A1*1.0887;
A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12;
鱼网:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38),COLOR9AFA00,LINETHICK1,DOTLINE;
白绿线:SMA(鱼,7,1),COLORWHITE;
鱼网蓝柱:鱼网=48 AND CROSS(鱼,好线) AND REF(MA(C,3),1)<=MA(C,3) and sma(鱼,7,1)>ref(SMA(鱼,7,1),1),COLORBLUE,LINETHICK0;
STICKLINE(鱼网蓝柱,50,55,10,0),COLORBLUE;
镶黄柱:C>MA(C,3) AND C>=MA(C,7) AND count(C>=O,2)>1 AND 鱼网蓝柱 ,COLORYELLOW,LINETHICK0 ;
STICKLINE(镶黄柱,60,65,10,0),COLORYELLOW;
80,DOTLINE;
20,DOTLINE;
HH:=BARSLAST(鱼<=15)<5;
深水鱼:CROSS(鱼,RSI4) AND HH AND RSI4<15,COLORBROWN,lINETHICK0;
STICKLINE(深水鱼,55,60,9,0),COLORBROWN;
买点1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
买点2:=SMA(买点1,3,1);
买点3:=SMA(买点2,3,1);
买点4:=3*买点2-2*买点3;
买点5:=C-REF(C,1);
买点6:=100*EMA(EMA(买点5,6),6)/EMA(EMA(ABS(买点5),6),6);
买点:=LLV(买点6,2)=LLV(买点6,7) AND COUNT(买点6<0,2) AND CROSS(买点6,MA(买点6,2));
STICKLINE(FILTER(买点=1,5),15,20,10,0),COLORRED;
STICKLINE(买点,10,15,10,0),COLORYELLOW;

大智慧RSI变指标公式

 

大智慧爱心无价指标公式

zz:=(o+h+l)/3;
hjmd:EMA(zz,4),COLORYELLOW,LINETHICK1;
xxb:=CLOSE*VOL;
xxbym:EMA((EMA(xxb,3)/EMA(VOL,3)+EMA(xxb,6)/EMA(VOL,6)+EMA(xxb,12)/EMA(VOL,12)+EMA(xxb,24)/EMA(VOL,24))/4,13),colorff00ff,LINETHICK0;
爱心:=EMA(CLOSE,13)-EMA(CLOSE,55);
无价:=EMA(爱心,3);
PARTLINE(xxbym,爱心>=无价,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;
DRAWTEXTREL(700,120,’今日买点:’+NUMTOSTRN(hjmd,2 )),LINETHICK2,coloryellow;
yc:=(h+l)/2;
ychjx:=(EMA(zz,4))+(yc-ref(zz,3))/4;
DRAWTEXTREL(650,20,’昨测今日买点:’+NUMTOSTRN(ref(ychjx,1),2)),LINETHICK2,colorFF00FF;
DRAWTEXTREL(700,220,’明日买点:’+NUMTOSTRN(ychjx,2)),LINETHICK2,colorff00ff;

大智慧爱心无价指标公式

 

大智慧操盘线买卖主图指标公式

bu:=cross(high,SAR(3,1,20));
sel:=cross(SAR(3,1,20),low);
var1:=last(high<SAR(3,1,20));
var2:=last(low>sar(3,1,20));
drawflagtext(bu,high,’买入‘);
drawflagtext(sel,low,’卖出’);
drawtext(bu,LOW,’B’),valign0,align1,coloryellow,linethick2;
drawtext(sel,HIGH,’S’),valign2,align1,colorgreen,linethick2;
STICKLINE(low>SAR(3,1,20) and isdown,high,open,0.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,open,7.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,low,0.5,1),colorred;
STICKLINE(high<SAR(3,1,20) and isup,high,close,0.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,close,open,7.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,open,low,0.5,1),colorcyan;
drawflagtext(high<SAR(3,1,20) and high>=ref(high,1),high,’明日突破’+forcast(sar(3,1,20),max(var1,2))+’建议关注’);
drawflagtext(high<SAR(3,1,20) and high<ref(high,1),high,’持币观望’);
drawflagtext(low>SAR(3,1,20) and low<=ref(low,1),low,’明日跌破’+forcast(sar(3,1,20),max(var2,2))+’注意止盈’);
drawflagtext(low>SAR(3,1,20) and low>ref(low,1),low,’继续持股‘);
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
牛线:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/211,COLORYELLOW;
马线:MA(牛线,5),COLORRED;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(涨停,H,L,0,0),COLORMAGENTA;

大智慧操盘线买卖主图指标公式

 

大智慧布林收口主图指标公式

P:=3;
N:=10;
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK2;
UPR:BBI+P*STD(BBI,N);
DWN:BBI-P*STD(BBI,N);
EMA5:EMA(CLOSE,5);
W:=BARSLAST(DISPSTATUS=1);
天:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXTREL(10,150,’■目前可见K线:’+NUMTOSTRN(W+1,0)+’天’),colorwhite;
低涨:(C/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;DRAWTEXTREL(10,100,’■低点至今上涨:’+NUMTOSTRN(低涨,2)+’%’+NUMTOSTRN(天,0)+’天’),COLOR0000FF;
DRAWTEXTREL(10,200,’■建议查阅K线:短线30天,中长线120天!’),COLORFF8899;
DRAWTEXTREL(10,50,’所属板块:’+BKNAME),LINETHICK1,color00FFFF;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
STICKLINE(ZT,REF(O,BH),REF(C,BH),7,0),COLORYELLOW;
TY:=C;
A1:=REF(TY,5)=HHV(TY,2*5+1);B1:=FILTER(A1,5);C1:=BACKSET(B1,5+1);HD:=FILTER(C1,5);
A2:=REF(TY,5)=LLV(TY,2*5+1);B2:=FILTER(A2,4);C2:=BACKSET(B2,4+1);LD:=FILTER(C2,5);
压力线:REF(C,BARSLAST(HD)),COLORRED{红色},POINTDOT;
STICKLINE(C,压力线,压力线,8,2),COLORMAGENTA{红色},linethick1;

大智慧布林收口主图指标公式

 

大智慧渔网兜鱼指标公式

好线:=38;
平线:=51;
ok:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
鱼:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100, colorred,DOTLINE;
RSI4:SMA(鱼,7,1);
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9;
趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18;
A1:=MA(趋势A,7)*1.372;
A2:=A1*1.0887;
A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12;
鱼网:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38),colorblue;
鱼网蓝柱:鱼网=48 AND CROSS(鱼,好线) AND REF(MA(C,3),1)<=MA(C,3),colorblue;
STICKLINE(鱼网蓝柱,50,70,8,0),colorblue;
镶黄柱:C>MA(C,3) AND C>=MA(C,7) AND all(C>O,2) AND 鱼网蓝柱,COLORYELLOW; ;
STICKLINE(镶黄柱,30,50,7,0),COLORYELLOW;
HH:=BARSLAST(鱼<=15)<5;
深水鱼:CROSS(鱼,RSI4) AND HH AND RSI4>15,COLORFFFFFF;
STICKLINE(深水鱼,80,70,6,0),COLORFFFFFF;
三七金叉:BARSLAST(鱼网蓝柱)<5 AND CROSS(MA(C,3),MA(C,7)),COLORFF00FF;
STICKLINE(三七金叉,50,70,6,0),COLORFF00FF;

大智慧渔网兜鱼指标公式

 

大智慧MACD看透主力更新版指标公式

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
SHORT:=12;LONG:=26;MID:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),COLORYELLOW;
DEA:EMA(DIF,MID),COLORFF9900 ;
MACD:=(DIF-DEA)*2;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;{OBV上升且3日均线上升,画MACD黄柱}
吸:="XLPL.NOTEXT吸";
拉:="XLPL.NOTEXT拉";
派:="XLPL.NOTEXT派";
落:="XLPL.NOTEXT落";
STICKLINE(吸,0,MACD,1,0),COLOR00ccff;
STICKLINE(拉,0,MACD,1,0),COLORRED;
STICKLINE(派,0,MACD,1,0),COLORGREEN;
STICKLINE(落,0,MACD,1,0),COLORWHITE;
{ 主力买1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
主力买2:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLOR00FF00,LINETHICK2;}
主力买1:(DIF>REF(DIF,1))*DIF,COLORRED,LINETHICK0;
主力买2:(DIF<REF(DIF,1))*DIF,COLOR00FF00,LINETHICK0;
partline(dif,DIF>REF(DIF,1),rgb(255,0,0),DIF<REF(DIF,1),rgb(0,255,0)),linethick2;
低位金叉:CROSS(DIF,DEA) AND DIF<-0.1,linethick0;
STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;
DRAWTEXT(低位金叉,0.16,’ 低位金叉’),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,linethick0;
STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,’ 二次金叉’),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA),linethick0;
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
DRAWTEXT(底背离,0.12,’底背离’),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF),linethick0;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,’三全项’),COLOR0000FF,LINETHICK2;

大智慧MACD看透主力更新版指标公式

 

大智慧量比猎庄分时指标公式

量比曲线:SUM(VOL,0)*240/DYNAINFO(38)/BARSCOUNT(C);
量比选:量比曲线>REF(量比曲线,1),linethick0;
个股涨幅:=(C-REF(C,1))/REF(C,1)*100;
大盘涨幅:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
强弱度:=个股涨幅-大盘涨幅;
强弱选:强弱度>REF(强弱度,1),linethick0;
AA1:=(C-REF(C,1))/REF(C,1)*100;
AA2:=(V-REF(MA(V,5),1))/REF(MA(V,5),1)*100;
AA3:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
AA4:=(INDEXV-REF(MA(INDEXV,5),1))/REF(MA(INDEXV,5),1)*100;
TJ1:=AA1>=1.8 AND AA2>=200 AND (AA1/AA3>=2 OR AA3<=0) AND AA2/AA4>3 AND HOUR>=10;
TJ2:=AA1>=3 AND AA2>=8 AND (AA1/AA3>=3 OR AA3<=0) AND AA2/AA4>5 AND HOUR<10;
强势买:TJ1 OR TJ2,colorred;
强势买s:sum(强势买,0),linethick0;
昨收价:=DYNAINFO(3);
涨幅:=C/昨收价<=1.055;
出击:量比选 AND 强弱选 AND 强势买 AND 涨幅,linethick0;
出击s:sum(出击,0),linethick0;
DRAWTEXT(出击,量比曲线,’猎庄’ ),COLOR0000FF;
DRAWICON(出击,量比曲线,7),ALIGN1,VALIGN2;
{基本信息}
【上市年】:=REF(YEAR,BARSCOUNT(C)-1);
【月】:=REF(MONTH,BARSCOUNT(C)-1);
【日】:=REF(DAY,BARSCOUNT(C)-1);
DRAWTEXTabs(1,70,’■上市日期:’+NUMTOSTRN(【上市年】,0)+’年’+NUMTOSTRN(【月】,0)+’月’+NUMTOSTRN(【日】,0)+’日’+’ 上市后总交易天数:’+NUMTOSTRN(BARSCOUNT(C),0)+’天 ‘),ColorAAEEEE,LINETHICK1;
DRAWTEXTABS(1,25,’■所属板块:’+’ ‘+BKNAME),COLORYELLOW,LINETHICK1;
DRAWTEXTABS(1,40,’■流通盘:’+capital/1000000+’亿’),COLORred,linethick1;
drawtextabs(1,55,bkname);

大智慧量比猎庄分时指标公式