大智慧财务数据指标公式

{背景颜色}
DRAWGBKLAST(DYNAINFO(3)<DYNAINFO(7){OPEN},STRIP(RGB(50,0,150),RGB(150,0,50),1));
DRAWGBKLAST({CLOSE}DYNAINFO(3)>DYNAINFO(7){OPEN},STRIP(RGB(50,0,150),RGB(150,0,50),1));
{所属板块基本面}
报告日期:=FINANCE2(1);
所属板块:=BKNAME;
总股本:=FINANCE2(35)/10000;
流通股:=FINANCE2(37)/10000;
限售股:=FINANCE2(35)/10000-FINANCE2(37)/10000;
收益:=FINANCE2(3);
净资产:=FINANCE2(4);
净利润率:=PFFIN(1657,0);
净资产收益率:=FINANCE2(5);
公积金:=FINANCE2(7);
净利润同比:=FINANCE2(10);
主营收同比:=FINANCE2(11);
市净率:=DYNAINFO(58);
市盈率:=DYNAINFO(39);
上市交易日:=BARSCOUNT(C);
毛利润率:=FINANCE2(12);
资产负债率:=PFFIN(1701,0);
DRAWTEXTABS(12,5, ‘所属板块:’+所属板块),COLORYELLOW;
DRAWTEXTABS(12,20,’总股本:’+NUMTOSTRN(总股本,2)+’亿’),COLORYELLOW;
DRAWTEXTABS(12,35,’流通股:’+NUMTOSTRN(流通股,2)+’亿’),COLORBF3EFF;
DRAWTEXTABS(12,50,’限售股:’+NUMTOSTRN(限售股,2)+’亿’),COLORYELLOW;
DRAWTEXTABS(12,65,’上市交易日:’+上市交易日),COLORYELLOW;
DRAWTEXTABS(8,95,’【财务报告日期】:’+NUMTOSTRN(报告日期,0)+’日’),COLORBF3EFF;
DRAWTEXTABS(150,20,’收益:’+NUMTOSTRN(收益,2)+’元’),COLORYELLOW;
DRAWTEXTABS(150,35,’公积金:’+NUMTOSTRN(公积金,2)+’元’),LINETHICK1,COLORYELLOW;
DRAWTEXTABS(150,50,’市盈率:’+NUMTOSTRN(市盈率,0)+’倍’),LINETHICK2,COLORBF3EFF;
DRAWTEXTABS(150,65,’市净率:’+NUMTOSTRN(市净率,0)+’倍’),LINETHICK2,COLORBF3EFF;
DRAWTEXTABS(277,20,’历史最高:’+HHV(HIGH,0)),COLORYELLOW;
DRAWTEXTABS(477,20,’历史最低:’+LLV(LOW,0)),COLORYELLOW;
DRAWTEXTABS(12,127,’净利润率:’+NUMTOSTRN(净利润率,2)+’%’),LINETHICK3,COLORYELLOW;
DRAWTEXTABS(12,157,’净利润同比:’+NUMTOSTRN(净利润同比,2)+’%’),LINETHICK3,COLORYELLOW;
DRAWTEXTABS(12,187,’主营收同比:’+NUMTOSTRN(主营收同比,2)+’%’),LINETHICK3,COLORYELLOW;
DRAWTEXTABS(12,217,’销售毛利率:’+NUMTOSTRN(毛利润率,2)+’%’),LINETHICK3,COLORYELLOW;
DRAWTEXTABS(227,157,’资产负债率:’+NUMTOSTRN(资产负债率,2)+’%’),LINETHICK3,COLOR00FF00;
DRAWTEXTABS(227,127,’净资产收益率:’+NUMTOSTRN(净资产收益率,2)+’%’),LINETHICK3,COLORYELLOW;
{三年复合净利润}
年末净利润:=PFFIN(1272,3);
三年前净利润:=PFFIN(1272,15);
三年复合增长率:(POW(年末净利润/三年前净利润,1/3)-1)*100,LINETHICK2,COLORred;
DRAWTEXTABS(227,187,’三年复合增长率:’+NUMTOSTRN(三年复合增长率,2)+’%’),LINETHICK3,COLORBF3EFF;
{年报季报,N需要随着年度更改}
N:=2017;
年报:= PFFININ(1001,N-1,1231 );
去年增长率:= PFFININ(1604,N-1,1231 );
去年收益率:=PFFININ(1002 ,N-1 ,1231 );
一季收益率:= PFFININ(1002,N,0331 );
二季收益率:= PFFININ(1002,N,0630 );
三季收益率:= PFFININ(1002,N,0930 );
四季收益率:= PFFININ(1002,N,1231 );
一季增长率:= PFFININ(1604,N,0331 );
二季增长率:= PFFININ(1604,N,0630 );
三季增长率:= PFFININ(1604,N,0930 );
四季增长率:= PFFININ(1604,N,1231 );
DRAWTEXTREL(677,120,’2017净利润同比:’+去年增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,120,’2017净资产收益:’+去年收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,180,’一季净利润同比:’+一季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,240,’二季净利润同比:’+二季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,300,’三季净利润同比:’+三季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,360,’四季净利润同比:’+四季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,180,’一季收益率:’+一季收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,240,’二季收益率:’+二季收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,300,’三季收益率:’+三季收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,360,’四季收益率:’+四季收益率),LINETHICK1,Coloryellow;
{年报季报,N需要随着年度更改}
N:=2018;
年报:= PFFININ(1001,N-1,1231 );
去年增长率:= PFFININ(1604,N-1,1231 );
去年收益率:=PFFININ(1002 ,N-1 ,1231 );
一季收益率:= PFFININ(1002,N,0331 );
二季收益率:= PFFININ(1002,N,0630 );
三季收益率:= PFFININ(1002,N,0930 );
四季收益率:= PFFININ(1002,N,1231 );
一季增长率:= PFFININ(1604,N,0331 );
二季增长率:= PFFININ(1604,N,0630 );
三季增长率:= PFFININ(1604,N,0930 );
四季增长率:= PFFININ(1604,N,1231 );
DRAWTEXTREL(677,500,’2018净利润同比:’+去年增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,500,’2018净资产收益:’+去年收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,560,’一季净利润同比:’+一季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,620,’二季净利润同比:’+二季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,680,’三季净利润同比:’+三季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(677,740,’四季净利润同比:’+四季增长率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,560,’一季收益率:’+一季收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,620,’二季收益率:’+二季收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,680,’三季收益率:’+三季收益率),LINETHICK1,Coloryellow;
DRAWTEXTREL(850,740,’四季收益率:’+四季收益率),LINETHICK1,Coloryellow;
{获利盘与套牢盘}
F:=COST(5 );J:=COST(95 );
M:=COST(15 );N:=COST(85 );
F1:=(J-F)/(F+J)*100;M1:=(N-M)/(N+M)*100;
莸利比例:=WINNER(c )*100;
净资产:=FINANCE2(4);
获利盘:=WINNER(CLOSE)*100;
套牢盘:=100*(1-WINNER(C));
成本集中度90:=F1;
成本集中度70:=M1;
浮筹比例:=(winner(c*1.1)-winner(c*0.9))/winner(hhv(h,0))*100;
DRAWTEXTABS(277,50,’获利盘: ‘+NUMTOSTRN(获利盘,2)+’%’),LINETHICK2,COLORBF3EFF;
DRAWTEXTABS(477,50,’套牢盘: ‘+NUMTOSTRN(套牢盘,2)+’%’),LINETHICK0,Color00FF00;
{主力成本与压力}
n1:=barslast(cross(c,MA(c,60)));
n2:=barslast(cross(MA(c,60),c));
建仓成本:=MAXCYC;
压力位:=DMA(AMOUNT/(100*VOL),VOL/(100*FINANCE2(37)))*1.12;
强股排序:=if(n1<n2,n1+1,0);
DRAWTEXTABS(277,35,’庄家成本:’+NUMTOSTRN(建仓成本,2)+’元’),LINETHICK2,COLORBF3EFF;
DRAWTEXTABS(12,80,’上穿60均线:’+NUMTOSTRN(强股排序,0)+’天’),COLORYELLOW;
DRAWTEXTABS(477,35,’心理压力:’+NUMTOSTRN(压力位,2)+’元’),Color00FF00;
换手率:=(VOL*100/CAPITAL);;
5日换手率:=SUM(日换手率,5);;
DRAWTEXTABS(477,65,’换手率:’+NUMTOSTRN(日换手率,2)+’%’),COLORYELLOW;
DRAWTEXTABS(277,65,’5日换手:’+NUMTOSTRN(5日换手率,2)+’%’),LINETHICK2,COLORBF3EFF;
{该股代码和名称当日股价和当日涨幅}
DRAWTEXTREL(277,850,STKLABEL+’ ‘+STKNAME+’ ‘+DYNAINFO(7)+’元’+’ ‘+DYNAINFO(14)*100+’%’),LINETHICK4,COLORFFFF00;

大智慧财务数据指标公式

 

大智慧持仓主图指标公式

操作个股一:="SH600519$CLOSE";
股一买入价:=700;
股一买入数:=100;
个股一涨幅:=(操作个股一/ref(操作个股一,1)-1)*100;
DRAWTEXTABS(5,100,’贵州茅台’+NUMTOSTRN(操作个股一,2)+'(‘+NUMTOSTRN(个股一涨幅,2)+’%’+’)’),COLOrWHITE;
盈亏一:=操作个股一/股一买入价*100-100;
盈亏一数:=(操作个股一-股一买入价)*股一买入数;
DRAWTEXTABS(95,100,’ 盈亏 ‘+NUMTOSTRN(盈亏一,2)+’%’+’ ‘+NUMTOSTRN(盈亏一数,2)),COLOrWHITE;
{个股一止盈}DRAWTEXTABS(5,85,’ 止盈价 ‘+NUMTOSTRN(股一买入价*1.05,2)),COLOrred;
DRAWTEXTABS(95,85,IFS(盈亏一>=3,’ 止盈’,”)),COLOrred,LINETHICK1;
{个股一止损}DRAWTEXTABS(5,115,’ 止损价 ‘+NUMTOSTRN(股一买入价*0.97,2)),COLOrgreen;
DRAWTEXTABS(95,115,IFS(盈亏一<=-3,’ 止损’,”)),COLOrgreen,LINETHICK1;

大智慧持仓主图指标公式

 

大智慧买卖通道看盘主图指标公式

DRAWGBK(DATE>900101,STRIP(RGB(0,150,130),RGB(0,0,0),0));
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=cross(买线,卖线);
SEL:=cross(卖线,买线);
drawtext(bu,LOW,’B’),ALIGN1,VALIGN0,colorred,linethick3;
DRAWTEXT(bu,LOW,’ ̄’),ALIGN1,VALIGN0,Color208FFF,LINETHICK3;
DRAWTEXT(sel,HIGH,’ ̄’),ALIGN1,VALIGN0,ColorFFFF00,LINETHICK3;
drawtext(sel,HIGH,’S’),ALIGN1,VALIGN2,colorgreen,linethick3;
stickline(买线>=卖线,low,high,0.1,1),colorred;
stickline(买线>=卖线,close,open,8,1),colorred;
stickline(买线<卖线,close,open,8,0),color00ff00;
stickline(买线<卖线,low,high,0.1,1),color00ff00;
stickline(cross(买线,卖线) or cross(卖线,买线),open,close,6,0),colorffff00;
指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick1,ColorFFffFF;
界: MA(CLOSE,27),linethick1,Color00FFFF;
DRAWTEXT(cross(指导线,界),界,’上破’),ALIGN1,VALIGN2,Colorffffff;
DRAWTEXT(cross(指导线,界),界,’ ̄ ̄’),ALIGN1,VALIGN0,Colorffffff;
DRAWTEXT(cross(界,指导线),界,’下破’),ALIGN1,Color00ffff;
DRAWTEXT(cross(界,指导线),界,’ ̄ ̄’),ALIGN1,Color00ffff;
上限: 界+3*STD(CLOSE,27),linethick1,Color00FFFF;
卖: 界+2*STD(CLOSE,27),linethick1,ColorFF00FF;
买: 界-2*STD(CLOSE,27),linethick1,ColorF0FF00;
下限: 界-2.9*STD(close,27),linethick1,Color00FF00;
DRAWTEXT(cross(H,上限),H,’获利’),ALIGN1,VALIGN2,Color00ffff;
DRAWTEXT(cross(H,上限),H,’ ̄ ̄’),ALIGN1,VALIGN0,Color00ffff;
DRAWTEXT(cross(上限,H),H,’&利’),ALIGN1,VALIGN2,Color00ffff;
DRAWTEXT(cross(上限,H),H,’ ̄ ̄’),ALIGN1,VALIGN0,Color00ffff;
DRAWTEXT(cross(H,卖),H,’获利’),ALIGN1,VALIGN2,Colorff00ff;
DRAWTEXT(cross(H,卖),H,’ ̄ ̄’),ALIGN1,VALIGN0,Colorff00ff;
DRAWTEXT(cross(C,卖),H,’获利’),ALIGN1,VALIGN2,Colorff0000;
DRAWTEXT(cross(C,卖),H,’ ̄ ̄’),ALIGN1,VALIGN0,Colorff0000;
DRAWTEXT(cross(下限,L),l,’观’),ALIGN1,VALIGN0,Color00ff00;
DRAWTEXT(cross(下限,L),l,’ ̄ ̄’),ALIGN1,VALIGN0,Color00ff00;
DRAWTEXT(cross(买,L),l,’◎’),ALIGN1,VALIGN0,Colorff0000;
DRAWTEXT(cross(买,L),l,’ ̄ ̄’),ALIGN1,VALIGN0,Colorff0000;
DRAWTEXT(cross(买,C),L,’◎’),ALIGN1,VALIGN0,Colorff0000;
DRAWTEXT(cross(买,C),L,’ ̄ ̄’),ALIGN1,VALIGN0,Colorff0000;

大智慧买卖通道看盘主图指标公式

 

大智慧龙眼看盘主图指标公式

生命线:MA(CLOSE,22),LINETHICK2,COLORRED;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
主力成本:EMA(X,13),{COLORFF00FF}COLORBLACK,LINETHICK1;
短期底部:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
IF(MA(C,3),MA(C,3),c),COLOR006633,LINETHICK2;
IF(MA(C,9),MA(C,9),c),COLORMAGENTA,LINETHICK2;
IF(MA(C,23.5),MA(C,23.5),c),COLORblue,LINETHICK0;
{DRAWKLINE(HIGH,OPEN,LOW,CLOSE);}
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);
DRAWTEXT(FB,L-0.58,’持股‘),COLORRED;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
DRAWTEXT(CROSS(V1,V2),V1+0.05,’直到涨’),colorff0099;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 100),5);
AK:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),’低吸’),COLORMAGENTA;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
建仓:BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;
DRAWTEXT(慢建仓,L*0.99,’慢建仓’),COLOR0099FF;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),’★介必升 ‘),COLORBLUE;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.96000001),’★莫观望’),COLORBLUE;
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),’手勿痒’),COLOR006633;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,’高抛’),COLORBLUE;
{*********************************}
{****************************}
{VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.90),’★大胆搏 ‘),COLORblack;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(1.2),’★加仓‘),COLORblack;}
{************************}
DRAWTEXTABS(2,6,’所属板块:’+BKNAME),COLORblack,linethick1;
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比:=FINANCE2(10);
DRAWTEXTABS(118,40,’每股净资产:’+NUMTOSTRN(每股净资产,2)+’元’),COLORRED;
DRAWTEXTABS(2,40,’销售毛利率:’+NUMTOSTRN(销售毛利率,2)+’%’),LINETHICK1,COLORblue;
DRAWTEXTABS(2,57,’主营收入同比:’+NUMTOSTRN(主营收入同比,2)+’%’),LINETHICK1,Colorblack;
DRAWTEXTABS(2,72,’净利润同比:’+NUMTOSTRN(净利润同比,2)+’%’),LINETHICK1,COLOR006633;
DRAWTEXTABS(3,87,’最高价:’+HHV(HIGH,0)),Colorred;
DRAWTEXTABS(3,102,’最低价:’+LLV(LOW,0)),Colorff0099;
{********************};
每股收益:finance2(3),linethick0,COLORBLUE;
{最新:DYNAINFO(7),color888888;}
{*************************************}
DRAWTEXTABS(55,25,STR(DYNAINFO(39))),COLORRED;
DRAWTEXTABS(165,25,STR(DYNAINFO(58))),COLORRED;
DRAWTEXTABS(275,25,STR(WINNER(C)*100)),COLORRED;
DRAWTEXTABS(5,25,’市盈率: 市净率: 获利比例: % ‘),COLORRED;
X:=(3*C+L+O+H)/6;
海平面:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLOR888888,LINETHICK0;
DD:=海平面<REF(海平面,1);
A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
A6:=EMA(A5,9);
A7:=(A5<-0.1 AND A5>A6);
龙王:IF(A7,LLV(L,21),生命线),COLORRED,{CIRCLEDOT}POINTDOT,linethick3;

大智慧龙眼看盘主图指标公式

 

大智慧净量换手排序指标公式

input:n(5);
k1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
k2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
dt:=VOL*K1/(K1+K2);
kt:=VOL-DT;
买量:sum(dt,n),COLOR0000FF;
卖量:-sum(kt,n),COLORFFFF00;
FILLRGN(买量,0,1,RGB(0,120,0));
FILLRGN(卖量,0,1,RGB(0,80,0));
进出量:买量+卖量,POINTDOT,COLOR00FFFF;
净量换手:100*进出量/CAPITAL,POINTDOT,COLOR00FF33;
STICKLINE(进出量>=0,0,进出量,6,1),COLOR0000FF;
STICKLINE(进出量<0,0,进出量,6,1),COLORFFFF00;
D5:=100*SUM(DT,5)/CAPITAL;
K5:=100*SUM(KT,5)/CAPITAL;
J5:=D5-K5;
D10:=100*SUM(DT,10)/CAPITAL;
K10:=100*SUM(KT,10)/CAPITAL;
J10:=D10-K10;
D20:=100*SUM(DT,20)/CAPITAL;
K20:=100*SUM(KT,20)/CAPITAL;
J20:=D20-K20;
BL5:=400/MAX(D5,K5);
BL10:=400/MAX(D10,K10);
BL20:=400/MAX(D20,K20);
DRAWRECTREL(0,0,360,999,RGB(50,50,50));
D5B:=999-D5*BL5;
K5B:=999-K5*BL5;
J5B:=999-ABS(J5)*BL5;
D10B:=999-D10*BL10;
K10B:=999-K10*BL10;
J10B:=999-ABS(J10)*BL10;
D20B:=999-D20*BL20;
K20B:=999-K20*BL20;
J20B:=999-ABS(J20)*BL20;
{画直方图}
DRAWRECTREL(30,D5B,50,999,RGB(150,0,0));
DRAWRECTREL(50,K5B,70,999,RGB(0,150,150));
DRAWRECTREL(70,J5B,90,999,RGB(150,150,0));
DRAWRECTREL(150,D10B,170,999,RGB(150,0,0));
DRAWRECTREL(170,K10B,190,999,RGB(0,150,150));
DRAWRECTREL(190,J10B,210,999,RGB(150,150,0));
DRAWRECTREL(270,D20B,290,999,RGB(150,0,0));
DRAWRECTREL(290,K20B,310,999,RGB(0,150,150));
DRAWRECTREL(310,J20B,330,999,RGB(150,150,0));
DRAWTEXTREL(90,0,’买量’), colorddffff;
DRAWTEXTREL(180,0,’卖量’), colorddffff;
DRAWTEXTREL(270,0,’进出量’), colorddffff;
DRAWTEXTREL(20,100,’今日’), color33ffff;
DRAWTEXTREL(90,100,NUMTOSTRN(100*DT/CAPITAL,2)), color33ffff;
DRAWTEXTREL(180,100,NUMTOSTRN(100*KT/CAPITAL,2)), color33ffff;
DRAWTEXTREL(270,100,NUMTOSTRN(100*DT/CAPITAL-100*KT/CAPITAL,2)), color33ffff;
DRAWTEXTREL(27,200,’5日’), colorddffff;
DRAWTEXTREL(90,200,NUMTOSTRN(D5,2)), colorddffff;
DRAWTEXTREL(180,200,NUMTOSTRN(K5,2)), colorddffff;
DRAWTEXTREL(270,200,NUMTOSTRN(J5,2)), colorddffff;
DRAWTEXTREL(20,300,’10日’), color33ffff;
DRAWTEXTREL(90,300,NUMTOSTRN(D10,2)), color33ffff;
DRAWTEXTREL(180,300,NUMTOSTRN(K10,2)), color33ffff;
DRAWTEXTREL(270,300,NUMTOSTRN(J10,2)), color33ffff;
DRAWTEXTREL(20,400,’20日’), colorddffff;
DRAWTEXTREL(90,400,NUMTOSTRN(D20,2)), colorddffff;
DRAWTEXTREL(180,400,NUMTOSTRN(K20,2)), colorddffff;
DRAWTEXTREL(270,400,NUMTOSTRN(J20,2)), colorddffff;
DRAWTEXTREL(15,800,’5′), colorbbffff;
DRAWTEXTREL(10,900,’日’), colorbbffff;
DRAWTEXTREL(130,800,’10’), colorbbffff;
DRAWTEXTREL(130,900,’日’), colorbbffff;
DRAWTEXTREL(250,800,’20’), colorbbffff;
DRAWTEXTREL(250,900,’日’), colorbbffff;

大智慧净量换手排序指标公式

 

大智慧变速线主图指标公式

N:=5;
N1:=10;
N2:=20;
DIR:=ABS(CLOSE-REF(CLOSE,n));
VIR:=SUM(ABS(CLOSE-REF(CLOSE,1)),n);
ER:=DIR/VIR;
CS:=ER*(2/3-2/31)+2/31;
CQ:=CS*CS;
AMA:DMA(CLOSE,CQ), COLORWHITE,linethick1;
DIR1:=ABS(CLOSE-REF(CLOSE,n1));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),n1);
ER1:=DIR1/VIR1;
CS1:=ER1*(2/3-2/31)+2/31;
CQ1:=CS1*CS1;
AMA10:DMA(CLOSE,CQ1),COLORYELLOW,linethick2;
DIR2:=ABS(CLOSE-REF(CLOSE,n2));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),n2);
ER2:=DIR2/VIR2;
CS2:=ER2*(2/3-2/31)+2/31;
CQ2:=CS2*CS2;
AMA20:DMA(CLOSE,CQ2),COLORGREEN,linethick3;
PARTLINE(AMA20,AMA20>REF(AMA20,1),rgb(255,0,0)),linethick3;
DRAWTEXT(C*BACKSET(BARSTATUS=2,6)>0 AND C*BACKSET(BARSTATUS=2 ,5)=0,L*0.999,’5日’),COLORYellow,LINETHICK2;
DRAWTEXT(C*BACKSET(BARSTATUS=2,11)>0 AND C*BACKSET(BARSTATUS=2 ,10)=0,L*0.998,’10日’),COLORYellow,LINETHICK2;
DRAWTEXT(C*BACKSET(BARSTATUS=2,21)>0 AND C*BACKSET(BARSTATUS=2 ,20)=0,L*0.998,’20日’),COLORYellow,LINETHICK2;
DRAWTEXT(C*BACKSET(BARSTATUS=2,31)>0 AND C*BACKSET(BARSTATUS=2 ,30)=0,L*0.998,’30日’),COLORYellow,LINETHICK2;
DRAWTEXT(C*BACKSET(BARSTATUS=2,61)>0 AND C*BACKSET(BARSTATUS=2 ,60)=0,L*0.998,’60日’),COLORYellow,LINETHICK2;
DRAWTEXT(C*BACKSET(BARSTATUS=2,121)>0 AND C*BACKSET(BARSTATUS=2 ,120)=0,L*0.998,’120日’),COLORYellow,LINETHICK2;
DRAWTEXT(C*BACKSET(BARSTATUS=2,241)>0 AND C*BACKSET(BARSTATUS=2 ,240)=0,L*0.998,’240日’),COLORYellow,LINETHICK2;

大智慧变速线主图指标公式

 

大智慧窥探主力绝顶指标公式

{自动坐标系:50;250;400}
LC:=REF(CLOSE,1);
动力:SUM(IF(CLOSE>LC,VOL,0),26)/SUM(IF(CLOSE<=LC,VOL,0),26)*100,COLORGRAY,linethick2;
STICKLINE(CROSS(250,动力),350,400,9,0),COLOR00ff00;
洗盘:0,color00ff00;
STICKLINE(CROSS(400,动力),300,400,9,0),COLORff00ff;
舔血:0,colorff00ff;
关注:IF(动力<70,70,50),LINETHICK2,COLORffcc66;
WVAD10:=MA((CLOSE-OPEN)/(HIGH-LOW)*VOL,10)/1000+50;
真金:IF(CROSS(WVAD10,50) AND 关注>50 AND 动力<400 AND ZIG(1,19)>REF(ZIG(1,19),1),200,50),LINETHICK2,COLORBLUE;
白银:IF(CROSS(WVAD10,50) AND 动力<400 AND ZIG(1,19)>REF(ZIG(1,19),1),150,50),LINETHICK2,COLORYELLOW;
铜钱:IF(CROSS(WVAD10,50),100,50),LINETHICK2,COLORRED;
Var2:=(CLOSE+HIGH+LOW)/3;
Var3:=EMA(Var2,10);
Var4:=REF(Var3,1);
{持股:}STICKLINE(Var3>Var4,258,288,2,0),COLOR0066FF,linethick2;
持股:0,color0066ff;
{持币:}STICKLINE(Var3<Var4,218,248,2,0),COLORgreen,linethick2;
持币:0,colorgreen;
50,LINETHICK2,COLORYELLOW;
250,LINETHICK2,COLORff00ff;
400,LINETHICK2,COLORGREEN;

大智慧窥探主力绝顶指标公式

 

大智慧大神仙选股指标公式

除业绩后退股:=FINANCE2(33)>=REF(FINANCE2(33),130);
D0:=除业绩后退股;
D2:=IF(STRFIND(stkname,’S’,1),0,1);
D3:=IF(STRFIND(stkname,’*’,1),0,1);
D4:=DYNAINFO(17)>0;
去除大盘股:=CAPITAL/1000000<20;
去高价:=C<=60;
去掉:=D0 AND D2 AND D3 AND D4 AND 去除大盘股 AND 去高价 AND NOT(C>=REF(C,1)*1.097 AND C=O AND H=L);
DIF1:=(EMA(CLOSE,12)-EMA(CLOSE,26))/EMA(CLOSE,26)*100;
DEA1:=EMA(DIF1,9);
AAA1:=(DIF1-DEA1)*100;
用:=45;
户:=AAA1-REF(AAA1,1);
注册:=CROSS(户,用);
DIF:=(EMA(CLOSE,10)-EMA(CLOSE,72))/EMA(CLOSE,72)*100;
DEA:=EMA(DIF,17);
AAA:=(DIF-DEA)*100;
用户:=CROSS(AAA-REF(AAA,1),45);
VAR1:=(((CLOSE – REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR2:=(MA(VOL,2) / MA(VOL,10));
VAR3:=(VOL / CAPITAL);
XG1:=((((0 – (12.24 * ((((0.0068 * VAR1) – (0.0072 * VAR2)) – (0.5676 * VAR3)) – 0.0105))) – (1 * ((((0.0015 * VAR1) – (0.0124 * VAR2)) + (1.7461 * VAR3)) – 0.0074))) + 0.32) < 0)*110 ;
用户注册:(注册 AND 用户 ) AND 去掉 AND XG1;

大智慧大神仙选股指标公式

 

大智慧大盘趋势指标公式

大盘5日:=(INDEXC-MA(INDEXC,5))/MA(INDEXC,5)*10;
大盘7日:=(INDEXC-MA(INDEXC,7))/MA(INDEXC,7)*10;
大盘13日:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13)*10;
大盘:(大盘5日 + 大盘7日 + 大盘13日)/3;
平衡:0,COLORYELLOW;
STICKLINE(大盘>平衡,大盘,平衡,8,0),colorred;
STICKLINE(大盘<平衡,大盘,平衡,8,0),COLORWHITE;
{STICKLINE(个股>大盘,个股,大盘,3,0),COLORRED;
STICKLINE(个股<平衡,个股,平衡,3,0),COLORWHITE;};

大智慧大盘趋势指标公式