大智慧波段黄金分割主图指标公式

a1:=zig(3,N); {N自行设置:一般为2、3、5、8、13、21等等}
a2:=last(a1>ref(a1,1));
a3:=last(a1<ref(a1,1));
tt1:=peak(1,N,1);
bb1:=trough(2,N,1);
H1:=tt1-(tt1-bb1)*0.236;
H2:=tt1-(tt1-bb1)*0.382;
H3:=tt1-(tt1-bb1)*0.5;
H4:=tt1-(tt1-bb1)*0.618;
H5:=tt1-(tt1-bb1)*0.764;
H6:=tt1-(tt1-bb1)*1.0;
H7:=tt1-(tt1-bb1)*1.27;
H8:=tt1-(tt1-bb1)*1.618;
L1:=bb1+(tt1-bb1)*0.236;
L2:=bb1+(tt1-bb1)*0.382;
L3:=bb1+(tt1-bb1)*0.5;
L4:=bb1+(tt1-bb1)*0.618;
L5:=bb1+(tt1-bb1)*0.764;
L6:=bb1+(tt1-bb1)*1.0;
L7:=bb1+(tt1-bb1)*1.27;
L8:=bb1+(tt1-bb1)*1.618;
stickline(a3>0,tt1,tt1,8,0),linethick2,colorred;
stickline(a2>0,bb1,bb1,8,0),linethick2,colorred;
stickline(a3>0,H1,H1,8,0),linethick0,colorFF99CC;
stickline(a3>0,H2,H2,8,0),linethick0,colorFF99CC;
stickline(a3>0,H3,H3,8,0),linethick0,colorFF99CC;
stickline(a3>0,H4,H4,8,0),linethick0,colorFF99CC;
stickline(a3>0,H5,H5,8,0),linethick0,colorFF99CC;
stickline(a3>0,H6,H6,8,0),linethick0,colorFF99CC;
stickline(a3>0,H7,H7,8,0),linethick0,colorFF99CC;
stickline(a3>0,H8,H8,8,0),linethick0,colorFF99CC;
drawtext(a3=1,H1,’23.6%’),linethick0,colorFF99CC;
drawtext(a3=1,H2,’38.2%’),linethick0,colorFF99CC;
drawtext(a3=1,H3,’50%’),linethick0,colorFF99CC;
drawtext(a3=1,H4,’61.8%’),linethick0,colorFF99CC;
drawtext(a3=1,H5,’76.4%’),linethick0,colorFF99CC;
drawtext(a3=1,H6,’100%’),linethick0,colorFF99CC;
drawtext(a3=1,H7,’127%’),linethick0,colorFF99CC;
drawtext(a3=1,H8,’161.8%’),linethick0,colorFF99CC;
stickline(a2>0,L1,L1,8,0),linethick0,colorFF99CC;
stickline(a2>0,L2,L2,8,0),linethick0,colorFF99CC;
stickline(a2>0,L3,L3,8,0),linethick0,colorFF99CC;
stickline(a2>0,L4,L4,8,0),linethick0,colorFF99CC;
stickline(a2>0,L5,L5,8,0),linethick0,colorFF99CC;
stickline(a2>0,L6,L6,8,0),linethick0,colorFF99CC;
stickline(a2>0,L7,L7,8,0),linethick0,colorFF99CC;
stickline(a2>0,L8,L8,8,0),linethick0,colorFF99CC;
drawtext(a2=1,L1*1.015,’23.6%’),linethick0,colorFF99CC;
drawtext(a2=1,L2*1.015,’38.2%’),linethick0,colorFF99CC;
drawtext(a2=1,L3*1.015,’50%’),linethick0,colorFF99CC;
drawtext(a2=1,L4*1.015,’61.8%’),linethick0,colorFF99CC;
drawtext(a2=1,L5*1.015,’76.4%’),linethick0,colorFF99CC;
drawtext(a2=1,L6*1.015,’100%’),linethick0,colorFF99CC;
drawtext(a2=1,L7*1.015,’127%’),linethick0,colorFF99CC;
drawtext(a2=1,L8*1.015,’161.8%’),linethick0,colorFF99CC;

大智慧波段黄金分割主图指标公式

 

大智慧VOL抓主升浪指标公式

用法:
红色持股,青色卖出,更多用法还需自己揣摩。
指标只是参考,重点在于自己怎样操作,准确熟练把握指标的用法,再结合K线知识,正所谓一招鲜吃遍天。

var0:=eMA(vol,20);
var1:= var0 + 2*STD(vol,10);
var2:=var0 – 2*STD(vol,10);
主升浪:STICKLINE(var1>ref(var1,1) ,var1 ,ref(var1,1) ,8 ,1),colorred;
STICKLINE(var1<ref(var1,1) ,var1 ,ref(var1,1) ,8 ,1),COLORCYAN;

大智慧VOL抓主升浪指标公式

 

大智慧波段幅度测幅主图指标公式

a1:=zig(3,N); {设定波段,3为收盘价。要准确判断波段,必须使用这个zig函数}
{N自行设置:一般为2、3、5、8、13、21等等}
a2:=last(a1>ref(a1,1)); {波段上涨天数}
a3:=last(a1<ref(a1,1)); {波段下跌天数}
tt1:=peak(1,N,1); {向前数第一个波峰的值,括号中第一个1表示以最高价作为波峰。这里是用这个波峰值作为这个波段的顶}
bb1:=trough(2,N,1); {向前数第一个波谷的值,括号中的2表示以最低价作为波谷。这里以这个波谷的值作为这个波段的底}
H1:=tt1-(tt1-bb1)*0.1; {设定波段从顶部落下来时,落下的幅度位置,H1是落下10%的位置。以下依此类推}
H2:=tt1-(tt1-bb1)*0.2;
H3:=tt1-(tt1-bb1)*0.3;
H4:=tt1-(tt1-bb1)*0.4;
H5:=tt1-(tt1-bb1)*0.5;
H6:=tt1-(tt1-bb1)*0.6;
H7:=tt1-(tt1-bb1)*0.7;
H8:=tt1-(tt1-bb1)*0.8;
H9:=tt1-(tt1-bb1)*0.9;
H10:=tt1-(tt1-bb1)*1.0;
H11:=tt1-(tt1-bb1)*1.1;
H12:=tt1-(tt1-bb1)*1.2;
H13:=tt1-(tt1-bb1)*1.3;
H14:=tt1-(tt1-bb1)*1.4;
H15:=tt1-(tt1-bb1)*1.5;
L1:=bb1+(tt1-bb1)*0.1; {设定波段从底部涨上去时,上涨的幅度位置,L1是上涨10%的位置。以下依此类推}
L2:=bb1+(tt1-bb1)*0.2;
L3:=bb1+(tt1-bb1)*0.3;
L4:=bb1+(tt1-bb1)*0.4;
L5:=bb1+(tt1-bb1)*0.5;
L6:=bb1+(tt1-bb1)*0.6;
L7:=bb1+(tt1-bb1)*0.7;
L8:=bb1+(tt1-bb1)*0.8;
L9:=bb1+(tt1-bb1)*0.9;
L10:=bb1+(tt1-bb1)*1.0;
L11:=bb1+(tt1-bb1)*1.1;
L12:=bb1+(tt1-bb1)*1.2;
L13:=bb1+(tt1-bb1)*1.3;
L14:=bb1+(tt1-bb1)*1.4;
L15:=bb1+(tt1-bb1)*1.5;
stickline(a3>0,tt1,tt1,8,0),linethick2,colorred; {画波段顶}
stickline(a2>0,bb1,bb1,8,0),linethick2,colorred; {画波段底}
stickline(a3>0,H1,H1,8,0),linethick0,colorFF99CC; {波段下跌,在H1位置画"—"线(图)。以下类推。}
stickline(a3>0,H2,H2,8,0),linethick0,colorFF99CC; {接上行:因为没有在主图画水平线的函数,所以用一系列的“-”来画出水平线}
stickline(a3>0,H3,H3,8,0),linethick0,colorFF99CC;
stickline(a3>0,H4,H4,8,0),linethick0,colorFF99CC;
stickline(a3>0,H5,H5,8,0),linethick0,colorFF99CC;
stickline(a3>0,H6,H6,8,0),linethick0,colorFF99CC;
stickline(a3>0,H7,H7,8,0),linethick0,colorFF99CC;
stickline(a3>0,H8,H8,8,0),linethick0,colorFF99CC;
stickline(a3>0,H9,H9,8,0),linethick0,colorFF99CC;
stickline(a3>0,H10,H10,8,0),linethick0,colorFF99CC;
stickline(a3>0,H11,H11,8,0),linethick0,colorFF99CC;
stickline(a3>0,H12,H12,8,0),linethick0,colorFF99CC;
stickline(a3>0,H13,H13,8,0),linethick0,colorFF99CC;
stickline(a3>0,H14,H14,8,0),linethick0,colorFF99CC;
stickline(a3>0,H15,H15,8,0),linethick0,colorFF99CC;
drawtext(a3=1,H1,’10%’),linethick0,colorFF99CC; {波段下跌,在H1*0.95位置标记"10%"。以下类推。}
drawtext(a3=1,H2,’20%’),linethick0,colorFF99CC; {接上行:在波段下跌第一天处,标注幅度值,看起来一目了然}
drawtext(a3=1,H3,’30%’),linethick0,colorFF99CC;
drawtext(a3=1,H4,’40%’),linethick0,colorFF99CC;
drawtext(a3=1,H5,’50%’),linethick0,colorFF99CC;
drawtext(a3=1,H6,’60%’),linethick0,colorFF99CC;
drawtext(a3=1,H7,’70%’),linethick0,colorFF99CC;
drawtext(a3=1,H8,’80%’),linethick0,colorFF99CC;
drawtext(a3=1,H9,’90%’),linethick0,colorFF99CC;
drawtext(a3=1,H10,’100%’),linethick0,colorFF99CC;
drawtext(a3=1,H11,’110%’),linethick0,colorFF99CC;
drawtext(a3=1,H12,’120%’),linethick0,colorFF99CC;
drawtext(a3=1,H13,’130%’),linethick0,colorFF99CC;
drawtext(a3=1,H14,’140%’),linethick0,colorFF99CC;
drawtext(a3=1,H15,’150%’),linethick0,colorFF99CC;
stickline(a2>0,L1,L1,8,0),linethick0,colorFF99CC; {波段上涨,在L1位置画"—"线(图)。以下类推。}
stickline(a2>0,L2,L2,8,0),linethick0,colorFF99CC;
stickline(a2>0,L3,L3,8,0),linethick0,colorFF99CC;
stickline(a2>0,L4,L4,8,0),linethick0,colorFF99CC;
stickline(a2>0,L5,L5,8,0),linethick0,colorFF99CC;
stickline(a2>0,L6,L6,8,0),linethick0,colorFF99CC;
stickline(a2>0,L7,L7,8,0),linethick0,colorFF99CC;
stickline(a2>0,L8,L8,8,0),linethick0,colorFF99CC;
stickline(a2>0,L9,L9,8,0),linethick0,colorFF99CC;
stickline(a2>0,L10,L10,8,0),linethick0,colorFF99CC;
stickline(a2>0,L11,L11,8,0),linethick0,colorFF99CC;
stickline(a2>0,L12,L12,8,0),linethick0,colorFF99CC;
stickline(a2>0,L13,L13,8,0),linethick0,colorFF99CC;
stickline(a2>0,L14,L14,8,0),linethick0,colorFF99CC;
stickline(a2>0,L15,L15,8,0),linethick0,colorFF99CC;
drawtext(a2=1,L1*1.015,’10%’),linethick0,colorFF99CC; {波段上涨,在L1*1.05位置标记"10%"。以下类推。}
drawtext(a2=1,L2*1.015,’20%’),linethick0,colorFF99CC; {接上行:在波段上涨第一天处,标注幅度值,看起来一目了然}
drawtext(a2=1,L3*1.015,’30%’),linethick0,colorFF99CC;
drawtext(a2=1,L4*1.015,’40%’),linethick0,colorFF99CC;
drawtext(a2=1,L5*1.015,’50%’),linethick0,colorFF99CC;
drawtext(a2=1,L6*1.015,’60%’),linethick0,colorFF99CC;
drawtext(a2=1,L7*1.015,’70%’),linethick0,colorFF99CC;
drawtext(a2=1,L8*1.015,’80%’),linethick0,colorFF99CC;
drawtext(a2=1,L9*1.015,’90%’),linethick0,colorFF99CC;
drawtext(a2=1,L10*1.015,’100%’),linethick0,colorFF99CC;
drawtext(a2=1,L11*1.015,’110%’),linethick0,colorFF99CC;
drawtext(a2=1,L12*1.015,’120%’),linethick0,colorFF99CC;
drawtext(a2=1,L13*1.015,’130%’),linethick0,colorFF99CC;
drawtext(a2=1,L14*1.015,’140%’),linethick0,colorFF99CC;
drawtext(a2=1,L15*1.015,’150%’),linethick0,colorFF99CC;
drawtext(a2=1,bb1*0.995,’下跌’+barslast(a3=1)+’周期’),coloryellow; {波段上涨开始,在底部标记"前一波下跌"的周期数}
drawtext(a3=1,tt1*1.030,’上涨’+barslast(a2=1)+’周期’),coloryellow; {波段下跌开始,在顶部标记"前一波上涨"的周期数}

大智慧股票涨跌概率指标公式

{m:5,100,60}
B:=c>ref(c,1);
D:=c=ref(c,1);
E:=c<ref(c,1);
F:=count(B,M)+count(D,M)+count(E,M);
上升概率:100*count(B,M)/F;
下跌概率:100*count(E,M)/F;
平盘概率:100*count(D,M)/F;
v1:=(c-LLV(L,9))/(HHV(H,15)-LLV(L,9))*100;
v2:=sma(v1,3,1);
v3:=sma(v2,3,1);
A1:IF(c/ma(c,3)>=1.05 and ma(AMOUNT,3)/ma(AMOUNT,20)>1.5 and count(V3<20,20)>=1,100,0);

大智慧股票涨跌概率指标公式

 

大智慧买卖指标公式

VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B:ZIG(3,50/5)*100,COLORWHITE;
G:MA(B,2),COLORYELLOW;
D:=CROSS(B,G)*1000,COLORRED;
W:=CROSS(G,B)*1000,COLORBLUE;
E:=REF(INDEXC,1);
F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);
VAR10:=F AND F<8;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
MM:=A AND D AND VAR10 AND VAR14 ;
DRAWTEXT(W=1000,B*1.05,’卖’ ),COLOR00FF00;
DRAWTEXT(D=1000,B*1.05,’买’),COLORRED;

大智慧买卖指标公式

 

大智慧成交量跑道指标公式

var0:=eMA(vol,20);{√}
var1:= var0 + 2*STD(vol,10);
var2:=var0 – 2*STD(vol,10);
{MID:STICKLINE( var0>ref( var0,1) , var0 ,ref( var0,1) ,8 ,0 ),coloryellow;}
UPPER:STICKLINE(var1>ref(var1,1) ,var1 ,ref(var1,1) ,8 ,0 ),colorred;
LOWER:STICKLINE(var2>ref(var2,1) ,var2 ,ref(var2,1) ,8 , 0),colorred;
{STICKLINE( var0<ref( var0,1) , var0 ,ref( var0,1) ,8 ,0 ),colorwhite;}
STICKLINE(var1<ref(var1,1) ,var1 ,ref(var1,1) ,8 ,0),COLORWHITE;
STICKLINE(var2<ref(var2,1) ,var2 ,ref(var2,1) ,8 , 0),COLORWHITE;;
Vara1:=vol;
C1: (EMA(Vara1,2)+EMA(Vara1,5)+EMA(Vara1,8))/3,LINETHICK2, COLORYELLOW;
C2: (EMA(Vara1,3)+EMA(Vara1,6)+EMA(Vara1,9))/3,color00CC33;
C3: (EMA(Vara1,4)+EMA(Vara1,7)+EMA(Vara1,10))/3,color00CC33;
C4: (EMA(Vara1,5)+EMA(Vara1,8)+EMA(Vara1,11))/3,color00CC33;
C5: (EMA(Vara1,6)+EMA(Vara1,9)+EMA(Vara1,12))/3,color00CC33;
C6: (EMA(Vara1,7)+EMA(Vara1,10)+EMA(Vara1,13))/3,color00CC33;
C7: (EMA(Vara1,8)+EMA(Vara1,11)+EMA(Vara1,14))/3,color00CC33;
C8: (EMA(Vara1,9)+EMA(Vara1,12)+EMA(Vara1,15))/3,color00CC33;
C9: (EMA(Vara1,10)+EMA(Vara1,13)+EMA(Vara1,16))/3,color00CC33;
C10: (EMA(Vara1,11)+EMA(Vara1,14)+EMA(Vara1,17))/3,color00CC33;
C11: (EMA(Vara1,12)+EMA(Vara1,15)+EMA(Vara1,18))/3,color00CC33;
C12: (EMA(Vara1,13)+EMA(Vara1,16)+EMA(Vara1,19))/3,color00CC33;
C13: (EMA(Vara1,14)+EMA(Vara1,17)+EMA(Vara1,20))/3,color00CC33;
C14: (EMA(Vara1,15)+EMA(Vara1,18)+EMA(Vara1,21))/3,color00CC33;
C15: (EMA(Vara1,16)+EMA(Vara1,19)+EMA(Vara1,22))/3,color00CC33;
C16: (EMA(Vara1,17)+EMA(Vara1,20)+EMA(Vara1,23))/3,color00CC33;
C17: (EMA(Vara1,18)+EMA(Vara1,21)+EMA(Vara1,24))/3,color00CC33;
C18: (EMA(Vara1,19)+EMA(Vara1,22)+EMA(Vara1,25))/3,color00CC33;
C19: (EMA(Vara1,20)+EMA(Vara1,23)+EMA(Vara1,26))/3,LINETHICK3, COLOR0099ff;
C20: (EMA(Vara1,21)+EMA(Vara1,24)+EMA(Vara1,27))/3,color00CC33;
C21: (EMA(Vara1,22)+EMA(Vara1,25)+EMA(Vara1,28))/3,color00CC33;
C22: (EMA(Vara1,23)+EMA(Vara1,26)+EMA(Vara1,29))/3,color00CC33;
C23: (EMA(Vara1,24)+EMA(Vara1,27)+EMA(Vara1,30))/3,color00CC33;
C24: (EMA(Vara1,25)+EMA(Vara1,28)+EMA(Vara1,31))/3,color00CC33;
C25: (EMA(Vara1,26)+EMA(Vara1,29)+EMA(Vara1,32))/3,color00CC33;
C26: (EMA(Vara1,27)+EMA(Vara1,30)+EMA(Vara1,33))/3,color00CC33;
C27: (EMA(Vara1,28)+EMA(Vara1,31)+EMA(Vara1,34))/3,color00CC33;
C28: (EMA(Vara1,29)+EMA(Vara1,32)+EMA(Vara1,35))/3,color00CC33;
C29: (EMA(Vara1,30)+EMA(Vara1,33)+EMA(Vara1,36))/3,color00CC33;
C30: (EMA(Vara1,31)+EMA(Vara1,34)+EMA(Vara1,37))/3,color00CC33;
C31: (EMA(Vara1,32)+EMA(Vara1,35)+EMA(Vara1,38))/3,color00CC33;
C32: (EMA(Vara1,33)+EMA(Vara1,36)+EMA(Vara1,39))/3,color00CC33;
C33: (EMA(Vara1,34)+EMA(Vara1,37)+EMA(Vara1,40))/3,color00CC33;
C34: (EMA(Vara1,35)+EMA(Vara1,38)+EMA(Vara1,41))/3,color00CC33;
C35: (EMA(Vara1,36)+EMA(Vara1,39)+EMA(Vara1,42))/3,color00CC33;
C36: (EMA(Vara1,37)+EMA(Vara1,40)+EMA(Vara1,43))/3,color00CC33;
C37: (EMA(Vara1,38)+EMA(Vara1,41)+EMA(Vara1,44))/3,color00CC33;
C38: (EMA(Vara1,39)+EMA(Vara1,42)+EMA(Vara1,45))/3,color00CC33;
C39: (EMA(Vara1,40)+EMA(Vara1,43)+EMA(Vara1,46))/3,LINETHICK2, COLORBLUE;

大智慧成交量跑道指标公式

 

大智慧趋势选股指标公式

VAR1:=EMA(CLOSE,N1)-EMA(CLOSE,N2);
VAR2:=EMA(VAR1,N3);
VAR3:2*(VAR1-VAR2);
STICKLINE(VAR3,0,VAR3,4,1),COLORYELLOW;
STICKLINE(VAR3>=ref(VAR3,1)and VAR3>0,0,VAR3,4,1),COLORRED;
STICKLINE(VAR3>ref(VAR3,1)and VAR3<0,0,VAR3,4,1),COLORFFC8FF;
STICKLINE(VAR3<=ref(VAR3,1)and VAR3<0,0,VAR3,4,1),COLORFFCC66;
趋势一:EMA(CLOSE,N4)-EMA(CLOSE,N5),COLORWHITE;
趋势二:EMA(VAR1,N5),COLORYELLOW;
红色:VAR3>=ref(VAR3,1)and VAR3>0,PRECIS0,COLOR0000FF,linethick0;
白色:VAR3>ref(VAR3,1)and VAR3<0,PRECIS0,COLOR0000FF,linethick0;
绿色:VAR3<=ref(VAR3,1)and VAR3<0,PRECIS0,COLOR0000FF,linethick0;
黄色:VAR3<=ref(VAR3,1)and VAR3>0,PRECIS0,COLOR0000FF,linethick0;
向上:VAR3>ref(VAR3,1),PRECIS0,COLOR0000FF,linethick0;
连续飘红:LAST(红色>0),PRECIS0,COLOR0000FF,linethick0;
十日飘红:COUNT(红色>0,10),PRECIS0,COLOR33CCFF,linethick0;

大智慧趋势选股指标公式
大智慧趋势选股指标公式

 

大智慧数字主图指标公式

数字主图 加明日价格预测 加明日模拟K线

预测1:=(C+H+L)/3;
预测2:=H-L;
预测4:=预测1+预测2;
预测5:=预测1-预测2;
预测6:=2*预测1-L;
预测7:=2*预测1-H;
预测9:=BARSTATUS=2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测4,预测5,1,1000),COLOR102070,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测4,预测5,0,1000),COLOR1020E0,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,8,1000),COLOR102070,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,7,1000),COLOR102080,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,6,1000),COLOR102090,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,5,1000),COLOR1020A0,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,4,1000),COLOR1020B0,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,3,1000),COLOR1020C0,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,2,1000),COLOR1020D0,LINETHICK2;
STICKLINE(预测9>0 AND 预测6>REF(C,1),预测6,预测7,1,1000),COLOR1020E0,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测4,预测5,1,1000),COLOR105510,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测4,预测5,0,1000),COLOR10CC10,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,8,1000),COLOR105510,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,7,1000),COLOR106610,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,6,1000),COLOR107710,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,5,1000),COLOR108810,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,4,1000),COLOR109910,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,3,1000),COLOR10AA10,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,2,1000),COLOR10BB10,LINETHICK2;
STICKLINE(预测9>0 AND 预测6<=REF(C,1),预测6,预测7,1,1000),COLOR10CC10,LINETHICK2;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力, 1);
今日支撑:=REF(明日支撑, 1);
STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Color0000FF;
STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Color00FF00;
STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),ColorFF00FF;
STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),ColorFF0000;
DRAWTEXTREL(406,117,’—————————————‘),ColorFFFFFF;
IF BARSTATUS=2 and c>=今日支撑 THEN
DRAWTEXTREL(408,147,’今日支撑:’+NUMTOSTRN(今日支撑,2)),colorred;
IF BARSTATUS=2 and c<今日支撑 THEN
DRAWTEXTREL(408,147,’今日支撑:’+NUMTOSTRN(今日支撑,2)),colorred;
IF BARSTATUS=2 and c>=今日阻力 THEN
DRAWTEXTREL(408,187,’今日阻力:’+NUMTOSTRN(今日阻力,2)),Color0000FF;
IF BARSTATUS=2 and c<今日阻力 THEN
DRAWTEXTREL(408,187,’今日阻力:’+NUMTOSTRN(今日阻力,2)),Color00FF00;
IF BARSTATUS=2 and c>=明日支撑 THEN
DRAWTEXTREL(510,147,’ 明日支撑:’+NUMTOSTRN(明日支撑,2)),Color00FFFF;
IF BARSTATUS=2 and c<明日阻力 THEN
DRAWTEXTREL(510,187,’ 明日阻力:’+NUMTOSTRN(明日阻力,2)),Color00FFFF;
DRAWTEXTREL(406,217,’====================’),ColorFFFFFF;
下档线:=(((CLOSE – LLV(LOW,13))/(HHV(HIGH,13) – LLV(LOW,13))) * 100);
aRSV:=SMA(下档线,3,1);
aK:=SMA(aRSV,3,1);
aD:=((3 * aRSV) – (2 * aK));
aJ12:=(((CLOSE – LLV(LOW,55))/(HHV(HIGH,55) – LLV(LOW,55))) * 100);
aRSV24:=SMA(aJ12,3,1);
aK24:=SMA(aRSV24,3,1);
aD24:=((3 * aRSV24) – (2 * aK24));
撑压位:=IF(CROSS(aD24,aD),HIGH,REF(HIGH,BARSLAST(CROSS(aD24,aD))));
底:=LLV(HIGH,30){,COLOR00FF00,LINETHICK2};
STICKLINE(BARSTATUS=2,撑压位,撑压位,30,1),LINETHICK1,COLORFFFFFF;
DRAWTEXT(BARSTATUS=2,撑压位,’撑压’),COLORFFFFFF,VALIGN1;
STICKLINE(BARSTATUS=2,底,底,30,1),COLOR00FF00,LINETHICK1;
DRAWTEXT(BARSTATUS=2,底,’底线’),COLOR00FF00,VALIGN0;
AA05:MA(C,5),colorff00ff,linethick1;
五日乖离率:=(c-AA05)/AA05*100;
BB05:=atan((aa05/ref(aa05,1)-1)*100)*180/3.1416;
速度5:=sma(ema((AA05-ref(AA05,1))/ref(AA05,1),3)*100,3,1);
加速度5:ema((速度5-ref(速度5,1)),3),linethick0;
{STICKLINE(BB05>30 and AA05>ref(AA05,1),AA05,REF(AA05,1),8,1),colorff00ff;}
AA10:MA(C,10),coloryellow;
AA20:=MA(c,20);
BB10:=atan((aa10/ref(aa10,1)-1)*100)*180/3.1416;
{STICKLINE(BB05<0 and AA05<ref(AA05,1),AA05,REF(AA05,1),3,1),colorcyan;}
AA30:MA(C,30),colorwhite;
三拾日乖离率:(c-AA30)/AA30*100,linethick0;
Var1:=(AA20-AA30)>ref((AA20-AA30),1) and AA20>ref(aa20,1) and AA30>ref(AA30,1);
Var2:=(AA30-AA20)<ref((AA30-AA20),1) and AA20<ref(aa20,1) and AA30<ref(AA30,1);
BB30:=atan((aa30/ref(aa30,1)-1)*100)*180/3.1416;
{STICKLINE(BB30>15 and AA30>ref(AA30,1),AA30,REF(AA30,1),8,1),colorff00ff;}
强势狙击:=filter(BB30>30 and BB10>45 and cross(BB05,60),10);
加仓:=filter(count(cross(BB05,30),5)>=1 and AA05>ref(aa05,1) and 三拾日乖离率>ref(三拾日乖离率,1) and AA10>ref(AA10,1)
and 加速度5>ref(加速度5,1) and 速度5>ref(速度5,1),10) ;
清仓:=filter(count(cross(30,BB05),5)>=1 and (c>AA30 or O>AA30) and AA05<ref(aa05,1) and 三拾日乖离率<ref(三拾日乖离率,1) and AA10<ref(AA10,1),10);
drawtext(加仓,low*0.98,’←加仓’),colorred;
JC:=cross(0,五日乖离率) and 三拾日乖离率<ref(三拾日乖离率,1) and AA10>ref(AA10,1) ;
减仓:=filter(JC,10);
MR:=count(cross(五日乖离率,0),3)>=1 and 三拾日乖离率>ref(三拾日乖离率,1) and AA05>ref(AA05,1) and (c/ref(c,1)-1)*100>5 and ref(c,1)<AA30;
买入:=filter(MR,10);
drawtext(减仓,high*1.02,’←减仓’),colorcyan;
drawtext(买入,low*0.98,’←买入’),coloryellow;
drawtext(强势狙击,LOW*0.98,’←强势狙击’),coloryellow;
Var21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
Var3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(Var21+Var3)/AMOUNT*VOL*100*50;
DRAWTEXT(MV>6 and l<=llv(l,10),l*0.96,’←异动’),colorcyan;
aa:=if(c>=ref(c,3),1,0);
bb:=if(c>=ref(c,5),1,0);
cc:=if(c>=ref(c,7),1,0);
dd:=if(c>=ref(c,8),1,0);
ee:=if(c>=ref(c,13),1,0);
ff:=if(c>=ref(c,21),1,0);
gz2:=aa+bb+cc+dd+ee+ff;
Var11:=EMA(CLOSE,3)-EMA(CLOSE,6)-(EMA(CLOSE,6)-EMA(CLOSE,12))*(-100);
Var12:=EMA(Var11,3);
Var5:=CROSS(Var11,Var12);
Var6:=CROSS(Var12,Var11);
STICKLINE(C>=O,l,H,0,0),COLOR0000FF,LAYER2;
STICKLINE(C<O,l,H,0,0),COLORFFFF00,LAYER2;
STICKLINE(C>=O,O,C,10,1),COLOR0000FF,LAYER2;
STICKLINE(C<O,O,C,8,0),COLORFFFF00,LAYER2;
STICKLINE(Var6,OPEN,CLOSE,8,0),COLORBLUE,LAYER0;{兰色熊K}
STICKLINE(Var5,OPEN,CLOSE,5,0),COLORYELLOW,LAYER0;{彩色牛K}
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.33,5,0),COLORaaccdd,LAYER0;{彩色牛 K}
STICKLINE(Var5,OPEN,CLOSE-(CLOSE-OPEN)*0.66,5,0),COLORRED,LAYER0;{彩色牛K}
DRAWTEXT(c>0,(O+C)/2,NUMTOSTRN(gz2,0 )),coloryellow,LAYER0,ALIGN1,VALIGN0,LINETHICK1;{彩色牛K};

大智慧数字主图指标公式

 

大智慧短线高手指标公式

A1:=REF(CLOSE,1);
A2:=((SMA((MAX((CLOSE – A1),0)),5,1)) / (SMA(ABS((CLOSE – A1)),5,1))) * 100;
A3:=SUM((MAX((MAX((HIGH – LOW),ABS((HIGH – A1)))),ABS((LOW – A1)))),10);
A4:=HIGH – (REF(HIGH,1));
A5:=(REF(LOW,1)) – LOW;
A6:=SUM((IF(((A4 > 0) AND (A4 > A5)),A4,0)),10);
A7:=SUM((IF(((A5 > 0) AND (A5 > A4)),A5,0)),10);
A8:=(A6 * 100) / A3;
A9:=(A7 * 100) / A3;
A10:=MA(((ABS((A9 – A8)) / (A9 + A8)) * 100),5);
A11:=A2 + A10;
A12:=((A10 + (REF(A10,5))) / 2) + A2;
A13:=(100 * ((HHV(HIGH,10)) – CLOSE)) / ((HHV(HIGH,10)) – (LLV(LOW,10)));
A14:=A2 – A13;
A15:=A11 + A14;
0,COLOR00FF00;
YXF:LLV(A15,1),LINETHICK2,COLORRED;
REVERSE(YXF),LINETHICK2,COLORRED;
STICKLINE((A15 < 0),0,A15,0.8,1),LINETHICK2,COLORRED;
STICKLINE((REVERSE(A15) >= 0),0,REVERSE(A15),0.3,1),LINETHICK2,COLORRED;
FXY:IF((YXF < 0),0,YXF),LINETHICK2,COLORYELLOW;
REVERSE(FXY),LINETHICK2,COLORWHITE;

大智慧短线高手指标公式

 

大智慧大资金介入指标公式

参数为: N1 5  N2 21

Var1:=SMA(AMOUNT,10,1)/100000;
Var2:=MA(REF(CLOSE,1),5);
收盘:=Var1*CLOSE/Var2/10;
C0:=INTPART(收盘);
B1:=REF(C0,1);B2:=REF(C0,2);B3:=REF(C0,3);B4:=REF(C0,4);B5:=REF(C0,5);B6:=REF(C0,6);B7:=REF(C0,7);
B8:=REF(C0,8);B9:=REF(C0,9);B10:=REF(C0,10);B11:=REF(C0,11);B12:=REF(C0,12);B13:=REF(C0,13);B14:=REF(C0,14);
B15:=REF(C0,15);B16:=REF(C0,16);B17:=REF(C0,17);B18:=REF(C0,18);B19:=REF(C0,19);B20:=REF(C0,20);
B21:=REF(C0,21);B22:=REF(C0,22);B23:=REF(C0,23);B24:=REF(C0,24);B25:=REF(C0,25);B26:=REF(C0,26);
B27:=REF(C0,27);B28:=REF(C0,28);B29:=REF(C0,29);B30:=REF(C0,30);B31:=REF(C0,31);B32:=REF(C0,32);
B33:=REF(C0,33);B34:=REF(C0,34);B35:=REF(C0,35);B36:=REF(C0,36);B37:=REF(C0,37);B38:=REF(C0,38);
B39:=REF(C0,39);B40:=REF(C0,40);B41:=REF(C0,41);B42:=REF(C0,42);B43:=REF(C0,43);B44:=REF(C0,44);
B45:=REF(C0,45);B46:=REF(C0,46);B47:=REF(C0,47);B48:=REF(C0,48);B49:=REF(C0,49);B50:=REF(C0,50);
HL:=IF(C0>B1 AND B1>=B2,1,IF(C0<B1 AND B1<=B2,-1,IF(C0>B2 AND B2>B1,2,IF(C0<B2 AND B2<B1,-2,0))));
HG:=IF(B1>B2 AND B1>B3,1,IF(B1<B2 AND B1<B3,-1,IF(B2>B3 AND B2>B4,2,IF(B2<B3 AND B2<B4,-2,
IF(B3>B4 AND B3>B5,3,IF(B3<B4 AND B3<B5,-3,IF(B4>B5 AND B4>B6,4,IF(B4<B5 AND B4<B6,-4,
IF(B5>B6 AND B5>B7,5,IF(B5<B6 AND B5<B7,-5,IF(B6>B7 AND B6>B8,6,IF(B6<B7 AND B6<B8,-6,
IF(B7>B8 AND B7>B9,7,IF(B7<B8 AND B7<B9,-7,IF(B8>B9 AND B8>B10,8,IF(B8<B9 AND B8<B10,-8,
IF(B9>B10 AND B9>B11,9,IF(B9<B10 AND B9<B11,-9,IF(B10>B11 AND B10>B12,10,IF(B10<B11 AND B10<B12,-10,
IF(B11>B12 AND B11>B13,11,IF(B11<B12 AND B11<B13,-11,IF(B12>B13 AND B12>B14,12,IF(B12<B13 AND B12<B14,-12,
IF(B13>B14 AND B13>B15,13,IF(B13<B14 AND B13<B15,-13,IF(B14>B15 AND B14>B16,14,IF(B14<B15 AND B14<B16,-14,
IF(B15>B16 AND B15>B17,15,IF(B15<B16 AND B15<B17,-15,IF(B16>B17 AND B16>B18,16,IF(B16<B17 AND B16<B18,-16,
IF(B17>B18 AND B17>B19,17,IF(B17<B18 AND B17<B19,-17,IF(B18>B19 AND B18>B20,18,IF(B18<B19 AND B18<B20,-18,
IF(B19>B20 AND B19>B21,19,IF(B19<B20 AND B19<B21,-19,IF(B20>B21 AND B20>B22,20,IF(B20<B21 AND B20<B22,-20,
IF(B21>B22 AND B21>B23,21,IF(B21<B22 AND B21<B23,-21,IF(B22>B23 AND B22>B24,22,IF(B22<B23 AND B22<B24,-22,
IF(B23>B24 AND B23>B25,23,IF(B23<B24 AND B23<B25,-23,IF(B24>B25 AND B24>B26,24,IF(B24<B25 AND B24<B26,-24,
IF(B25>B26 AND B25>B27,25,IF(B25<B26 AND B25<B27,-25,IF(B26>B27 AND B26>B28,26,IF(B26<B27 AND B26<B28,-26,
IF(B27>B28 AND B27>B29,27,IF(B27<B28 AND B27<B29,-27,IF(B28>B29 AND B28>B30,28,IF(B28<B29 AND B28<B30,-28,
IF(B29>B30 AND B29>B31,29,IF(B29<B30 AND B29<B31,-29,IF(B30>B31 AND B30>B32,30,IF(B30<B31 AND B30<B32,-30,
IF(B31>B32 AND B31>B33,31,IF(B31<B32 AND B31<B33,-31,IF(B32>B33 AND B32>B34,32,IF(B32<B33 AND B32<B34,-32,
IF(B33>B34 AND B33>B35,33,IF(B33<B34 AND B33<B35,-33,IF(B34>B35 AND B34>B36,34,IF(B34<B35 AND B34<B36,-34,
IF(B35>B36 AND B35>B37,35,IF(B35<B36 AND B35<B37,-35,IF(B36>B37 AND B36>B38,36,IF(B36<B37 AND B36<B38,-36,
IF(B37>B38 AND B37>B39,37,IF(B37<B38 AND B37<B39,-37,IF(B38>B39 AND B38>B40,38,IF(B38<B39 AND B38<B40,-38,
IF(B39>B40 AND B39>B41,39,IF(B39<B40 AND B39<B41,-39,IF(B40>B41 AND B40>B42,40,IF(B40<B41 AND B40<B42,-40,
IF(B41>B42 AND B41>B43,41,IF(B41<B42 AND B41<B43,-41,IF(B42>B43 AND B42>B44,42,IF(B42<B43 AND B42<B44,-42,
IF(B43>B44 AND B43>B45,43,IF(B43<B44 AND B43<B45,-43,IF(B44>B45 AND B44>B46,44,IF(B44<B45 AND B44<B46,-44,
IF(B45>B46 AND B45>B47,45,IF(B45<B46 AND B45<B47,-45,IF(B46>B47 AND B46>B48,46,IF(B46<B47 AND B46<B48,-46,
IF(B47>B48 AND B47>B49,47,IF(B47<B48 AND B47<B49,-47,IF(B48>B49 AND B48>B50,48,IF(B48<B49 AND B48<B50,-48,
0))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))));
开盘:=Var1*OPEN/Var2/10;
最高:=Var1*HIGH/Var2/10;
最低:=Var1*LOW/Var2/10;
昨收盘:=REF(收盘,1);
涨跌:=(收盘-REF(收盘,1))/REF(收盘,1)*100;
短生命线:EMA(收盘,n1);
长生命线:EMA(收盘,n2),COLORCYAN;
STICKLINE(HL=1 OR HG>=1 AND HL=0,B1,C0,7,1),COLORRED;
STICKLINE(HL=-1 OR HG<=-1 AND HL=0,B1,C0,7,0),COLORGREEN;
STICKLINE(HL=2,B2,C0,7,1),COLORRED;
STICKLINE(HL=-2,B2,C0,7,0),COLORGREEN;
STICKLINE((HL=-1 OR HL=-2) AND HG>0,B2,B1,7,1),COLORRED;
STICKLINE((HL=1 OR HL=2) AND HG<0,B2,B1,7,0),COLORGREEN;

大智慧大资金介入指标公式