大智慧主力入货指标公式

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
DRAWTEXTABS(5,5,’股旁网 www.gupang.com’),linethick1,COLOR00EEff;
VAR8:EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
STICKLINE(VAR8,0,VAR8,9,3),colorred;

大智慧主力入货指标公式

 

大智慧短线买入指标公式

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE – LC),0),5,1) / SMA(ABS((CLOSE – LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH – LOW),ABS((HIGH – REF(CLOSE,1)))),ABS((LOW – REF(CLOSE,1)))),10);
HD:=(HIGH – REF(HIGH,1));
LD:=(REF(LOW,1) – LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
DRAWTEXTABS(5,5,’股旁网 www.gupang.com’),linethick1,COLOR00EEff;
ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) – CLOSE)) / (HHV(HIGH,10) – LLV(LOW,10)));
NEWVOL:=(RSI5 – WR10);
阶段底部:=(AV + NEWVOL);
警戒:=阶段底部<0;
出击:CROSS(阶段底部,0);

大智慧短线买入指标公式

 

大智慧吸筹指标公式

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(VAR3*10,3);
VAR5:=LLV(LOW,13);
VAR6:=HHV(VAR4,13);
VAR7:=IF(barpos>34,1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
{股旁网股票公式网站 www.GupAng.com}
吸筹:VAR9,LINETHICK2,COLOREE00EE;
STICKLINE(VAR9>-120,0,VAR9,8,1),COLOR00FFFF;

大智慧吸筹指标公式

 

大智慧一品低吸主图指标公式

MA1:EMA(C,5),COLOR0000FF,linethick2;
MA2:REF(MA1,1),COLORFFFFFF;
ma3:EMA(ema(c,7),6),color00FFFF,linethick2;
FILLRGN(MA2,MA1,MA2<=MA1),COLORRED;
FILLRGN(MA1,MA2,MA1<=MA2),COLORGREEN;
FILLRGN(MA2,ma3,MA2<=ma3),COLORBLUE;
FILLRGN(MA2,ma3,MA2>=ma3),COLORFF00FF;
DRAWTEXTABS(5,5,’股旁网 www.gupang.com’),linethick1,COLOR00EEff;

大智慧一品低吸主图指标公式

 

大智慧四度解盘+缺口主图指标公式

INPUT:M(10,3,250,3);均线:(MA(CLOSE,M) * 1),Colorred,linethick2;早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
解盘:=’【解盘】’+
IFs(倾盆大雨,’★倾盆大雨,见顶信号;’,”)+
IFs(大阴烛,’★大阴烛,后市向淡,发生逆转;’,”)+
IFs(好友反攻,’★好友反攻,底部反转;’,”)+
IFs(跳空缺口,’★跳空缺口,注意向上还是向下跳空;’,”)+
IFs(光脚阴线,’★光脚阴线,下跌信号;’,”)+
IFs(光头阳线,’★光头阳线,后市看涨;’,”)+
IFs(三只乌鸦,’★三只乌鸦,可能见顶回落;’,”)+
IFs(分离,’★分离,注意看涨分离和看跌分离;’,”)+
IFs(长下影,’★长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;’,”)+
IFs(长上影,’★长上影,表明行情上档压力沉重,升势受阻;’,”)+
IFs(下跌三部曲,’★下跌三部曲,下跌信号;’,”)+
IFs(上升三部曲,’★上升三部曲,上涨信号;’,”)+
IFs(早晨之星,’★早晨之星,见底回升;’,”)+
IFs(黄昏之星,’★黄昏之星,见顶回落;’,”)+
IFs(十字星,’★十字星,有转向意味,注意股价位置在顶部还是底部;’,”)+
IFs(长十字,’★长十字,注意在顶部还是底部;’,”)+
IFs(垂死十字,’★垂死十字,下跌信号;’,”)+
IFs(早晨十字星,’★早晨十字星,上涨信号,见底回升;’,”)+
IFs(黄昏十字星,’★黄昏十字星,下跌信号,见顶回落;’,”)+
IFs(射击之星,’★射击之星,可能见顶回落,可靠性低;’,”)+
IFs(倒转锤头,’★倒转锤头,可能见底回升;’,”)+
IFs(锤头,’★锤头,可能见底回升,如有量配合,信号强烈;’,”)+
IFs(吊颈,’★吊颈,上升行情中见顶回落,顶部出现,见顶信号;’,”)+
IFs(平顶,’★平顶,温和的反转;’,”)+
IFs(穿头破脚,’★穿头破脚,顶部出现,见顶回落信号;’,”)+
IFs(乌云盖顶,’★乌云盖顶,见顶回落信号;’,”)+
IFs(曙光初现,’★曙光初现,后市见底回升;’,”)+
IFs(身怀六甲,’★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;’,”)+
IFs(十字胎,’★十字胎;’,”)+
IFs(平底,’★平底,温和的反转;’,”)+
IFs(大阳烛,’★大阳烛,看涨;’,”)+
IFs(三个白武士,’★三个白武士,每日收盘价上移,表示可能见底回升;’,”)+
IFs(双飞乌鸦,’★双飞乌鸦,行情将见顶回落;’,”)+
IFs(孕育线,’★孕育线,注意股价位置;’,”)+
IFs(多方炮,’★多方炮,在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;’,”)+
IFs(出水芙蓉,’★出水芙蓉,见底回升;’,”);
DRAWTEXTABS(0,0,解盘);
MA5:MA(C,5),COLORF00FF0;
MA21:MA(C,21),COLORE66878;
MA30:MA(C,30),COLORYELLOW; MA55:MA(CLOSE,55),LINETHICK1,ColorGREEN;
半年线:MA(C,120),COLOR399C7F,POINTDOT;
年线:MA(C,240),COLOR000999,POINTDOT;X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWICON(CROSS(X2,X3),L*0.98,7);
DRAWICON(CROSS(X3,X2),H*1.02,8);
DRAWGBKLAST(C>0,STRIP(RGB(10,10,50),RGB(50,10,10),0));
均价:=(3*C+H+L+O)/6;
VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+
4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;
SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;
SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;
SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND CLOSE>VAR2 AND CLOSE<VAR1;
SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)
AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1)
AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);;
SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;
XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)
AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);
XD2:=VAR1=VAR2 AND CLOSE>VAR1;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:=IF(SAT>1,1,SAT)*100;
IF BARSTATUS=2 AND SZ1 THEN BEGIN
DRAWTEXTABS(390,25,’调整结束短线介入’),LINETHICK2,COLORRED;
END
ELSE
IF BARSTATUS=2 AND SZ2 THEN BEGIN
DRAWTEXTABS(390,25,’上升通道走势良好’),LINETHICK2,COLORRED;
END
ELSE
IF BARSTATUS=2 AND SZ3 THEN BEGIN
DRAWTEXTABS(390,25,’股价偏离注意调整’),LINETHICK2,COLORRED;
END
ELSE
IF BARSTATUS=2 AND SZ4 THEN BEGIN
DRAWTEXTABS(390,25,’上升通道调整洗盘‘),LINETHICK2,COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND SZ5 THEN BEGIN
DRAWTEXTABS(390,25,’转向特征注意离场’),LINETHICK2,COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND SZ6 THEN BEGIN
DRAWTEXTABS(390,25,’通道改变坚决离场’),LINETHICK2,COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND XD1 THEN BEGIN
DRAWTEXTABS(390,25,’下跌通道只宜观望’),LINETHICK2,COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND XD2 THEN BEGIN
DRAWTEXTABS(390,25,’短期底部准备进入’),LINETHICK2,COLORYELLOW;
END;
;a:="LTFunc5@FORLT2";
s1:="LTFunc5@LT_S1";
hs:="LTFunc5@LT_HS";
ls:="LTFunc5@LT_LS";
p1:="LTFunc5@LT_P1";
upp:="LTFunc5@LT_UPP";
udd:="LTFunc5@LT_UDD";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
买入:p1=1 and ref(p1,1)=0,LineThick0,Precis0,ColorRed;
d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,’明日收盘价<‘+numtostrn(udd,2)+’,出现S点n’,’若明日收盘价>’+numtostrn(upp,2)+’,出现B点n’);
tr1:=ifs(s1=1,’明日收盘价<‘+numtostrn(ls,2)+’,短线卖出机会’,’若明日收盘价>’+numtostrn(hs,2)+’短线买入机会’);
tr2:=ifs(p1=1,ifs(cross(p1,0),’B点’,’持股‘),ifs(cross(1,p1),’S点’,’持币‘));
tr3:=ifs(s1=0,’向下,’,’向上,’);
tr4:=’3.能量级别:’+numtostrn(d3,1)+’级’;
bs:=”+datestr(date)+’买卖点决策系统提示n’+’1.BS点:’+tr2+’,’+tr0+’2.短线:’+tr3+tr1+’n’+tr4;
drawflagtext(1,fb,bs);
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;
drawbmp(p1=1 and ref(p1,1)=0,l,’buy1.bmp’),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,’sell1.bmp’),align1,valign2;
{股旁网股票公式网站 www.GupAng.com}
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,’bs.bmp’),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,’ss.bmp’),align1,valign2;闪:EMA(c+(h- l)*0.618,3),Color0099FF,LINETHICK0; 进:EMA((o+h+l)/3,4),COLORCYAN,LINETHICK0;
预测明日买点:=EMA((o+h+l)/3,4)+((h+l)/2-ref((o+h+l)/3,3))/4;
DRAWTEXTREL(800,950,’测今日低点:’+NUMTOSTRN(ref(预测明日买点,1),2 )),ColorGREEN;
预测明日卖点:=EMA(c+(h-l)*0.618,3)+(EMA(c+(h-l)*0.618,3)-进)*0.618;
DRAWTEXTREL(580,950,’测今日高点:’+NUMTOSTRN(ref(预测明日卖点,1),2 )),Colorred
;gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
I1:=0;
flag1:=0;
while I1<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)
DO
IF REF(H,I1)<REF(L,I1+1) AND REF(L,I1+1)>HHV(H,I1+1)
THEN BEGIN FLAG1:=1;
S1:=I1;
I1:=BARSLAST(DISPSTATUS=1);
END
ELSE I1:=I1+1;
STICKLINE(FLAG1,REF(L,S1+1),HHV(H,S1+1),(s1+1)*20,0),Color808080,ALIGN1,LAYER7;
DRAWTEXT(flag1,REF(L,s1+1),NUMTOSTRN(ref(l,s1+1),2)+’-‘+NUMTOSTRN(hhV(h,S1+1),2)),ALIGN2,COLORffffff,linethick2;
I:=0;
flag:=0;
while I<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)
DO
IF REF(L,I)>REF(H,I+1) AND REF(H,I+1)<LLV(LOW,I+1)
THEN BEGIN FLAG:=1;
S:=I;
I:=BARSLAST(DISPSTATUS=1);
END
ELSE I:=I+1;
STICKLINE(FLAG,REF(h,S+1),LLV(L,S+1),20*(s+1),500),Color808080,ALIGN1,LAYER7;
DRAWTEXT(FLAG,REF(H,s+1),NUMTOSTRN(ref(h,s+1),2)+’-‘+NUMTOSTRN(LLV(L,S+1),2)),
ALIGN2,COLORgreen,linethick2;

大智慧超级KD指标公式

n:=44;n1:=50;
RSV:=(C-LLV(L,23))/(HHV(H,23)-LLV(L,23))*100;
上:=SMA(SMA(RSV,3,1),3,1);
下:=EMA(上,5){,PRECIS2,ColorA9FFA9};
FILLRGN(上,下,上>=下),ColorF16FF1;
FILLRGN(上,下,上<=下),ColorA9FFA9{,Color00FF00};
⑥:=c>DMA(C,V/CAPITAL*34/100);
强区:IF(⑥,120,-20),PRECIS0,Color567A89;
R:=(C-LLV(L,45))/(HHV(H,45)-LLV(L,45))*100;
周K:SMA(R,15,5),PRECIS2,LINETHICK2,Color008900;
DRAWTEXTABS(5,5,’股旁网 www.gupang.com’),linethick1,COLOR00EEff;
RSVK:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;{kdj}
KK:=SMA(RSVK,3,1);
DK:=SMA(KK,3,1);
JK:=3*KK-2*DK;
顶:=JK<120 AND JK>98 AND JK>REF(JK,1);
DRAWTEXT(顶,104 ,’ !’),Color00FF00;
DRAWTEXT(FILTER(顶,10),100,’ 警惕’),ALIGN2,Color00FF00;
Vv1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;{kdj}
k:SMA(Vv1,3,1),PRECIS2,ColorEE00E2;
D:SMA(k,3,1),PRECIS2,Color00ECEE;
J:3*k-2*D,PRECIS2,Color0000FF;
角度:atan(j-ref(j,1))*180/3.1416,PRECIS2,LINETHICK0,ColorF5F6FF;
A:=(5-HHVBARS(H,5))/5*100;
B:=(5-LLVBARS(L,5))/5*100;
P:=(25-HHVBARS(H,25))/25*100;
Q:=(25-LLVBARS(L,25))/25*100;
卖:=ref(P,1)=ref(A,1) and ref(A,1)=100 and (A and P)<100 and Q<=n{40} and B<=n1{50};
高点:STICKLINE(卖>0,103,105,4,1),ColorFFFF00;
买:=ref(Q,1)=ref(B,1) and ref(B,1)=100 and (B and Q)<100 and P<=40 and A<=50;
低点:STICKLINE(买>0,-18,-22,4,1),Color0078FF;
100,PRECIS0,POINTDOT,ColorDDD6FF;
20,PRECIS0,POINTDOT,Color29A929;
-20,PRECIS0,POINTDOT,ColorFFFF00;
PARTLINE(J,J>ref(J,1),RGB(255,50,0),J<ref(J,1),RGB(55,55,255)),PRECIS2,ColorFFFFFF;

大智慧超级KD指标公式

 

大智慧多周期MACD叠加指标公式

DRAWGBKLAST(C,STRIP(RGB(40,100,100),RGB(100,80,60),0));
DIF_15F:="MACD.DIFF#MIN15";
DEA_15F:="MACD.DEA#MIN15";
MACD_15F:="MACD.MACD#MIN15";
DIF_30F:="MACD.DIFF#MIN30";
DEA_30F:="MACD.DEA#MIN30";
MACD_30F:="MACD.MACD#MIN30";
DIF_60F:="MACD.DIFF#MIN60";
DEA_60F:="MACD.DEA#MIN60";
MACD_60F:="MACD.MACD#MIN60";
DIF_R:="MACD.DIFF#DAY";
DEA_R:="MACD.DEA#DAY";
MACD_R:="MACD.MACD#DAY";
DP_MDF15:=STKINDI(‘SZ000001′,’MACD.MACD#MIN15’,26,12,9);
DP_MDF30:=STKINDI(‘SZ000001′,’MACD.MACD#MIN30’,26,12,9);
DP_MDF60:=STKINDI(‘SZ000001′,’MACD.MACD#MIN60’,26,12,9);
DP_MDR:=STKINDI(‘SZ000001′,’MACD.MACD#DAY’,26,12,9);
DPMACD:=STKINDI(‘SZ000001′,’MACD.MACD’,26,12,9);
DPDIF:=STKINDI(‘SZ000001′,’MACD.DIFF’,26,12,9);
DPDEA:=STKINDI(‘SZ0001′,’MACD.DEA’,26,12,9);
DIF:EMA(C,12)-EMA(C,26),COLOR0000FF,LINETHICK0;
DEA:EMA(DIF,9),COLORFFF000,LINETHICK0;
MACD:2*DIF-2*DEA, COLORSTICK;
小DIF1:IF(DATATYPE=7,DIF_15F,IF(DATATYPE=8,DIF_30F,IF(DATATYPE=9,DIF_60F,DIF))),LINETHICK0;
小DEA1:IF(DATATYPE=7,DEA_15F,IF(DATATYPE=8,DEA_30F,IF(DATATYPE=9,DEA_60F,DEA))),LINETHICK0;
小DPMD1:IF(DATATYPE=7,DP_MDF15,IF(DATATYPE=8,DP_MDF30,IF(DATATYPE=9,DP_MDF60,DPMACD))),LINETHICK0;

小DIF2:IF(DATATYPE=6,DIF_15F,IF(DATATYPE=7,DIF_30F,IF(DATATYPE=8,DIF_60F,IF(DATATYPE=9,DIF_R,DIF)))),LINETHICK0;
小DEA2:IF(DATATYPE=6,DEA_15F,IF(DATATYPE=7,DEA_30F,IF(DATATYPE=8,DEA_60F,IF(DATATYPE=9,DEA_R,DEA)))),LINETHICK0;
小DPMD2:IF(DATATYPE=6,DP_MDF15,IF(DATATYPE=7,DP_MDF30,IF(DATATYPE=8,DP_MDF60,IF(DATATYPE=9,DP_MDR,DPMACD)))),LINETHICK0;
FILLRGN(DIF,DEA,DIF>DEA),color330066;
FILLRGN(DIF,DEA,DIF<=DEA),COLORGRAY;
FILLRGN(小DIF2,小DEA2,C),colorAA1122;
FILLRGN(小DIF2,小DEA2,小DIF2<=小DEA2),COLOR002200;
DRAWTEXTABS(5,5,’股旁网 www.gupang.com’),linethick1,COLOR00EEff;
STICKLINE(MACD>0,-0,MACD,2.5,0),COLOR400055;
STICKLINE(MACD>0,-0,MACD,2,0),COLOR400066;
STICKLINE(MACD>0,-0,MACD,1.5,0),COLOR400077;
STICKLINE(MACD>0,-0,MACD,1,0),COLOR400088;
STICKLINE(MACD>0,-0,MACD,0.5,0),COLOR400099;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,-0,MACD,2.5,0),COLOR888888;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,-0,MACD,2,0),COLOR999999;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,-0,MACD,1.5,0),COLORAAAAAA;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,-0,MACD,1,0),COLORBBBBBB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,-0,MACD,0.5,0),COLORCCCCCC;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,-0,MACD,2.5,0),COLOR555500;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,-0,MACD,2,0),COLOR666600;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,-0,MACD,1.5,0),COLOR777700;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,-0,MACD,1,0),COLOR888800;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,-0,MACD,0.5,0),COLOR999900;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,-0,MACD,2.5,0),COLOR1155BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,-0,MACD,2,0),COLOR2266CC;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,-0,MACD,1.5,0),COLOR3377DD;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,-0,MACD,1,0),COLOR4488EE;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,-0,MACD,0.5,0),COLOR5599FF;
PARTLINE(DEA,1),COLORFFF000,LINETHICK1,LAYER0;
PARTLINE(DIF,1),COLORFFFFFF,LINETHICK1,LAYER0;
PARTLINE(DIF,DIF>REF(DIF,1)),COLORRED,LINETHICK1,LAYER0;
PARTLINE(0,DPMACD<0 AND DPDIF>REF(DPDIF,1)),COLORFFFFFF,LINETHICK2,LAYER0;
PARTLINE(0,DPMACD>0),COLOR00FFFF,LINETHICK2,LAYER0;
PARTLINE(0,DPMACD>0 AND DPDIF>REF(DPDIF,1)),COLOR0000FF,LINETHICK2,LAYER0;
PARTLINE(小DIF2,1),COLORAA1144,LINETHICK2,LAYER0;
PARTLINE(小DEA2,1),COLORFFF000,DOTLINE,LINETHICK1,LAYER0;
PARTLINE(小DEA2,1),COLORC050DD,CIRCLEDOT,LINETHICK2,LAYER0;
PARTLINE(小DEA2,小DPMD2>0),COLORGREEN,LINETHICK2,CIRCLEDOT,LAYER0;
PARTLINE(小DIF1,1),COLOR00FFFF,LAYER0;
PARTLINE(小DEA1,1),COLOR00FF00,LAYER0;
PARTLINE(小DEA1,小DPMD1>0),COLOR0000FF,LAYER0;

大智慧多周期MACD叠加指标公式

 

大智慧钱龙黄金眼指标公式

P:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),3);
风警值:P+100,linethick1;
风险区:90,colorred,linethick2;
安全区:10,colorgreen,linethick2;
DRAWTEXTABS(5,5,’股旁网 www.gupang.com’),linethick1,COLOR00EEff;
{注:95;5和90;10都可以,数值设小些,安全些,}
fillrgn(风警值,25,风警值<25,rgb(0,255,50));
fillrgn(风警值,安全区,风警值<安全区,rgb(255,0,0));
持股线:ma(风警值,10),linethick2,coloryellow;

大智慧钱龙黄金眼指标公式

 

大智慧暴涨买点指标公式

LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
卖点:CROSS(85,RSI1)*10,COLOR00FF00,LINETHICK2;
卖:IF(卖点,5,0),STICK,COLORGREEN,LINETHICK4;
洗钱A:=(CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE;
量1:=EMA(洗钱A,3);
量2:=EMA(洗钱A,5);
量3:=EMA(洗钱A,7);
STICKLINE(量1>量2,量3,量1,3,1),COLORRED;
STICKLINE(量1<量2,量3,量1,2,0),COLORCYAN;
T1:=量2>量3 AND 量1<REF(量1,1);
T2:=量2<量3 AND 量1>REF(量1,1);
{股旁网股票公式网站 www.GupAng.com}
STICKLINE(T1,量1,量3,2,0),COLORYELLOW;
STICKLINE(T2,量1,量3,3,1),COLORFF00FF;
洗钱B:=SMA(洗钱A,13,1);
分水岭:SMA(洗钱B,2.5,1.5),LINETHICK2,COLORWHITE;
牛线:3*洗钱B-2*分水岭,LINETHICK2,COLORFF00FF ;
熊线:4*分水岭-3*洗钱B,LINETHICK2,COLORFF6633;
TT:=CROSS(分水岭 ,熊线);
TY:=CROSS(牛线 ,分水岭);
黄金买点:IF((TT AND TY),5,0),coloryellow,LINETHICK2;
AA:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
GG:=ALL(AA>=-0.03,5);
SS:=ALL(AA<=0.03,5);
QQ:=IF((GG AND SS),1,0);
暴涨买点:IF((黄金买点 AND QQ),10,0),colorred,LINETHICK4;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
STICKLINE(VAR8,0,VAR8,10,15),color000999;
主力入货:(VAR8),color000999;

大智慧暴涨买点指标公式