大智慧所属板块+流通盘+市盈率主图指标公式

流通盘:=CAPITAL/100;
DRAWTEXTABS(0,10,BKNAME),COLORYELLOW;
DRAWTEXTABS(0,25,’流通盘:’+STR(流通盘)+’万股’),COLORYELLOW;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXTABS(150,25,’每股收益:’+STR(FINANCE2(3))),COLORYELLOW;
DRAWTEXTABS(280,25,’市盈率:’+STR(DYNAINFO(39))),COLORYELLOW;
DRAWTEXTABS(398,25,’市净率:’+STR(DYNAINFO(58))),COLORYELLOW;
DRAWTEXTABS(150,40,’每股净资产:’+STR(FINANCE2(4))),COLORYELLOW;
DRAWTEXTABS(280,40,’销售毛利率:’+STR(FINANCE2(12))),COLORYELLOW;
DRAWTEXTABS(398,40,’主营收入同比:’+STR(FINANCE2(11))),COLORYELLOW;
DRAWTEXTABS(0,40,’净利润同比:’+STR(FINANCE2(10))),COLORYELLOW;

大智慧所属板块+流通盘+市盈率主图指标公式

 

大智慧7日线加涨停板回调主图指标公式

MA7:EMA(CLOSE,7);
M7:EMA(CLOSE,7);
MID:MA(CLOSE,20);
上轨:MID+2*STD(CLOSE,20),DOTLINE;
下轨:MID-2*STD(CLOSE,20),DOTLINE;
g1:=BARSLAST(CLOSE/REF(CLOSE,1)>=1.099);
g2:=ref(c,g1);
g3:=ref(o,g1);
HORILINE(g2 and g1<13,g2,20),LINETHICK2,COLORYELLOW;
HORILINE(g3 and g1<13,g3,20),LINETHICK2,COLORYELLOW;
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
HH:=ref(COUNT(涨停,13)>=1,1);
STICKLINE(涨停 AND COUNT(涨停,13)>=1,c,o,4.5,0),COLORYELLOW;
DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,h*1.015,’涨’),COLORYELLOW,LINETHICK2;
DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,h*1.028,’停’),COLORYELLOW;
{www.gUPaNg.com 股旁网_最新股票指标公式}
V1:=v/ma(ref(v,1),5);V2:=indexv/ma(ref(indexv,1),5);v0:=v1/v2;
d4:=WINNER(c)*100;
s2:=WINNER(ref(c,1))*100;
d1:=o<ma7 and c>ma7 and EMA(CLOSE,17)>ref(EMA(CLOSE,17),1) and hh;
DRAWTEXT(d1>0,l*0.98,’启动’),COLORYELLOW;
f1:=(d4>s2+20 or (cross(d4,86) and ref(d4,1)<80)) and hh;
DRAWTEXT(f1>0 and c>ref(g2,1),l,’强势’),COLORYELLOW;
DIFF1:=EMA(INDEXC,12)-EMA(INDEXC,26);
DEA1 :=EMA(DIFF1,9);
MACD1:=2*(DIFF1-DEA1);
大盘:MACD1-REF(MACD1,1),LINETHICK0;
DRAWFLAGTEXT(大盘>0,l,’大盘稳健’),COLORYELLOW,LINETHICK5;
DRAWFLAGTEXT(大盘<0,l,’大盘风险’),DOTLINE,LINETHICK5;

大智慧7日线加涨停板回调主图指标公式

 

大智慧贵人相助指标公式

DIFF:=EMA(C,5)-EMA(C,20);DEA:=EMA(DIFF,10);
MACD:=500*(DIFF-DEA)/EMA(C,30);
STICKLINE(MACD>=0,0,MACD,5,0) ,COLORRED;
STICKLINE(MACD<=0,0,MACD,5,0) ;
VARE:=(REF(LOW,1))*(0.89999997);
VARF:=(LOW)*(0.89999997);
VAR10:=((VARF)*(VOL)+(VARE)*(CAPITAL-VOL))/(CAPITAL);
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=((SMA(VAR13,7,1))/(SMA(VAR14,7,1)))*(100);
VAR16:=((SMA(VAR13,13,1))/(SMA(VAR14,13,1)))*(100);
VAR17:=BARSCOUNT(CLOSE);
VAR18:=((SMA(MAX(VAR12,0),6,1))/(SMA(ABS(VAR12),6,1)))*(100);
VAR19:=(((-200))*(HHV(HIGH,60)-CLOSE))/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100);
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*(2),3,1);
VAR1C:=((INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14)))*(100);
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=((HHV(HIGH,30)-CLOSE)/(CLOSE))*(100);
VAR20:=(VAR18<=25) AND (VAR19<(-95)) AND (VAR1F>20) AND (VAR1B<(-30)) AND (VAR1E<30) AND (VAR11-
CLOSE>=(-0.25)) AND (VAR15<22) AND (VAR16<28) AND (VAR17>50);
A1:=CROSS(VAR20,0.5) AND (COUNT((VAR20=1),10)=1);
贵人出现:IF(A1,50,0),COLOR00FFFF,LINETHICK2;
贵人入门:IF(VAR20,40,0),COLORFFCC66,LINETHICK2;
VAR26:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR27:=REVERSE(VAR26);
VAR28:=SMA(VAR26,3,1);
快线:SMA(VAR28,3,1),COLOR0000FF;
慢线:SMA(快线,3,1),COLOR00FFFF;
IF(CROSS(快线,慢线) AND (快线>30),快线+10,慢线), COLORYELLOW,LINETHICK1;
短卖:IF(CROSS(慢线,快线) AND (慢线>75),85,100),COLOR008000,LINETHICK2;
DRAWTEXT(CROSS(慢线,快线) AND 快线>75,87,’顶天 ‘),COLORWHITE;
金叉买:IF(CROSS(快线,慢线) AND (快线<40),35,0),COLOR0099FF,LINETHICK2;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXT(CROSS(快线,慢线) AND 快线<30,25,’立地 ‘),COLORWHITE;
{STICKLINE(金叉买,0,20,8,0),COLORRED;
STICKLINE(金叉买,18,35,2,0),COLORRED; }
STICKLINE(快线>慢线,快线,慢线,4,0),COLORWHITE;
STICKLINE(快线<慢线,快线,慢线,4,0),COLOR00FF00;
VARA:=IF(REF(L,1)<=LLV(L,120) AND HHV(C,120)/LLV(C,120)>1.25 AND C>O AND HIGH>LOW+0.04,4,0);
贵人相助:IF(VARA>0,40,0);
STICKLINE(贵人相助,40,0,4,0),COLORFF00FF;
V1:=AMOUNT/VOL/100;
V2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
V3:=SUM(AMOUNT,7)/V1/100;
V4:=DMA(V2,VOL/V3);
V5:=(CLOSE-V4)/V4*100;
V6:=MA(V5,20)+STD(V5,20);
BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(V6,V5) AND REF("KDJ.J"(34,3,3),1)>80 AND REF("KDJ.J"(9,3,3),1)>80,90,85,6,0),COLOR00FF00;

大智慧贵人相助指标公式

 

大智慧散庄战神主图指标公式

DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.97,’←机构进场’) ,
LINETHICK2,COLOR00FFFF;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.99,1);
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),H,2);
{www.gUPaNg.com 股旁网_最新股票指标公式}
AZ6:=(3 * (SMA((((CLOSE – (LLV(LOW,27))) /
((HHV(HIGH,27)) – (LLV(LOW,27)))) * 100),5,1))) – (2 * (SMA((SMA((((CLOSE –
(LLV(LOW,27))) / ((HHV(HIGH,27)) – (LLV(LOW,27)))) * 100),5,1)),3,1)));
B7:=(10);
DRAWTEXT(CROSS(AZ6,B7),L,’←底’),COLOR0000FF;
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
VARD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND
(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3));
DRAWTEXT((VARC=1),L,’←买’),COLOR0000FF;
DRAWTEXT((VARD=1),H,’←卖’),COLOR00FF00;

大智慧散庄战神主图指标公式

 

大智慧庄线走势指标公式

A01:=DYNAINFO( 7.000);
A02:=MA(AMOUNT / VOL / 100.000,VOL / CAPITAL);
A03:=BARSCOUNT(CLOSE);
A04:=SMA(CLOSE / HHV(HIGH, 120.000), 3.000, 1.000) * 100.000;
A05:=IF((A03 > 20.000),A04,0);
A06:=IF(((LOW > A01)),0,IF(((HIGH < A01)), 1.000,((A01 – LOW) + 0.009) / ((HIGH – LOW) + 0.009)));
A07:=DMA(A06,VOL / CAPITAL) * 100.000;
A08:=IF((A02 > A01),( 100.000 – A07),A07);
A09:=IF(((((A07 > 0) and (A07 > REF(A07, 1.000)))) and (A05 <= 88.000)),A07,0);
stickline((A09 > 0),0,A09,7,0),Colorblue;
庄家建仓区:IF(((CROSS(A09,0) and (OPEN <> LOW)) and (CLOSE <> LOW)), 88.000,0),Colorblue, LINETHICK0;
庄家走势线:A09,COLORwhite,LINETHICK1;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWICON(CROSS(A09, 0.009), 24.000, 1.000);
ww:=WINNER(low);
Var1aa:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
SS:=SMA(Var1aa,5,1);
Var2a:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
XX:=SMA(Var2a,2,1);
BBa:=MA(VOL/CAPITAL,30)*MA(VOL,60)/10000+MA(CLOSE,30)*8;
B1:=20;
BB1:=MA(VOL/CAPITAL,30)*MA(VOL,60)/10000+MA(CLOSE,30);
aa:=winner(c+c*15/100)*100;
bb:=winner(c+c*0/100)*100;
cc:=aa-bb;
dd:=(winner(c-c*0.1/100)-winner(c-c*15/100))*100;
ee:=cc<3 and dd<0.5 and o<>l;
a1:=dynainfo(6);
a2:=if(l>a1,0,if(h<a1,1,(a1-l+0.01)/(h-l+0.01)));
a3:=v/winner(l);
a4:=ref(hhv(c,120),1);
a5:=ref(llv(c,120),1);
a6:=100*(c-a5)/(a4-a5);
a7:=a2>0 or a2=1;
a8:=a7 and a3/ref(a3,3)>=3 and a6<80 ;
a9:=ref(a8,1) or ref(a8,2) or ref(a8,3) or ref(a8,4);
a10:=a8 and a9;
a11:=if(filter(a8,3),5,0);
a12:=if(filter(a10,3) or ee,10,0);
drawtext(a11,68,’庄进场’),colorffff00;
阿门11:=LLV(L,34);
阿门12:=EMA(((3*C+H+L+O)/6-阿门11)/(HHV(H,34)-阿门11)*100,8);
阿门13:=EMA(阿门12,5);
阿门14:=TROUGHBARS( 3,13,1);
阿门15:=PEAKBARS(3 ,13,1);
阿门16:=BARSLAST(阿门15>阿门14);
阿门17:=PEAK(3 ,13,1);
阿门18:=(C-阿门17)/阿门17*100<-13 AND REF(C,2)>=REF(C,1) AND C>REF(C,1);
阿门19:=IF(阿门18 AND REF(C,1)=LLV(C,阿门16) OR 阿门14=1,50,100);

大智慧庄线走势指标公式

 

大智慧猴王出世指标公式

Var1:=MA(CLOSE,5);
Var2:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var3:=SMA(Var2,5,1);
Var4:=REF(CLOSE,1);
Var5:=SMA(MAX(CLOSE-Var4,0),8,1)/SMA(ABS(CLOSE-Var4),8,1)*100;
Var6:=SMA(MAX(CLOSE-Var4,0),21,1)/SMA(ABS(CLOSE-Var4),21,1)*100;
{www.gUPaNg.com 股旁网_最新股票指标公式}
花果山: if(100-Var3<20 AND Var6<25,Var3+15,32.86),stick,linethick1,colorf00ff0;32.86,stick,linethick1,color000000;
山顶: if(100-Var3<30,Var3+5,32.86),stick ,linethick1, COLORRED;32.86,stick ,linethick1, COLOR000000;
山腰: if(100-Var3<50,Var3,32.86),stick ,linethick1, COLORGREEN;32.86,stick ,linethick1, COLOR000000;
山脚: if(100-Var3<50,Var3-15,32.86),stick ,linethick1, COLORYELLOW;32.86,stick ,linethick1, COLOR000000;
水帘洞: if(Var5<40 AND Var6<50 AND Var3>70,30,100-Var3),stick,linethick7,color0fff00;100-Var3,stick,linethick7,color000000;
猴王: 100-Var3,COLORRED;
猴王出世1: CROSS(Var5,10) AND CROSS(Var6,20)*125,COLORRED;
猴王出世2: CROSS(猴王,10)*125,COLORRED;
{DRAWICON(猴王出世1=125,130,1);};

大智慧猴王出世指标公式

 

大智慧蓝狐金矿指标公式

多方趋势: (7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1)),COLORWHITE;
空方趋势: EMA(MA(多方趋势,5),7),LINETHICK1,COLORF0F000;
{www.gUPaNg.com 股旁网_最新股票指标公式}
STICKLINE(多方趋势<空方趋势,多方趋势,空方趋势,3,0),COLORF0F000;
STICKLINE(空方趋势<14 AND 空方趋势>多方趋势,多方趋势,10,5,0);
VARA:= EMA(0.667*REF(多方趋势,1)+0.333*多方趋势,2);
STICKLINE(多方趋势>VARA,多方趋势,VARA,5,0),COLORRED;
B1:= 多方趋势>VARA;
介入¥:= B1>REF(B1,1) AND 多方趋势<38;
DRAWTEXT(介入¥,60,’关注’),COLORFF0000;
关注: B1>REF(B1,1) AND 多方趋势<35;
金矿: CROSS(多方趋势,空方趋势) AND 空方趋势<35;
DRAWTEXT(CROSS(多方趋势,空方趋势) AND 空方趋势<45,30,’金矿’),COLORYELLOW;

大智慧蓝狐金矿指标公式

 

大智慧庄家成本主图指标公式

N:=30;M:=95;
v1:ema(close,5),coloryellow;
v2:ema(ema(close,29)*1.01,10),colorffcc66;
DRAWICON(cross(v1,v2),v2,1);
v3:ema(close,10),colorff00ff;
v4:ema(ema(close,60)*0.99,10),color0099ff;
DRAWICON(cross(v3,v4),v4,1);
Var1:=AMOUNT/VOL/100;
{www.gUPaNg.com 股旁网_最新股票指标公式}
庄家运作成本: MA(CLOSE,18),colorwhite;
庄家平均成本: EMA(EMA(Var1,2),N),color00ff00;
庄家底仓成本: EMA(EMA(Var1,13),M),colorblue;
无穷成本均线: DMA(CLOSE,VOL/CAPITAL),colorblue;
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff{B0B0FF};
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),{COLORCYAN;}colorffcc66;
STICKLINE(C<=O,H,L,0,0),{COLORCYAN}colorffcc66;
Var326:=IF(CLOSE>REF(CLOSE,1),88,0);
Var327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND Var326>0, 91, 0);
STICKLINE(Var327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
DRAWTEXT(Var327>90,LOW*0.95,’追涨‘),COLORYELLOW;

大智慧庄家成本主图指标公式

 

大智慧金鼠送宝指标公式

v1:ema(close,5);
v2:ema(ema(close,90)*1.01,10),LINETHICK2;
DRAWICON(cross(v1,v2),v2,1);
DRAWTEXT(cross(v1,v2),v1+0.05,’金鼠送宝’),color00ff00;
{跟进:(cross(v1,v2));}
bbi:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,colorwhite;
VAR1:=IF(DATE<1500830 AND DATE>900101,1,0);
VAR2:=LLV(LOW,10);
AK1:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 100),5);
AK:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),’快乐金鼠窝’),colorYELLOW;
QY1:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
QY2:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
QY3:=QY1<REF(QY2,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
{www.gUPaNg.com 股旁网_最新股票指标公式}
XG:DRAWTEXT(QY3 AND COUNT(QY3,30)=1,L,’下钱雨了’),Color00FFFF;
{下钱雨了:QY3 AND COUNT(QY3,30)=1}
;VAR3:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1;
K1:=(20/10)*VAR1*100;
K2:=(32/10)*VAR1*100;
K3:=(35/10)*VAR1*100;
DRAWTEXT(CROSS(动能趋势线,K1),HIGH*1.02,’风险’),Color00FFFF;
DRAWTEXT(CROSS(动能趋势线,K2),HIGH*1.02,’减仓’),ColorFF0000;
DRAWTEXT(CROSS(动能趋势线,K3),HIGH*1.02,’出局’),Color0000FF;
M:=MA((C+O+H+L)/4,2);
M3:MA(M,3),Color000000;
M5:MA(M3,5),Color000000;
买入:=CROSS(M3,M5);
{买入显示}
DRAWTEXT(买入,LOW*0.98,’▲’),COLOR0000FF;
DRAWTEXT(买入,LOW*0.975,’O’),COLOR0000FF;
DRAWTEXT(买入,LOW*0.975,’‖’),COLOR0000FF;

大智慧金鼠送宝指标公式

 

大智慧无敌猎庄指标公式

高:=SUM(IF((REF(L,2)-L)>0 AND (REF(L,2)-L)>(H-REF(H,2)),(REF(L,2)-L),0),14)*80/SUM(MAX(MAX(H-L,ABS(H-REF((C+L+O+H)/4,2))),ABS(L-REF((C+L+O+H)/4,2))),14);
跌:=SMA(高,2,1);
限:=SMA(MAX(C-EMA((C+L)/2,21),0),8,1)/SMA(ABS(C-EMA((C+L)/2,21)),8,1)*100;
{www.gUPaNg.com 股旁网_最新股票指标公式}
制:=(EMA(EMA((C-SMA(LOW,10000,1))*100,7),1)-EMA(EMA(EMA((C-SMA(LOW,10000,1))*100,7),1),5))*3;
aa:=if(c>=ref(c,3),1,0);
bb:=if(c>=ref(c,5),1,0);
dd:=if(c>=ref(c,8),1,0);
ee:=if(c>=ref(c,13),1,0);
ff:=if(c>=ref(c,21),1,0);
gz2:=aa+bb+dd+ee+ff;
kk:=0;
for i=1 TO 4 DO
kk:=kk+REF(gz2,i);
kkk:=kk/4;
DRAWTEXT(kkk=0 and gz2>0 and c>REF(c,1) AND 跌>26 AND 限<70 AND 制<-6,(L/MA(C,50)-1.01)*100,’买’),COLORGREEN,ALIGN1;
DRAWTEXT(kkk=5 and gz2<5,(H/MA(C,50)-0.96)*100,’卖’),COLORRED,ALIGN1;
注意坐标线作用:0,POINTDOT;

大智慧无敌猎庄指标公式