大智慧满仓选股指标公式

R:=((CLOSE – LLV(LOW,9))/(HHV(HIGH,9) – LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) – 1),1);
N:=IF((陡峭度 > 0.35),6,65);
{www.gUPaNg.com 股旁网_最新股票指标公式}
VAR1:=((-((100)*(HHV(HIGH,N) – CLOSE))/(HHV(HIGH,N) – LLV(LOW,N))))*((DATE < 30070110));
VAR1A:=((-((100)*(HHV(HIGH,N) – CLOSE))/(HHV(HIGH,N) – LLV(LOW,N))) + 100)*((DATE < 30070110));
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 30070110));
((线 > REF(线,1)) and (线 < 25) and (COUNT((线 > REF(线,1)),5) = 1) and IF((N = 6),(获利盘 < 60),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0))*(40);

大智慧满仓选股指标公式

 

大智慧蓝柱短买选股指标公式

RSV:=(((CLOSE – LLV(LOW,9)) / (HHV(HIGH,9) – LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) – (2 * D));
VARB:=(((CLOSE – MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARC:=(((CLOSE – MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARD:=(((CLOSE – MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARE:=(((VARB + (2 * VARC)) + (3 * VARD)) / 6);
VARF:=MA(VARE,3);
xg:CROSS(J,0) AND (VARF<=(0-7));

大智慧蓝柱短买选股指标公式

 

大智慧金口玉言指标公式

AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),21,1)/SMA(ABS(CLOSE-AA),21,1)*1000;
HHH:=BBB-LLV(BBB,27);
CCC:=LLV(BBB,27)-BBB;
QQ:(MA(HHH*1.5,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS:(MA(CCC*1.5,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ0:(MA(HHH*2,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS0:(MA(CCC*2,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ1:(MA(HHH*2.5,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS1:(MA(CCC*2.5,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ2:(MA(HHH*3,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS2:(MA(CCC*3,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ3:(MA(HHH*3.5,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS3:(MA(CCC*3.5,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ4:(MA(HHH*4,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS4:(MA(CCC*4,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ5:(MA(HHH*4.5,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS5:(MA(CCC*4.5,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ6:(MA(HHH*5,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS6:(MA(CCC*5,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
QQ7:(MA(HHH*5.5,2)*3+HHH*13)/16,COLOR445EAF,LINETHICK1;
SS7:(MA(CCC*5.5,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
SS8:(MA(CCC*6,2)*3+CCC*13)/16,COLORFF9D00,LINETHICK1;
{www.gUPaNg.com 股旁网_最新股票指标公式}
GG:MA(HHH,3),LINETHICK2,COLORRED;
MM:MA(CCC,3),LINETHICK2,COLORGREEN;
WW:=IF(QQ<GG ,SS,MM);
EE:=IF(SS<MM ,GG,QQ);
EE1:=IF(SS<MM-4 ,GG-3,QQ-3);
WW1:=IF(QQ<GG-4 ,SS-3,MM-3);
STICKLINE(18,0,EE1-9,1,0),COLOR37A8EE;
STICKLINE(18,WW1+12,0,1,0),COLOR6E6F6F;
0,COLORB713EA,LINETHICK7;

大智慧金口玉言指标公式

 

大智慧顶底极品指标公式

实价线:(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,COLORWHITE;
A1:=(2*C+H+L)/4;
A2:=LLV(L,34);
A3:=HHV(H,34);
A4:=SMA((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100-70,9,1)+100;
A5:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
A6:=SMA(SMA(A5,3,1),3,1)+100;
A7:=A6-A4;
底部区域:IF(A7>60,A7-60,0),COLORYELLOW;
持有:STICKLINE(REF(底部区域,1)<底部区域,底部区域,REF(底部区域,1),5,0),COLORF00FF0;
出货:STICKLINE(REF(底部区域,1)>底部区域,底部区域,REF(底部区域,1),5,0),COLOR00FF00;
{www.gUPaNg.com 股旁网_最新股票指标公式}
中线持有:EMA((A1-A2)/(A3-A2)*100,13),COLORBLUE;
中线出货:EMA(0.667*REF(中线持有,1)+0.333*中线持有,2),COLORRED;
STICKLINE(中线持有-中线出货>0,中线持有,中线出货,8,0),COLORBLUE;
STICKLINE(中线持有-中线出货<0,中线持有,中线出货,8,0),COLORRED;

大智慧顶底极品指标公式

 

大智慧秘密波段指标公式

VAR22:=REF(LOW,1);
VAR23:=((SMA(ABS((LOW – VAR22)),3,1) / SMA(MAX((LOW – VAR22),0),3,1)) * 100);
VAR24:=EMA(IF((CLOSE * 1.2),(VAR23 * 10),(VAR23 / 10)),3);
VAR25:=LLV(LOW,38);
VAR26:=HHV(VAR24,38);
VAR27:=IF(LLV(LOW,90),1,0);
VAR28:=((EMA(IF((LOW <= VAR25),((VAR24 + (VAR26 * 2)) / 2),0),3) / 618) * VAR27);
主力秘密筹码:STICKLINE(VAR28,0,VAR28,6,1),colorRED;
动态底部:EMA(IF(L<= LLV(l,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(l,1),0),30,1),0),3)*10,STICK,COLORYELLOW,LINETHICK2;
{第二个:}
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 100),4) / SUM((VOL * 100),4));
VARB:=(INTPART((VARA * 100)) / 100);
VARC:=(SUM(((CLOSE * VOL) * 100),7) / SUM((VOL * 100),7));
VARD:=(INTPART((VARC * 100)) / 100);
VARE:=(SUM(((CLOSE * VOL) * 100),28) / SUM((VOL * 100),28));
VARF:=(INTPART((VARE * 100)) / 100);
短线趋势:=(EMA(CLOSE,5) – EMA(CLOSE,10));
中线趋势:=EMA(短线趋势,9);
VAR10:=((0 – ((100 * (HHV(CLOSE,5) – CLOSE)) / (HHV(CLOSE,5) – LLV(LOW,5)))) + 100);
VAR11:=((0 – ((100 * (HHV(CLOSE,10) – CLOSE)) / (HHV(CLOSE,10) – LLV(LOW,10)))) + 100);
VAR12:=((0 – ((100 * (HHV(CLOSE,20) – CLOSE)) / (HHV(CLOSE,20) – LLV(LOW,20)))) + 100);
VAR13:=((0 – ((100 * (HHV(CLOSE,30) – CLOSE)) / (HHV(CLOSE,30) – LLV(LOW,30)))) + 100);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 – VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 – VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
发现机构入场:IF((((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0)),-10,0),LINETHICK2,Color00FF00;
短线指标:IF(((((CROSS(短线趋势,中线趋势) AND (短线趋势 < 0)) AND (中线趋势 < (0 – 0.2))) AND (VAR11 > 45)) AND (VAR16 > 0)),-10,0),COLORWHITE;
VAR1F:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR20:=REVERSE(VAR1F);
VAR21:=SMA(VAR1F,3,1);
趋势:SMA(VAR21,3,1),COLOR0000FF,LINETHICK2;
人气:SMA(趋势,3,1),COLORYELLOW,LINETHICK2;
出击:IF(CROSS(趋势,人气) AND (趋势<30),20,0),COLOR0000FF,LINETHICK2;
短卖:IF(CROSS(人气,趋势) AND (人气>75),85,100),COLOR008000,LINETHICK2;
{www.gUPaNg.com 股旁网_最新股票指标公式}
Var1:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100+50;
Var2:=EMA(Var1,9);
Var3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
Var4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
Var5:=SMA(Var4,13,8);
Var6:=SMA(Var3,21,8);
Var7:=MA(CLOSE,80)-MA(CLOSE,10)/7;
Var8:=EMA(C,5);
Var9:=MA(LLV(C,9)*1.1,14);
Var10:=2*Var9-Var8-c*0.1;
Var11:=if((Var8-Var10)*5>0,POW((Var8-Var10)*5,2)/10,-1*POW
((Var8-Var10)*5,2)/10);
线:CEILING(SMA(Var5,13,8));
STICKLINE(线-Var6<-65,0,8,15,1),COLOR3098FF;
STICKLINE(LONGCROSS(Var1,Var2*1.05,15) AND Var1<40,18,0,6,0),COLORRED;
顶:STICKLINE(线-Var6>85,95,90,15,1),COLORGREEN;
STICKLINE(LONGCROSS(Var2,Var1*0.95,7) AND Var1>60,100,88,6,0),COLORFF9933;
柱:IF(Var11>0,Var11-0,0),STICK,COLOR00ffff;
框:IF(CLOSE<Var7,20,0);

大智慧秘密波段指标公式

 

大智慧只做红波段指标公式

N:=20;
jj:=(HIGH+LOW+CLOSE)/3;qj0:=vol/IF(HIGH=LOW,4,HIGH-LOW);
qj1:=IF(CAPITAL=0,qj0*(jj-MIN(CLOSE,OPEN)),qj0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
qj2:=IF(CAPITAL=0,qj0*(MIN(OPEN,CLOSE)-LOW),qj0*IF(HIGH=LOW,1,(jj-MIN(CLOSE,OPEN))));
qj3:=IF(CAPITAL=0,qj0*(HIGH-MAX(OPEN,CLOSE)),qj0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
qj4:=IF(CAPITAL=0,qj0*(MAX(CLOSE,OPEN)-jj),qj0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-jj)));
DDX:((qj1+qj2)-(qj3+qj4))/sum(vol,60)*1,COLOR00aaaa,LINETHICK0;DX:=ma(ddx,5)*n;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DDX1:sma(DX,3,1)*10,COLORyellow;
{变色}
if(DDX1>ref(DDX1,1),DDX1,0),Circledot,COLORYELLOW,LINETHICK1;
if(DDX1<ref(DDX1,1),DDX1,0),Circledot,COLOR00FF00,LINETHICK1;
{只做红波段}
VAR1:=EMA(CLOSE,13)-EMA(CLOSE,55);
VAR2:=EMA(VAR1,3);
VAR3:=VAR1>VAR2;
VAR4:=VAR1<VAR2;
牛熊分界:0,COLORwhite,LINETHICK2,POINTDOT;
STICKLINE(VAR3,VAR1,VAR2,4,0),COLORRED;
STICKLINE(VAR4,VAR1,VAR2,2,0),COLORGREEN;

大智慧只做红波段指标公式

 

大智慧问大底指标公式

Q1:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
AA:3*Q3-2*Q4,COLOR1010FF;
Q5:=AA>1*REF(AA, 1);
Q6:=LLVBARS(LOW, 50);
Q7:=SUM(VOL, Q6);
Q8:=HHVBARS(HIGH, 50);
Q9:=SUM(VOL,Q8);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
Q11:=HHV(AA,5);
A1:EMA(Q3, 3) , COLORFFDDCC;
A2:EMA(A1, 3) , COLORFFBBCC;
A3:EMA(A2, 3) , COLORFF99CC;
A4:EMA(A3, 3) , COLORFF55CC;
A5:EMA(A4, 3) , COLORFF33CC;
A6:EMA(A5, 3) , COLORFF11CC;
A:EMA(A4, 3), COLORFF00CC;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXT(CROSS(AA, 20) AND Q10<-13,18,’☆←大底’), COLORyellow;
DRAWTEXT(CROSS(AA, A5) AND REF(AA,1)<34,REF(AA,1),’☆←小杀’), COLORred;
DRAWTEXT(CROSS(A1, AA) AND REF(AA,1)>80, REF(AA,3), ‘★→顶’), COLOR00FF00;
DRAWTEXT(CROSS(AA, A1) AND Q5 AND A1<20 AND Q1>9 OR A1>1*REF(A1, 1)
AND Q1>4 AND A1<60, 30, ‘☆→拉’), COLORFFFFCC;

大智慧问大底指标公式

 

大智慧强势跟庄指标公式

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,
VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),
IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));
主动:=sum(主动买盘,0)/sum(主动卖盘,0)*-1;
低主5:=llv(主动,5);
动比:=主动-低主5;
高动5:=6/hhv(动比,5);
主动心:=高动5*动比;
k1:=主动心+1-ref(主动心,1)>0;
k2:=主动心+1-ref(主动心,1)<0;
主动心向:=主动心*k1-主动心*k2;
{下面是量价了相合}
ff:=CLOSE-ref(CLOSE,1);
a:=ma(vol*ff,2);
a0:=ma(vol*ff,3);
a1:=ma(vol*ff,5);
a2:=ma(vol*ff,10);
a3:=ma(vol*ff,20);
a4:=ma(vol*ff,30);
b:=a-ref(a,1);
b0:=a0-ref(a0,1);
b1:=a1-ref(a1,1);
b2:=a2-ref(a2,1);
b3:=a3-ref(a3,1);
b4:=a3-ref(a4,1);
量价相合:(b>0)+(b0>0)+(b1>0)+(b2>0)+(b3>0)+(b4>0),DOTLINE;
{www.gUPaNg.com 股旁网_最新股票指标公式}
yes:(量价相合>1)*量价相合*(主动心向>1 or 主动心>60);
partline(yes,yes>=ref(yes,1),rgb(255,0,0),yes<ref(yes,1),rgb(0,250,0)),linethick2;
周期1:IF(yes,BARSLAST(CROSS(yes,0.1))+1,0),COLORFF00FF,POINTDOT,LINETHICK0;

大智慧强势跟庄指标公式

 

大智慧黄金买点2指标公式

zz:=(o+h+l)/3;
hjmd:EMA(zz,4),COLORYELLOW,LINETHICK1;
xxb:=CLOSE*VOL;
xxbym:EMA((EMA(xxb,3)/EMA(VOL,3)+EMA(xxb,6)/EMA(VOL,6)+EMA(xxb,12)/EMA(VOL,12)+EMA(xxb,24)/EMA(VOL,24))/4,13),colorff00ff,LINETHICK0;
爱心:=EMA(CLOSE,13)-EMA(CLOSE,55);
无价:=EMA(爱心,3);
PARTLINE(xxbym,爱心>=无价,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;
DRAWTEXTREL(700,120,’今日买点:’+NUMTOSTRN(hjmd,2 )),LINETHICK2,coloryellow;
{www.gUPaNg.com 股旁网_最新股票指标公式}
yc:=(h+l)/2;
ychjx:=(EMA(zz,4))+(yc-ref(zz,3))/4;
DRAWTEXTREL(650,20,’昨测今日买点:’+NUMTOSTRN(ref(ychjx,1),2)),LINETHICK2,colorFF00FF;
DRAWTEXTREL(700,220,’明日买点:’+NUMTOSTRN(ychjx,2)),LINETHICK2,colorff00ff;

大智慧黄金买点2指标公式

 

大智慧绝品MACD指标公式

V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) /3.90),0.9);
HY1:=REF(EMA(V1,3),1);
DRAWtext(CROSS(HY1,CLOSE),HIGH*0.01,’★卖出’),LINETHICK3,colorwhite;
DIF1:=EMA(CLOSE,2) – EMA(CLOSE,55);
DEA1:=EMA(DIF1,3);
MACD1:=2*(DIF1-DEA1);
MACD2:=EMA(MACD1,4);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,9,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,9,0),COLORRED;
STICKLINE(MACD1<MACD2,0,MACD1,9,0),COLORFF0000;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLOR00FFFF;
MACD:MACD1,COLORRED,LINETHICK6;
强在量上卖:IF(DIF1>=DEA1,DIF1,0),COLORFFFF00,LINETHICK6;
持仓段:0,COLOR00CFFF;
空仓段:0,COLORFFCCFF;
DRAWTEXT(CROSS(DIF1,DEA1),DIF1+0.01,’建仓‘),COLORRED,LINETHICK3;
DRAWTEXT(CROSS(DEA1,DIF1),DIF1+0.01,’空仓’),COLORGREEN,LINETHICK7;
Va19f:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
Va1Af:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
Va1Bf:=EMA(Va1Af,9);
Va1Cf:=2*(Va1Af-Va1Bf);
DRAWTEXT(Va1Af<-50 AND Va19f>7 AND Va1Af<Va1Bf,0,’短期见底’),coloryellow,LINETHICK3 ;
{www.gUPaNg.com 股旁网_最新股票指标公式}
RSVA:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
KA:=SMA(RSVA,3,1);
DA:=SMA(KA,3,1);
买进:IF(DA<25 AND CROSS(KA,DA) ,0.05,0),COLORRED,STICK,LINETHICK5;
卖出:IF(DA>75 AND CROSS(DA,KA) ,0.05,0),COLORff0000,STICK,LINETHICK5;
Q:2*(DEA1-DIF1),COLOR00ff00,linethick5;
AS1:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
AA1:=SMA(AS1,3,1);
BB1:=SMA(AA1,3,1);
AB1:=CROSS(AA1,BB1);
DD1:=EMA(CLOSE,6)-EMA(CLOSE,13);
DD2:=EMA(DD1,3);
MACD1:(DD1-DD2)*2;
AD1:=CROSS(DD1,DD2);
MACD2:=EMA(MACD1,4);
EE:IF(AB1 AND AD1,0.8,0),STICK,LINETHICK7,COLORRED;
EE1:=C>EMA(C,13);
EE2:=EMA(C,13)>REF(EMA(C,13),1);
DRAWTEXT(EE AND EE1 AND EE2,0.8,’←买入‘),LINETHICK5,COLORff33ff;
AB2:=CROSS(BB1,AA1);
AD2:=CROSS(DD2,DD1);
FF:IF(AB2 AND AD2,0.8,0),LINETHICK3,COLORff0000;

大智慧绝品MACD指标公式