大智慧趋势阶段卖指标公式

趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORRED;
阶段卖: 90,POINTDOT,COLORRED;
{www.gupang.com 股旁网_大智慧股票指标公式}
强:80,POINTDOT,LINETHICK1,COLORYELLOW;
牛雄分界: 50,POINTDOT,LINETHICK1,COLORYELLOW;
弱:20,POINTDOT,LINETHICK1,COLORYELLOW;
底部: 10,POINTDOT,COLORRED;
买入警戒: IF(趋势<=10,40,0);
买入: IF(CROSS(趋势,底部),100,0);
卖出警戒: IF(趋势>=90,60,100);
天:100,COLOR009090;
地:0,COLOR009090;

大智慧趋势阶段卖指标公式

 

大智慧锁定大牛股选股指标公式

M5:=EMA(C,43);
M6:=EMA(C,55);
M7:=MA(C,78);
M8:=EMA(M7,3);
M9:=EMA(M8,3);
M11:=EMA(M9,3);
MA47:=EMA(CLOSE,46);
MA60:=EMA(CLOSE,60);
Y:=(H+L)/2;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3));
JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0<TUD0;
JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;
{www.gupang.com 股旁网_大智慧股票指标公式}
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
锁定牛股:JDU2 AND M9*0.90;

大智慧锁定大牛股选股指标公式

 

大智慧紫风拉升交易指标公式

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
STICKLINE(A>B,A,B,5,0),COLORYELLOW;
STICKLINE(A<B,A,B,5,0),COLORBLUE;
M1:EMA(CLOSE,3);
M2:EMA(CLOSE,8);
M3:EMA(M2,13);
M4:EMA(M2,55);
VAR1:=EMA(M3,55);
M5:EMA(M4,81), COLORRED,LINETHICK2;
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,21)+2*STD(CLOSE,21);
DRAWICON(CROSS(VAR2,VAR3),HIGH*1.035,2);
DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,’卖出’), COLORGREEN;
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),7,1)/SMA(ABS(CLOSE-VAR4),7,1)*100;
VAR6:=CROSS(79,VAR5);
VAR7:=FILTER(VAR6,4);
DRAWICON(VAR7,HIGH*1.035,2);
DRAWTEXT(VAR7,HIGH*1.02,’卖出’), COLORGREEN;
A7:=(2*C+H+L)/4;
VAR10:=LLV(LOW,34);
VAR11:=HHV(HIGH,34);
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND
COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,’买进‘) ,COLORRED;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW,’买进’), COLORRED;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,’抄底‘),COLORRED;紫风:=MA(C,1);
紫风1:MA(C,5),colorred,LINETHICK1;
紫风2:MA(MA(C,5),2),COLOR555555;
紫风3:MA(MA(MA(C,5),2),2),COLOR555555;
紫风4:MA(MA(MA(MA(C,5),2),2),2),COLOR555555;
紫风5:MA(MA(MA(MA(MA(C,5),2),2),2),2),COLOR555555;
紫风10:MA(C,20),colorFF1101;
紫风20:MA(C,60),color0111cc;
紫风21:MA(MA(C,60),2),color009000;
紫风22:MA(MA(MA(C,60),2),2),color009000;
交易:=紫风1;
拉升:HHV(交易,13),color2fffff;
压力:HHV(交易,60),color009000;
支撑:LLV(交易,13),COLOR009000;
{www.gupang.com 股旁网_大智慧股票指标公式}
STICKLINE(拉升>交易 AND 紫风>紫风1,拉升,紫风1,1,0),coloryellow;
STICKLINE(拉升>交易 AND 紫风<紫风1,拉升,紫风1,1,0),color00c000;
底:=LLV(LOW,60)*1.02;
顶:=HHV(HIGH,60)*0.98;
STICKLINE(底,底*0.9999,底,10,0),COLOR999999;
STICKLINE(顶,顶*0.9999,顶,10,0),COLOR999999;
DEA:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),COLORFF9909,LINETHICK1;
MID:=MA(CLOSE,20);
UPPER:MID +2*STD(CLOSE,20),color999999;
LOWER:MID – 2*STD(CLOSE,20),color999999;

大智慧紫风拉升交易指标公式

 

大智慧长短线RSI+顶底背离指标公式

指标提示加减仓,进场和出局,源码中用到未来函数,用于判断背离,不影响使用。

LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORRED;
RSI2:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100,LINETHICK2,COLORGREEN;
R1:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
VAR1:=4*SMA(R1,5,1)-3*SMA(SMA(R1,5,1),3.2,1);
VAR2:=24;
IF(CROSS(VAR1,VAR2),10,0),STICK,COLORRED;
DRAWTEXT(CROSS(VAR1,VAR2),10,’加’),COLOREEFF00;
VAR3:= 4*SMA(R1,5,1)-3*SMA(SMA(R1,5,1),3,1);
STICKLINE(CROSS(80,VAR3),100,90,3,0),COLORFFF666;
DRAWTEXT(CROSS(80,VAR3),100,’减’), COLOREEFF00;
VAR4:= 4*SMA(R2,5,1)-3*SMA(SMA(R2,5,1),3,1);
STICKLINE(CROSS(72,VAR4),110,100,3,0),STICK,COLORRED;
DRAWTEXT(CROSS(72,VAR4),105,’出局’), COLOREEFF00;
VAR5:=4*SMA(R2,5,1)-3*SMA(SMA(R2,5,1),3.2,1);
VAR6:=38;
IF(CROSS(VAR5,VAR6),15,0),STICK,COLORRED;
DRAWTEXT(CROSS(VAR5,VAR6),18,’进场’), COLOREEFF00;
AA:=REF(RSI1,3)=HHV(RSI1,2*3+1);
BB:=BACKSET(AA,3+1);
CC:=FILTER(BB,3) AND RSI1=HHV(RSI1,3+1);
A1:=BARSLAST(REF(CC,1));
背离:=REF(CLOSE,A1+1)<CLOSE AND REF(RSI1,A1+1)>RSI1 AND CC;
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORCYAN,LINETHICK2;
AA2:=REF(RSI1,3)=LLV(RSI1,2*3+1);
BB2:=BACKSET(AA2,3+1);
CC2:=FILTER(BB2,3) AND RSI1=LLV(RSI1,3+1);
AA2A:=BARSLAST(REF(CC2,1));
底背离:=REF(C,AA2A+1)>CLOSE AND REF(RSI1,AA2A+1)<RSI1 AND CC2;
DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORMAGENTA,LINETHICK2;
DRAWTEXT(顶背离,RSI1*1.02,’ -顶背’),COLORMAGENTA;
DRAWTEXT(底背离,RSI1*1.05,’ -底背’),COLORMAGENTA;
{www.gupang.com 股旁网_大智慧股票指标公式}
AA00:=REF(RSI2,3)=HHV(RSI2,2*3+1);
BB00:=BACKSET(AA00,3+1);
CC00:=FILTER(BB00,3) AND RSI2=HHV(RSI2,3+1);
A11:=BARSLAST(REF(CC00,1));
顶背离1:=REF(CLOSE,A11+1)<CLOSE AND REF(RSI2,A11+1)>RSI2 AND CC00;
DRAWLINE(CC00,RSI2,FILTER(顶背离1>0,5),RSI2,0),COLORwhite,LINETHICK2;
AA22:=REF(RSI2,3)=LLV(RSI2,2*3+1);
BB22:=BACKSET(AA22,3+1);
CC22:=FILTER(BB22,3) AND RSI2=LLV(RSI2,3+1);
AA22A:=BARSLAST(REF(CC22,1));
底背离1:=REF(C,AA22A+1)>CLOSE AND REF(RSI2,AA22A+1)<RSI2 AND CC22;
DRAWLINE(CC22,RSI2,FILTER(底背离1>0,5),RSI2,0),COLORRED,LINETHICK2;
DRAWTEXT(顶背离1,RSI2*1.02,’ -顶背’),COLORMAGENTA;
DRAWTEXT(底背离1,RSI2*1.05,’ -底背’),COLORMAGENTA;
100,POINTDOT;
80,POINTDOT;
50,POINTDOT;
20,POINTDOT;
0,POINTDOT;

大智慧长短线RSI+顶底背离指标公式

 

大智慧注意买入卖出指标公式

RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K1:=SMA(RSV1,5,1);
D1:=SMA(K1,5,1);
J1:=3*K1-2*D1;
AA1:=EMA(J1,5);
AA2:=REF(AA1,1);
STICKLINE(AA1>AA2,AA1,AA2,4,0),COLOR0055AA;
STICKLINE(AA1>AA2,AA1,AA2,4,0),COLOR0077CC;
STICKLINE(AA1>AA2,AA1,AA2,4,0),COLOR0099DD;
STICKLINE(AA1>AA2,AA1,AA2,1,0),Color01BEE7;
{www.gupang.com 股旁网_大智慧股票指标公式}
STICKLINE(AA1<=AA2,AA1,AA2,4,0),COLOR006600;
STICKLINE(AA1<=AA2,AA1,AA2,4,0),COLOR009900;
STICKLINE(AA1<=AA2,AA1,AA2,4,0),COLOR00BB00;
STICKLINE(AA1<=AA2,AA1,AA2,1,0),COLOR00CC00;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
STICKLINE(BB1>BB2,BB1,BB2,4,0),COLOR000045;
STICKLINE(BB1>BB2,BB1,BB2,4,0),COLOR000085;
STICKLINE(BB1>BB2,BB1,BB2,4,0),COLOR0000C5;
STICKLINE(BB1>BB2,BB1,BB2,1,0),COLOR0000E5;
STICKLINE(BB1<=BB2,BB1,BB2,4,0),COLOR353500;
STICKLINE(BB1<=BB2,BB1,BB2,4,0),COLOR555500;
STICKLINE(BB1<=BB2,BB1,BB2,4,0),COLOR757500;
STICKLINE(BB1<=BB2,BB1,BB2,1,0),COLOR858500;
DD:=AA1>AA2 AND BB1>BB2;
注意买入:DD AND NOT(REF(DD,1)) AND (AA1<50 OR BB1<50) ,LINETHICK0;
DRAWICON(注意买入,-5,4);
注意卖出:REF(DD,1)=1 AND NOT(DD),LINETHICK0;
DRAWICON(注意卖出,105,5);

大智慧注意买入卖出指标公式

 

大智慧DMI操盘指标公式

N:=14;M:=6;
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),N);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),N);
PDI: DMP*100/TR;
MDI: DMM*100/TR;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;
{www.gupang.com 股旁网_大智慧股票指标公式}
预警:if(ADX>90 and PDI=0,30,0),coloryellow,linethick2;
买:if(cross(PDI,MDI) and (C >1.05*ref(C,1) or ref(C,1)>1.05*ref(C,2)) and (V>2*ref(V,1) or ref(V,1)>2*ref(V,2))and ma(V,5)>ma(V,60) ,20,0),colorred,linethick2;
买2:if(cross(PDI,MDI) and count(预警,10)>=1,10,0),colormagenta,linethick3;

大智慧DMI操盘指标公式