大智慧金牛抄盘手主图指标公式

X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWICON(CROSS(X2,X3),L*0.998,7);
DRAWICON(CROSS(X3,X2),H*1.009,8);
STICKLINE(X2>=X3,LOW,HIGH,0,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3.2,2),COLORRED;
STICKLINE(X2<X3,LOW,HIGH,0,1),COLORGREEN;
STICKLINE(X2<X3,CLOSE,OPEN,3.2,2),COLORGREEN;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,3.2,0),COLORGREEN;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,3.2,0),COLORRED;
STICKLINE((CLOSE>OPEN) AND (X2<X3),CLOSE,OPEN,3.2,2),COLORGREEN;
STICKLINE((CLOSE>OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,2),COLORRED;
STICKLINE((CLOSE<OPEN) AND (X2<X3),CLOSE,OPEN,3.2,0),COLORGREEN;
STICKLINE((CLOSE<OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,0),COLORRED;
{MA5:MA(CLOSE,5),COLORRED;
MA10:MA(CLOSE,10) ,COLORFF00FF,LINETHICK1;
下跌5日均线:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORWHITE,LINETHICK1;
下跌10日均线:IF(MA10<REF(MA10,1),MA10,DRAWNULL),COLORGREEN,LINETHICK1;}
趋势线:MA(CLOSE,10), COLORGREEN,LINETHICK2;
PARTLINE(趋势线,趋势线>REF(趋势线,1),RGB(255,0,0),趋势线<REF(趋势线,1),RGB(0,255,0),1,RGB(0,0,255)),LINETHICK2;

大智慧金牛抄盘手主图指标公式

 

大智慧金牛抄底指标公式

周期:=15;
过滤:=8;
选股:=-26;
抄底:=-40;
T:0, POINTDOT;
VAR2:=MA(CLOSE, 5);
VAR3:=MA(CLOSE, 10);
VAR4:=MA(CLOSE, 20);
VAR5:=MA(CLOSE, 30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;
VAR7:=(VAR6-REF(VAR6, 周期))/REF(VAR6, 周期)*100;
VAR8:=(VAR6-REF(VAR6, 周期))/REF(VAR6, 周期)*100;
VAR9:=EMA(VAR7, 过滤);
反转:STICKLINE(VAR9>1*REF(VAR9, 1), VAR7, 0, 5, 0), COLOREE00EE;
持股:STICKLINE(VAR7>1*REF(VAR7, 1), VAR7, VAR9, 5, 0), COLORRED;
持币:STICKLINE(VAR7<1*REF(VAR7, 1), VAR7, VAR9, 5, 1), COLORGREEN;
洗盘:STICKLINE(VAR7<1*REF(VAR7, 1) AND VAR9>1*REF(VAR9, 1), VAR7, VAR9, 10, 0),
COLOR00EEFF;
VAR10:=(CLOSE-MA(CLOSE, 58))/MA(CLOSE, 58)*100;
VAR11:=(VAR10>1*REF(VAR10, 1) AND VAR10<选股 AND VAR10>抄底)*1.5;
VAR12:=VOL/CAPITAL*100;
VAR13:=LLVBARS(LOW, 50);
VAR14:=SUM(VOL, VAR13);
VAR15:=HHVBARS(HIGH, 50);
VAR16:=SUM(VOL, VAR15);
VAR17:=(CLOSE-REF(OPEN, VAR15))/REF(OPEN, VAR15)*100;
VAR18:=VAR16/CAPITAL*100;
VAR19:=(CLOSE-REF(OPEN, VAR13))/REF(OPEN, VAR13)*100;
VAR20:=VAR14/CAPITAL*100;
VAR21:=MA(CLOSE, 3);
VAR22:=REF(CLOSE, 2)*0.865;
VAR23:=REF(CLOSE, 13)*0.772;
VAR24:=MIN(VAR22, VAR23);
VAR25:=MA(CLOSE, 13);
抄底王:IF((CLOSE-VAR24)/CLOSE<0.030 AND VAR17<(-35) AND SUM(VAR12, 5)/5<1.800, 1
, 0)*10, COLORWHITE;
DRAWTEXT(抄底王, 抄底王, ‘ 成功率 90.22 %,共发出指示1289 次.底 追 ‘){,COLORFFAA
00};
VAR26:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
VAR27:=(EMA(CLOSE, 12)-EMA(CLOSE, 26))*100;
VAR28:=EMA(VAR27, 9);
VAR29:=2*(VAR27-VAR28);
DRAWTEXT(VAR27<(-50) AND VAR26>7 AND VAR27<VAR28, (-10), ‘底’), COLORWHITE;
DRAWTEXT(VAR27<(-50) AND VAR26>7 AND VAR27>=VAR28, 5, ‘追’), COLORWHITE;
STICKLINE(VAR27<(-50) AND VAR26>7, 0,(-10), 5, 0), COLORFFFF66;

大智慧金牛抄底指标公式

 

大智慧预测KDJ指标公式

REFLINE: 0, 20, 50, 80, 100;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:SMA(RSV,3,1),PRECIS2;
D:SMA(K,3,1);
J:3*K-2*D,PRECIS2;
拐点:((9/7*ref(j,1)-2*ref(k,1)+12/7*ref(d,1))/100)*(HHV(H,9)-LLV(L,9))+LLV(L,9),PRECIS2,colorEE88FF,linethick0;
强100a:=((9/7*100-2*ref(k,1)+12/7*ref(d,1))/100)*(HHV(H,9)-LLV(L,9))+LLV(L,9);
强100:IF(强100a<=HHV(H,9),强100a,((9/7*100-2*ref(k,1)+12/7*ref(d,1))/100)*(强100a-LLV(L,9))+LLV(L,9)),PRECIS2,color0088FF,linethick0;
弱10a:=((9/7*10-2*ref(k,1)+12/7*ref(d,1))/100)*(HHV(H,9)-LLV(L,9))+LLV(L,9);
弱10:IF(弱10a>=LLV(L,9),弱10a,((9/7*10-2*ref(k,1)+12/7*ref(d,1))/100)*(HHV(H,9)-弱10a)+弱10a),PRECIS2,colorFF8800,linethick0;
50,dotline,color00eeee;
10,dotline,ColorDDDD00;
100,dotline,Color5555DD;

大智慧预测KDJ指标公式

 

大智慧清仓买卖指标公式

VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
阶段卖出: 3.2,COLORC6C600;
3.5,COLOR0088FF;
清仓卖出: 3.5,COLORFF75FF;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLOR00FF00;
底部:0.2,COLOR70DB93;
关注:0.5,COLORYELLOW;
DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(清仓卖出,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,底部),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(阶段卖出,动力线),20),动力线+0.02,2);
强弱分界线:1.75,POINTDOT,LINETHICK2,COLOR70DB93;
数值:动力线,COLORA8A8A8;

大智慧清仓买卖指标公式

 

大智慧波段赢家主图指标公式

获利了结:EMA(EMA(EMA(HIGH,5),5),5)*1.15,COLORFFFFFF,LINETHICK1;
风险: EMA(EMA(EMA(HIGH,5),5),5)*1.1,COLORYELLOW;
回档: EMA(EMA(EMA(HIGH,5),5),5)*1.05,COLOR00FF00;
平衡: EMA(EMA(EMA(HIGH,5),5),5),COLORFF00FF,LINETHICK1;
反弹: EMA(EMA(EMA(HIGH,5),5),5)*0.95,COLORGRAY,LINETHICK1;
超跌: EMA(EMA(EMA(HIGH,5),5),5)*0.9,COLORBLUE,LINETHICK1;
STICKLINE(close>open,close,open,7.5,1),COLOR4444FF;
STICKLINE(open>=close,close,open,7.5,0),ColorFFFF00;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),COLOR4444FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0),COLOR4444FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0),ColorFFFF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0),ColorFFFF00;
高1:=REF(HHV(H,120),3);
低1:=REF(LLV(L,120),3);H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
基准:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1));
{
stickline(A1X>=0,突破,突破,10,0),coloryellow,LAYER6;
stickline(A1X<0,突破,ref(突破,1),0,-1000),LAYER6;
}
STICKLINE(A1X>=0,基准,突破,10,0),COLOR000099,LAYER6;
STICKLINE(A1X<0,基准,突破,10,0),COLOR00CC66,LAYER6;
b:="LTFunc6@FORLT2";
s1:="LTFunc6@LT_S1";
p0:="LTFunc6@LT_P0";
p1:="LTFunc6@LT_P1";
hs:="LTFunc6@LT_HS";
ls:="LTFunc6@LT_LS";
upp:="LTFunc6@LT_UPP";
udd:="LTFunc6@LT_UDD";
d2:="Lxddx.ddx"/ema(abs("Lxddx.ddx"),60)+8;
d3:=min("Lxddx.ddx"/ema(abs("Lxddx.ddx"),60),10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,’明日<‘+numtostrn(udd,2)+’,出现S点’,’明日>’+numtostrn(upp,2)+’,出现B点’);
tr1:=ifs(s1=1,’明日<‘+numtostrn(ls,2)+’,短线卖出’,’明日>’+numtostrn(hs,2)+’,短线买入‘);
tr2:=ifs(p1=1,ifs(cross(p1,0),’B点’,’持股待涨’),ifs(cross(1,p1),’S点’,’持币观望’));
tr3:=ifs(s1=0,’向下 ‘,’向上 ‘);
tr4:=’ 能量级别:’+numtostrn(d3,1)+’级’;
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd;}
d1:=ema(abs("ddx.ddx"),60); {ddx绝对值60日指数平滑移动平均}
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,’明日收盘价<‘+numtostrn(udd,2)+’,出现S点n’,’若明日收盘价>’+numtostrn(upp,2)+’,出现B点n’);
tr1:=ifs(s1=1,’明日收盘价<‘+numtostrn(ls,2)+’,短线卖出机会’,’若明日收盘价>’+numtostrn(hs,2)+’短线买入机会’);
tr2:=ifs(p1=1,ifs(cross(p1,0),’B点’,’持股’),ifs(cross(1,p1),’S点’,’持币’));
tr3:=ifs(s1=0,’向下,’,’向上,’);
tr4:=’3.能量级别:’+numtostrn(d3,1)+’级’;
bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>’+datestr(date)+’买卖点决策系统提示n’+'<*t=E7FFFF*><*c=000000*><*p=95*>’+’1.BS点:’+tr2+’,’+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>’+’2.短线:’+tr3+tr1+’n’+'<*t=E7FFFF*><*c=000000*><*p=95*>’+tr4;
drawflagtext(1,fb,bs); {1120,0415新版用代码}
drawbmp(p1=1 and ref(p1,1)=0,l,’buy1.bmp’),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,’sell1.bmp’),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,’bs.bmp’),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,’ss.bmp’),align1,valign2;

大智慧波段赢家主图指标公式

 

大智慧修正价格指标公式

重心:(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382,COLORYELLOW,LINETHICK1;
GAO:=HHV(C,60)-LLV(C,60);
RSI:=SMA(MAX(重心-REF(重心,1),0),5,1)/SMA(ABS(重心-REF(重心,1)),5,1);
指导线:重心+GAO*(RSI-0.5),COLORff00ff,LINETHICK1;
STICKLINE(CROSS(RSI,0.1),指导线,REF(指导线,1),1,0),COLORred,LINETHICK3;
STICKLINE(CROSS(0.9,RSI),指导线,REF(指导线,1),1,0),COLORgreen,LINETHICK3;
{趋势}
平衡:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
PARTLINE(平衡,重心>=平衡,RGB(255,0,0),重心<平衡,RGB(0,0,255)),LINETHICK2;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
持股区域:STICKLINE(A>B,A,B,2,0),COLORff00ff,LINETHICK5;
持币区域:STICKLINE(A<B,A,B,2,0),COLORgreen,LINETHICK5;

大智慧修正价格指标公式

 

大智慧主散筹码+选股指标公式

ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZSHTL:=SHCM/(ZLCM+SHCM)*100;
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZCMZL:=MA(ZLCM+SHCM,13);
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);
ZSHJJ:=EMA(ZSHTL,55);
ZZLJJ:=EMA(ZZLKP,55);
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,4,0),COLORfff000;
{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,4,0),COLORff0000;
{主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,3,0),COLORA4A4A4;
{筑顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,3,0),COLORffffff;
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),COLORRED;
{筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,3,0),COLOR66FFCC;
{筹码总量上升}
PARTLINE(0,ZCMZL>REF(ZCMZL,1)),COLOR00ffFF,LINETHICK2;
{增量资金}
散户套牢系数:INTPART(ZSHTL),COLORFFff00,LINETHICK2;
主力控盘系数:INTPART(ZZLKP),COLORYELLOW,LINETHICK2;
DRAWTEXTABS(5,5,”),linethick1,COLOR00EEff;
资金流入强度:ZJLRQD,LINETHICK2,COLOR0000FF;
PARTLINE(ZJLRQD<0,ZJLRQD),LINETHICK2,COLOR00FFFF;
PARTLINE(ZJLRQD,ZJLRQD<10),LINETHICK2,COLORFFFF00;
市场筹码总量:INTPART(ZCMZL),COLORWHITE,LINETHICK0;
DRAWICON(CROSS(主力控盘系数,散户套牢系数),散户套牢系数-5,9);
DRAWICON(CROSS(资金流入强度,散户套牢系数),散户套牢系数-5,4);

{
选股公式1:

ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZZLJJ:=EMA(ZZLKP,55);
选股:(ZZLJJ>REF(ZZLJJ,1) AND REF(ZZLJJ,1)<REF(ZZLJJ,2))*25;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,5,0),COLORRED;

选股公式2:

ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZZLJJ:=EMA(ZZLKP,55);
选股:(ZZLJJ>REF(ZZLJJ,1) AND REF(ZZLJJ,1)<REF(ZZLJJ,2));
}

大智慧主散筹码+选股指标公式

 

大智慧抓庄家指标公式

var2:=REF(LOW,1);
var3:=SMA(ABS(LOW-var2),3,1)/SMA(MAX(LOW-var2,0),3,1)*100;
var4:=EMA(IF(CLOSE*1.2,var3*10,var3/10),3);
var5:=LLV(LOW,38);
var6:=HHV(var4,38);
var7:=IF(LLV(LOW,90),1,0);
var8:=EMA(IF(LOW<=var5,(var4+var6*2)/2,0),3)/618*var7;
有庄的影子: STICKLINE(var8,0,var8,6,1) , COLORffaaff;
趋势线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORaabbdd;
aa:=((ref(趋势线,1)<ref(趋势线,2) and 趋势线<-30) and 趋势线>=ref(趋势线,1)) or (ref(cross(-30,趋势线),1) and cross(趋势线,-30)) or 趋势线=-30;
drawtext(aa,500,’砸锅卖田买’),coloryellow;
砸锅卖田买:if(aa,500,-30),coloryellow;
bb:=((ref(趋势线,1)<ref(趋势线,2) and 趋势线<-20 and 趋势线>-25) and 趋势线>=ref(趋势线,1)) or (ref(cross(-20,趋势线),1) and cross(趋势线,-20));
drawtext(bb,300,’见底信号’),colorred;
见底信号:if(bb,300,-20),colorred;
cc:=((ref(趋势线,1)<ref(趋势线,2) and 趋势线<-25 and 趋势线>-30) and 趋势线>=ref(趋势线,1)) or (ref(cross(-25,趋势线),1) and cross(趋势线,-25));
drawtext(cc,400,’莫错失机会’),color00ff00;
莫错失机会:if(cc,400,-25),color00ff00;
底部快显:if(cross(-20,趋势线),100,-20),linethick2,colorf0f000;
drawtext(cross(-20,趋势线),120,’★’),colorf0f000;
机会来临:if(cross(-25,趋势线),150,-25),linethick2,colorf00ff0;
drawtext(cross(-25,趋势线),170,’★’),colorf00ff0;
砸锅卖田等:if(cross(-30,趋势线),200,-30),linethick2,colorwhite;
drawtext(cross(-30,趋势线),220,’★’),colorwhite;
{见底信号:}-20,colorred,pointdot;
{莫错失机会:}-25,colorblue,pointdot;
{砸锅卖田等着你:}-30,coloryellow,pointdot;

大智慧抓庄家指标公式

 

大智慧KDJ监控主图指标公式

本公式特色: 1、可以直观观察kdj走势。 2、通过反推预先给出KDJ、RSI临界值的股价,可预先知道股价的风险区域,方便判断与逃顶。 3、通过KDJ、RSI、CCI三个指标监控及反推,给出三种提示逃顶卖出信号: 第一、J值大于80而且小于昨天,同时R值大于60而且小于昨天,同时C值大于90而且小于昨天,虽然盘中看还在继续上行,但技术上显示有回调要求,公式会给出卖的提示; 第二、CJR3个指标都已经超过临界值(CCI大于100,J大于90,R大于70),其中有任何一个指标小于昨天,虽然当日股价尚未回调,亦表示有回调要求,公式会给出应卖的提示; 第三、监控当天盘中指标,股价在高位,三指标处于高点,且当天任一指标超过临界以上后回落到临界点或以下(例如长上影线),表示有较强的回调意愿。这个监控的意义,在于对当天盘中冲高回落提出警示,有利于在收盘前可做出决策。 4、根据指标低位临界点的原理,给出买入信号。

j1:=(100);
RSI预设:=80;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),LINETHICK0,PRECIS1;
D:SMA(K,3,1),LINETHICK0,PRECIS1;
J:3*K-2*D,LINETHICK0,PRECIS1;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
RSV2:=(RSV1-0.5)/5*EMA(C,21);
RSVK:=SMA(RSV2,3,1);
RSVD:=SMA(RSVK,3,1);
RSVJ:=RSVK*3-RSVD*2;
Kj:RSVK+EMA(C,21),COLORWHITE,LINETHICK1,PRECIS0;
Dj:RSVD+EMA(C,21),COLORYELLOW,LINETHICK1;
Jj:RSVJ+EMA(C,21),COLORRED;
LC := REF(CLOSE,1);
Aa1:=SMA(MAX(CLOSE-LC,0),6,1);
Bb1:=SMA(ABS(CLOSE-LC),6,1);
RSI:aa1/bb1*100,LINETHICK0,PRECIS1;
TYP := (HIGH + LOW + CLOSE)/3;
cci:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0,PRECIS1;
买:=(cci<-80 and cci>ref(cci,1)) and (rsi<40 and rsi>ref(rsi,1)) and (j<20) and j>0;
DRAWTEXT(买,L-0.01,’●买’),COLORMAGENTA;
卖:=(cci>90 and cci<ref(cci,1)) and (rsi>60 and rsi<ref(rsi,1)) and (j>80 and j<ref(j,1));
卖21:=ref(cci,1)>100 and ref(rsi,1)>70 and ref(j,1)>90 and (cci>ref(cci,1) or rsi>ref(rsi,1) or j>ref(j,1));
卖22:=cci>100 and j>90 and rsi>70 and (cci<ref(cci,1) or rsi<ref(rsi,1) or j<ref(j,1));
卖2:=卖21 or 卖22;
DRAWTEXT(卖,h+0.1,’●’),colorgreen;
DRAWTEXT(卖2,h+0.05,’●’),Coloryellow;
{j反推}
j11:=j;
j昨:=ref(j,1);
jx:=if(j1=-50,j11,if(j1=-49,j昨,j1));
xxx:=((9/7*jx-2*ref(k,1)+12/7*ref(d,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9);
YCJ:IF(C>LC,(REF(Aa1,1)*(9-1)-REF(Bb1,1)*(9-1)*RSI预设/100)/(RSI预设/100-1)+LC,LC+REF(Bb1,1)*(9-1)-REF(Aa1,1)*(9-1)/(RSI预设/100)),LINETHICK0,PRECIS1;
rYCJ:=(YCJ-ref(c,1));
rre:=(80-ref(rsi,1));
rzz:=rre/rycj;
rh:=h-ref(c,1);
rhh:rzz*rh+ref(rsi,1),LINETHICK0,PRECIS1;
jxxx:=(xxx-ref(c,1));
jje:=(100-ref(j,1));
jzz:=jje/jxxx;
jhh:jzz*rh+ref(j,1),LINETHICK0,PRECIS1;
xh:=(rhh>70 and jhh>100) or (rhh>80 and jhh>90);
jrhh:=xh and (j<jhh or rsi<rhh);
DRAWTEXT(jrhh,h+0.1,’◆’),colorred;
DRAWTEXTREL(450,30,’预设J值=100 J临界股价: ‘+NUMTOSTRN(xxx ,2)),LINETHICK1,Coloryellow;
DRAWTEXTREL(450,90,’预设R值=80 R临界股价: ‘+NUMTOSTRN(YCJ ,2)),LINETHICK1,Coloryellow;
DRAWTEXTABS(10,10,’图示:●=必卖’),LINETHICK1,colorgreen;
DRAWTEXTABS(10,30,’图示:●=指标应卖 ‘),LINETHICK1,Coloryellow;
DRAWTEXTABS(10,50,’图示:◆=指标超卖 ‘),LINETHICK1,colorred;

大智慧KDJ监控主图指标公式

 

大智慧多空概率主图指标公式

蓝线为做空概率为95%,红线为做空概率为68%,绿、紫线分别为做多概率为68%和95%,原博尔系统中无平衡点,为后加的以判别趋势和阶段支撑,而判别是否为顶、底部部的基本方法是平顶,在上升(或下降)过程中不管做多还是做空都是抬高(或下降)的,此时关注量能及附图指标的变化,尤其是负向威廉指标和乖离率。而在K线形态中,在底部出现的粉红色K线为机构净买入信号。

DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));
做空95:HHV((HIGH+LOW+OPEN+2*CLOSE)/5+H-L,5),colorblue;
做空68:HHV((HIGH+LOW+OPEN+2*CLOSE)/5*2-L,5),colorred;
平衡点:LLV((HIGH+LOW+OPEN+2*CLOSE)/5,3),colorgray,DOTLINE;
做多68:LLV((HIGH+LOW+OPEN+2*CLOSE)/5*2-H,8),colorgreen;
做多95:LLV((HIGH+LOW+OPEN+2*CLOSE)/5-H+L,8),colorfaabec;
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND f<0,1,0);
p1:=今小昨;
今小前:=IF(C<REF(O,2) AND f<0,1,0);
p2:=今小前;
stickline(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,open,CLOSE,6,0),COLORMAGENTA;
stickline(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,open,CLOSE,3,0),COLORGREEN;

大智慧多空概率主图指标公式