大智慧买入必涨主图指标公式

成本:MAXCYC,colorff9900;
趋势:ma(c,90),colorred;
MA14:MA(CLOSE,14);
码:cost(50),coloryellow;
diff:=EMA(CLOSE,12)-EMA(CLOSE,26);
dea:=EMA(diff,9);
多头:STICKLINE(diff>dea,C,O,5,0),colorred;
STICKLINE(diff>dea,H,L,0,0),colorred;
空头:STICKLINE(diff<=dea,C,O,5,0),colorgray;
STICKLINE(diff<=dea,H,L,0,0),colorgray;
DRAWTEXT(CROSS(diff,dea),L-0.2,’买入‘),colorwhite;
diff1:=EMA(CLOSE,12)-EMA(CLOSE,26);
dea1:=EMA(diff1,9);
多头1:STICKLINE(diff1>dea1,C,O,5,0),colorred;
STICKLINE(diff>dea1,H,L,0,0),colorred;
空头1:STICKLINE(diff1<=dea1,C,O,5,0),colorgray;
STICKLINE(diff1<=dea1,H,L,0,0),colorgray;
DRAWTEXT(CROSS(diff1,dea1),L-0.2,’买入’),colorwhite;

大智慧买入必涨主图指标公式

 

大智慧定位散户主图指标公式

jnyy:=(ma(c,5)+ma(c,13)+ma(c,21)+ma(c,32))/4;
成本差:=ma(jnyy,22);
压力:=成本差+2*std(jnyy,22);
支撑:=成本差-2*std(jnyy,22);
var1:=ema(c,3);
ma5:=ma(c,5);
var2:=ema(c,8);
ma21:=ema(c,21);
aa1:=c*2-ref(c,3/2);
aa2:=ref(c,3/2)*2-c;
短期对称:=(aa1+aa2)/2;
定位指南针:hhv(短期对称,9/2),colorffffff;
m1:=l*2-ref(h,27/2);
m2:=ref(h,27/2)*2-l;
m3:=(m1+m2)/2;
中期对称:=forcast(m3,21);
趋势判断:=ma(m3,15);
sm:=ema(jnyy,21);
短定位:dma(sm,c/指支撑),pointdot,Linethick3,colorgreen;
中定位:dma(sm,c/m3-1),color3399ff;
长定位:dma(sm,c/短期对称-1),colorff0000;
partline(短定位,短定位>ref(短定位,1),RGB(255,0,255)),Linethick3,pointdot;
博弈点位:dma(sm,c/指压力-1),coloryellow;

大智慧定位散户主图指标公式

 

大智慧军师将军主图指标公式

x:=3;
y:=5;
a1:=cost(95);
a2:=cost(85);
a3:=cost(75);
a4:=cost(65);
a5:=cost(55);
a6:=cost(45);
a7:=cost(35);
a8:=cost(25);
a9:=cost(15);
a10:=cost(10);
a11:=cost(8);
a12:=cost(6);
a13:=cost(4);
a14:=cost(2);
b1:ma(a1,x),colorgray;
b2:ma(a2,x),colorgray;
b3:ma(a3,x),colorgray;
b4:ma(a4,x),colorgray;
b5:ma(a5,x),colorgray;
b6:ma(a6,x),colorgray;
b7:ma(a7,x),colorgray;
b8:ma(a8,x),colorgray;
b9:ma(a9,x),colorgray;
b10:ma(a10,x),colorgray;
b11:ma(a11,x),colorgray;
b12:ma(a12,x),colorgray;
b13:ma(a13,x),colorgray;
b14:ma(a14,x),colorgray;
dis1:=a1-a14;
dis2:=a2-a13;
dis3:=a3-a12;
dis4:=a4-a11;
dis5:=a5-a10;
dis6:=a6-a9;
dis0:=(a1+a2+a3+a4+a5+a6)/6;
dis00:ma(dis0,49),linethick3,colorblue;
向下:=if(dis00<ref(dis00,Y),1,0);
一直向上:=if(dis00>=ref(dis00,Y) and count(向下,50)<30,1,0);
红色将军:if(b14>=ref(b14,y)and b13 >= ref(b13,y) and b12 >= ref(b12,y) and b11 >= ref(b11,y) and b10 >= ref(b10,y) and 一直向上,1,0),colorred,linethick0;
stickline(红色将军,b14,b1,5,0),colorred;
hahaha1:if(b1>=ref(b1,y),1,0),linethick0;
stickline(hahaha1,b1,b3,5,0),ColorC0A6D1;
黄色军师:if(b1<ref(b1,Y) and b14>=ref(b14,Y) and b13>ref(b13,Y) and b12>ref(b12,Y) and b11>ref(b11,Y)and count(红色将军,70)<20 and count(红色将军,210)<40 and(c/hhv(c,500)<0.65 or c/hhv(c,1000)<0.65 or c/hhv(c,1500)<0.65 or c/hhv(c,2000)<0.65),1,0),coloryellow,linethick0;
stickline(黄色军师,b6,b11,4,0),coloryellow;
军师在此:=if(黄色军师 and count(黄色军师,50)<=1,1,0);
partline(1,军师在此,rgb(255,255,0));
drawtext(军师在此,a14-(a14*0.2),’军师在此’),coloryellow;
DRAWICON(军师在此,a14-(a14*0.04),7);
dis000:ma(dis0,49),linethick5,colorblue;
abc:ema(c,15),colorred,linethick1;
stickline(c<abc,h,l,0.4,2),COLORgreen;
stickline(c<abc,o,c,8,2),COLORgreen;
stickline(c>abc,h,l,0.4,0),colorred;
stickline(c>abc,o,c,8,0),colorred;

大智慧军师将军主图指标公式

 

大智慧短线稳赚主图指标公式

快线:EMA(EMA(EMA(EMA(CLOSE,3),3),3),3),LINETHICK2,COLORred;
慢线:EMA(REF(快线,1),3),LINETHICK2,COLOR00FFFF;
趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,65),3),3),3),3),LINETHICK2,colorblue;
VAR84:= (CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR85:= 100-ABS(VAR84);
VAR86:= 3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR87:= 3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR88:= 100-VAR87;
VAR89:= 100-VAR86;
VAR92:= MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR93:= 100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR94:= 100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR95:= VAR93<REF(VAR94,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VARA:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARB:= SMA(VARA,3,1);
VARC:= SMA(VARB,3,1);
探索:= EMA(3*VARB-2*VARC,3);
主力:= (-1)*(EMA(VAR89,1)-50)+50;
Z1:= MA(主力,9);
VARD:= (-1)*(EMA(VAR89,1)-50)+50;
VARE:= (-1)*(EMA(VAR89,12)-50)+50;
LCC:= REF(CLOSE,1);
RSI1:= SMA(MAX(CLOSE-LCC,0),6,1)/SMA(ABS(CLOSE-LCC),6,1)*100;
苦海:= EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6);
ZS:= MA(探索,3);
ZM:= MA(MA(探索,3),3);
A11:= 3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
黑马线:= EMA(A11,5);
A12:= (黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A4:= (CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
趋势线3:= MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2);
A5:= (HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
N:= 3;
VAR1:= REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:= SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:= EMA(VAR2,10);
VAR4:= LLV(LOW,33);
VAR5:= EMA(IF(LOW<=VAR4,VAR3,0),5);
VAR6:= REF(CLOSE,1);
VAR7:= SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
VAR8:= LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
VAR9:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR10:= VAR8 AND VAR9;
VAR11:= (2*CLOSE+HIGH+LOW)/4;
VAR12:= LLV(LOW,13);
VAR13:= HHV(HIGH,13);
VAR14:= LLV(LOW,1)=LLV(LOW,35) AND CLOSE>=OPEN*1.04;
VAR15:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR16:= EMA((VAR11-VAR12)/(VAR13-VAR12)*100,13);
VAR17:=(CLOSE-MA(CLOSE,6)/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
VAR19:= MA(CLOSE,13);
VAR20:= 100-ABS((CLOSE-VAR19)/VAR19*100);
VAR21:= LLV(LOW,75);
VAR22:= HHV(HIGH,75);
VAR23:= (VAR22-VAR21)/100;
VAR24:= SMA((CLOSE-VAR21)/VAR23,20,1);
VAR25:= SMA((OPEN-VAR21)/VAR23,20,1);
VAR26:= 3*VAR24-2*SMA(VAR24,15,1);
VAR27:= MA(HHV(HIGH,485),17);
VAR28:= MA(HHV(HIGH,222),17);
VAR29:= MA(HHV(HIGH,96),17);
VAR30:= MA(LLV(LOW,485),17);
VAR31:= MA(LLV(LOW,222),17);
VAR32:= MA(LLV(LOW,96),17);
VAR33:= MA((VAR30*0.96+VAR31*0.96+VAR32*0.96+VAR27*0.558+VAR28*0.558+VAR29*0.558)/6,17);
VAR34:= MA((VAR30*1.25+VAR31*1.23+VAR32*1.2+VAR27*0.55+VAR28*0.55+VAR29*0.65)/6,17);
VAR35:= MA((VAR30*1.3+VAR31*1.3+VAR32*1.3+VAR27*0.68+VAR28*0.68+VAR29*0.68)/6,17);
VAR36:= LLV(LOW,30);
VAR37:= MA((VAR33*3+VAR34*2+VAR35)/6*1.738,17);
VAR38:= VAR37;
VAR39:= LOW;
VAR40:= REF(LOW,1);
VAR41:= SMA(ABS(VAR39-VAR40),3,1)/SMA(MAX(VAR39-VAR40,0),N,1)*100;
VAR42:= MA(IF(CLOSE*1.35<=VAR38,VAR41*10,VAR41/10),N);
VAR43:= HHV(VAR42,30);
VAR45:= 3*VAR25-2*SMA(VAR25,15,1);
VAR46:= 100-VAR45;
VAR49:= REF(LOW,1)*0.9;
VAR50:= LOW*0.9;
VAR53:= CLOSE-REF(CLOSE,1);
VAR54:= MAX(VAR53,0);
VAR55:= ABS(VAR53);
VAR56:= SMA(VAR54,7,1)/SMA(VAR55,7,1)*100;
VAR57:= SMA(VAR54,13,1)/SMA(VAR55,13,1)*100;
VAR58:= BARSCOUNT(CLOSE);
VAR59:= SMA(MAX(VAR53,0),6,1)/SMA(ABS(VAR53),6,1)*100;
VAR60:= (-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR61:= (CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR62:= SMA((SMA(VAR61,4,1)-50)*2,3,1);
VAR63:= (INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR64:= SMA(VAR63,4,1);
VAR65:= SMA(VAR64,3,1);
VAR66:= (HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR68:= (HIGH+LOW+CLOSE)/3;
VAR69:= (VAR68-MA(VAR68,14))/(0.015*AVEDEV(VAR68,14));
VAR70:= (VAR68-MA(VAR68,70))/(0.015*AVEDEV(VAR68,70));
VAR71:= IF(VAR69>=150 AND VAR69<200 AND VAR70>=150 AND VAR70<200,10,0);
VAR72:= IF(VAR69<=(-150) AND VAR69>(-200) AND VAR70<=(-150) AND VAR70>(-200),-10,VAR71);
VAR73:= (CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR74:= REVERSE(VAR73);
VAR75:= SMA(VAR73,3,1);
绝佳买点:=MA(IF(LOW<=VAR36,(VAR42+VAR43*2)/2,0),N);
跑:= FILTER(REF(黑马线,1)>90 AND A12<0,7);
买线:= EMA(CLOSE,2);
卖线:= EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
指滴恢:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
抄底:= CROSS(指滴恢,10) AND DATE<=10280531;
A1:= VOL=HHV(VOL,120);
A2:= CLOSE/OPEN>1.05;
TJ:= A1 AND A2;
龙:= VAR10;
买4:= VAR14;
AA1:= AMOUNT/VOL;
BB1:= LOW<AA1*0.9;
CC1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:= LOW<MA(CLOSE,5)*0.921;
EE1:= VOL<MA(VOL,5)*1.5;
FF1:= BB1 AND CC1 AND DD1 AND EE1;
买3:= FILTER(FF1,3) AND DATE<=10280530;
二十天最低跌幅:= HHV(CLOSE,20)/LLV(CLOSE,20);
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:= SMA(RSV,3,1);
D:= SMA(K,3,1);
J:= 3*K-2*D;
X:= LLV(J,2)=LLV(J,8);
买1:= CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3;
长期底部:= LLV(HIGH,30);
上:= SMA(LOW,5,2)*0.96;
短期底部:= LLV(HIGH,30)*0.93;
LC:= REF(CLOSE,1);
RSI:= SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
大顶:= VAR17>20 AND (VAR17<REF(VAR17,1));
VAR76:= (OPEN+LOW+HIGH+CLOSE)/4;
MAN:= SMA(HIGH,21,2)*1.05;
短底2:= EMA(VAR76,5);
支撑:= HHV(短底2,60);
VAR77:= (HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR78:= SMA(VAR77,5,1);
VAR79:= SMA(VAR78,8,1);
VAR80:= CROSS(VAR78,VAR79) AND VAR79<5;
VAR81:= CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR80;
VAR82:= IF(CLOSE>1000,VAR80,VAR81);
黑马起步:= VAR82;
逃:= FILTER(HIGH>支撑 AND CLOSE<支撑 AND CLOSE/OPEN>0-1.06 AND CLOSE<OPEN,5);
逃命:= 黑马起步>0;
选逃:= FILTER(逃命 OR 逃 OR CROSS(84,RSI) OR 大顶,3);
上线:= SMA(CLOSE,6.5,1);
下线:= SMA(CLOSE,13.5,1);
散户:= SMA(VAR75,3,1);
新庄:= SMA(散户,3,1);
高抛:= CROSS(新庄,散户) AND 新庄>75;
买:= CROSS(买线,卖线);
卖:= CROSS(卖线,买线);
大黑马:= CROSS(趋势线3,0) AND 黑马线<40;
大买:= FILTER(绝佳买点>30000,5);
选底:= FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=长期底部 AND CLOSE/OPEN>1.03,3);
稳赚10买:= FILTER(买3 OR 选底,3) AND COUNT(买1+买4+龙,3)>0;
资金进场:= VAR95 AND COUNT(VAR95,30)=1;
STICKLINE(买线>=卖线 ,LOW,HIGH,1,0),COLOR0000FF;
STICKLINE(买线>=卖线 ,CLOSE,OPEN,4.5,0),COLOR0000AA;
STICKLINE(买线>=卖线 ,CLOSE,OPEN,4,0),COLOR0000CC;
STICKLINE(买线>=卖线 ,CLOSE,OPEN,3,0),COLOR0000CC;
STICKLINE(买线>=卖线 ,CLOSE,OPEN,2,0),COLOR0000EE;
STICKLINE(买线<卖线 ,CLOSE,OPEN,4.5,0),COLORAAAA00;
STICKLINE(买线<卖线 ,CLOSE,OPEN,4,0),COLORBBBB00;
STICKLINE(买线<卖线 ,CLOSE,OPEN,3,0),COLORCCCC00;
STICKLINE(买线<卖线 ,CLOSE,OPEN,2,0),COLOREEEE00;
STICKLINE(买线<卖线 ,LOW,HIGH,1,0),COLORFFFF00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,9*0.5,0),COLORFF5B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8*0.5,0),COLORFF6C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7*0.5,0),COLORFF7B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6*0.5,0),COLORFF9C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5*0.5,0),COLORFFBE00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.5*0.5,0),COLORFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5*0.5,0),COLORFFFF00;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,9*0.5,0),COLOR070084;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8*0.5,0),COLOR0000A3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7*0.5,0),COLOR0000B7;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6*0.5,0),COLOR0000CD;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,5*0.5,0),COLOR0000E9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3*0.5,0),COLOR0754E9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1.5*0.5,0),COLOR076EF3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1*0.5,0),COLOR077BF3;
STICKLINE(CLOSE>OPEN,OPEN,LOW,1*0.5,0),COLOR0726CA;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,1*0.5,0),COLOR0726CA;
STICKLINE(OPEN>CLOSE,CLOSE,LOW,1*0.5,0),COLORDE9100;
STICKLINE(OPEN>CLOSE,OPEN,HIGH,1*0.5,0),COLORDE9100;
选买:= FILTER(买3 OR 选底,3) AND COUNT(买1+买4+龙,3)>0 ;
STICKLINE(选买,CLOSE,HHV(HIGH,90)*0.94,0.3,0),COLORFF0000;
DRAWTEXT(选买,HHV(HIGH,90)*1,’稳赚’),COLORFF0000;
DRAWTEXT(选买,HHV(HIGH,90)*0.97,’10%买’),COLORFF0000;
DRAWTEXT(选逃,HIGH*1.04,’逃’),COLOR00FFFF;
DRAWTEXT(买,LOW*0.996,’买’),COLOR0000FF;
DRAWTEXT(卖,HIGH*1,’卖’),COLOR00FFFF;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.095,’大资金’),COLOR008000;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.06,’进场’),COLOR008000;
DRAWTEXT(跑,HIGH*1.02,’跑’),COLOR00FFFF;
DRAWTEXT(大黑马,LOW*0.98,’大黑马’),COLORFFFFFF;
DRAWTEXT(CROSS(新庄,散户) AND 新庄>75,HIGH*1.04,’抛’),COLOR00FFFF;
DRAWTEXT(大买,LOW*0.96,’大买’),COLOR0000FF;
DRAWTEXT(IF(选底,100,0),LOW*0.995,’底’),COLOR399C71;

大智慧短线稳赚主图指标公式

 

大智慧不错买卖指标公式

RSV:=(((CLOSE – LLV(LOW,9)) / (HHV(HIGH,9) – LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
RE:=CROSS(J,REF(J+0.01,1)) AND X AND J<19;
STICKLINE(RE,0,1,3,0),COLORYELLOW;
CSS:=((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100);
HH:=CROSS(20,EMA(CSS,3));
CE:=REF(HH,1);
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线趋势:IF(SS>13,MA(SS,2),SS)/6,colorf00ff0;
短线买点:IF(CROSS(短线趋势,1) AND (短线趋势<30),50,1),coloryellow,linethick3;
stickline(L>REF(H,1),L,REF(H,1),50,1001),color0000FF;
stickline(REF(L,1)>H,ref(L,1),H,50,1001),color00FF00;
{红买绿卖}
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B:ZIG(3,50/5)*0.01,COLORWHITE;
G:MA(B,2),COLORYELLOW;
买:CROSS(B,G)*80,COLORRED,LINETHICK3;
卖:CROSS(G,B)*80,COLORGREEN,LINETHICK3;
E:=REF(INDEXC,1);
F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);
VAR10:=F AND F<8;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
MM:=A AND 买 AND VAR10 AND VAR14 ;
DRAWTEXT(卖=80,B*500,’★卖’),LINETHICK2,COLORGREEN;
DRAWTEXT(买=80,B*500,’★买’),LINETHICK2,COLORRED;

大智慧不错买卖指标公式

 

大智慧历史量比指标公式

分钟:=if(currenttime<=93000,0,
if(currenttime<=113000,(INTPART((TIMETOT0(currenttime)-34200)/60)),
if(currenttime>113000 and currenttime<=130000,120,
if(currenttime>1300000 and currenttime<=150000,(INTPART((TIMETOT0(currenttime)-34200)/60))-90,
if(currenttime>150000,240,(INTPART((TIMETOT0(currenttime)-34200)/60))-90)))));
量比:VOL/分钟/(SUM(REF(VOL,1),5)/1200);

大智慧历史量比指标公式

 

大智慧急速超跌主图指标公式

STICKLINE(c>0,h,l,5.5,0),color000000;
急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
红色持股:STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),5,0),color0000AA;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),4.5,0),color0000BB;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),4,0),color0000CC;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3.5,0),color0000DD;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,0),color0000EE;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2,0),color0000FF;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),1,0),color0000FF;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),0,0),color0000FF;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,LOW,HIGH,0.1,0),color0000FF;
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
青色观望:STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),5,0),colorAAAA00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),4.5,0),colorBBBB00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),4,0),colorCCCC00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3.5,0),colorDDDD00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),colorEEEE00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2,0),colorFFFF00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),1,0),colorFFFF00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0,0),colorFFFF00;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,LOW,HIGH,0.1,0),colorFFFF00;
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
黄色短买:STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),5.2,0),color33AACC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),5,0),color33BBCC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4.5,0),color33CCCC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,0),color33DDCC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),color33EECC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),color33FFCC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0),color33FFCC;
DRAWTEXT(VAR19,REF(CLOSE,1),’←短买’),color33FFCC;
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
品红离场:STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),5,0),colorFF33FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),4.5,0),colorFF44FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),4,0),colorFF55FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.5,0),colorFF66FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),colorFF77FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0),colorFF88FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),colorFF99FF;
DRAWTEXT(VAR1A,REF(CLOSE,1)+0.1,’←离场’),colorFF99FF;
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
辰星线: (20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211;
牵牛线:MA(CLOSE,26),colorFF00FF;
等待:=IF(MA3>辰星线,辰星线,MA3);
AA:=FORCAST(CLOSE,21);
BB:=FORCAST(CLOSE,111);
中轨:=MA(CLOSE,26);
上轨:=中轨+STD(CLOSE,20);
下轨:=中轨-STD(CLOSE,20);
上极限:(中轨+2*STD(CLOSE,20)),color00FFFF;
下极限:(中轨-2*STD(CLOSE,20)),colorFFFF00;
CJ1:=CROSS(AA,BB);
D2:=EMA(辰星线,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
K2:=EMA(K1,2);
K3:=EMA(K2,2);
HZD:=MA(辰星线,3);
CJ2:=CROSS(辰星线,K3);
YTYH1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
YTYH2:=SMA(YTYH1,3,1);
YTYH3:=SMA(YTYH2,9,1);
YTYH4:=CROSS(YTYH3,YTYH2);
YTYH5:=YTYH3>80 OR YTYH2>80;
YTYH6:=YTYH4 AND YTYH5;
YTYH7:=EMA(AMOUNT/VOL/100,3);
YTYH8:=EMA(YTYH7,89);
YTYH9:=EMA(YTYH7,89)*0.8;
VRA:=YTYH9*0.8;
VRB:=LOW<VRA AND CLOSE>REF(CLOSE,1)*1.02;
离场:IF(VAR1A,1,0),LINETHICK0;
短买:IF(VAR19,1,0),LINETHICK0;

大智慧急速超跌主图指标公式

 

大智慧绝佳点主图指标公式

MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
G1:=IF(-MMS>95,0,20);UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0
AND G1)+1);
KS:=(((CLOSE – EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 –
100));
KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS
/ 10) + EMA(CLOSE,10)),3);AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=(EMA(AA,5)
);SSL:=EMA(CLOSE,3);MMV:=EMA(((SLOPE(CLOSE,22) * 20) +
CLOSE),55);
MM:=MA(MMV,1);STICKLINE(((SSL>MM)),SSL,MM,0.01,0),COLORRED;
SA:=(MM*0.985);SS:=(MA(CLOSE,5));DD:=(MA(CLOSE,13));GG:=(MA(CLOSE,21));
绝佳点:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF;
能量线:=DMA(((CLOSE
+ OPEN) / 2),(VOL / (SMA(VOL,4,1)
*4)));上开:=O;上收:=C;
上高:=H;上低:=L;JJ:=(上开+上高+上低)/3;A:=EMA(JJ,4);智能黄金线:A,COLORYELLOW,LINETHICK1;
B:=REF(A,1);STICKLINE(((SSL<MM)),绝佳点,智能黄金线,0.01,0),COLORFFFF00;
VA1:=EMA(上收,8);VA2:=EMA(上收,20);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,’★绝佳’)
,LINETHICK2,COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,’★卖’);
DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND
智能黄金线>REF(智能黄金线,1),VA1*0.97,’★买’),COLOR00FF00;
选手A:=MA(上收,3);箱顶A:=MA(REF(HHV(上收,6),1),3);
箱底A:=MA(REF(LLV(上收,3),1),3);T1:=MA(上收,20)>=REF(MA(上收,20),1);
T2:=CROSS(选手A,箱底A)
AND 箱顶A/箱底A>100/100 AND T1;
T3:=CROSS(箱顶A,选手A) AND
箱顶A/箱底A>100/100;
选手:=MA(上收,2);箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
T4:=CROSS(选手,箱底)
AND 箱顶/箱底>110/100;
T5:=CROSS(箱顶,选手) AND
箱顶/箱底>110/100;
VAR1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
VAR2:=SMA(VAR1,3,1);VAR3:=SMA(VAR2,3,1);VAR4:=SMA(VAR3,3,1);
DRAWTEXT(CROSS(VAR3,VAR4)AND(C>=O)AND
VAR3<40 AND
UOO>0,LOW*0.96,’★’),COLORF00FF0;
STICKLINE(C>=O,C,O,5,0),COLORRED;STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,5,0),COLORGREEN;STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
买线:=EMA(C,2);卖线:=EMA(SLOPE(C,21)*20+C,42);
DRAWTEXT(CROSS(买线,卖线)AND
箱顶>=REF(箱顶,1),LOW*0.95,’★跟’),COLOR00FFFF;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,3,0),COLOR00FFFF;

大智慧绝佳点主图指标公式

 

大智慧黄金踏浪指标公式

强度系数: (EMA(CLOSE,21)-EMA(CLOSE,89))*5, COLORSTICK;
黄金踏浪线: EMA(HIGH+LOW+2*CLOSE/4,21)*10-EMA(HIGH+LOW+2*CLOSE/4,89)*10, CROSSDOT;
移动平均线: SMA(黄金踏浪线,5,1);强度系数: (EMA(CLOSE,21)-EMA(CLOSE,89))*5, COLORSTICK;
黄金踏浪线: EMA(HIGH+LOW+2*CLOSE/4,21)*10-EMA(HIGH+LOW+2*CLOSE/4,89)*10, CROSSDOT;
移动平均线: SMA(黄金踏浪线,5,1);

大智慧黄金踏浪指标公式