大智慧准确率极高的成交量指标公式

VOLUME:VOL,VOLSTICK;
主力启动线:MA(VOLUME,5),COLORRED,LINETHICK2;
主力洗盘线:MA(VOLUME,35),COLORYELLOW,LINETHICK2;
资金异动线:MA(VOLUME,135),COLORBLUE,LINETHICK2;
出击:STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)),0,VOL,2,0),COLORYELLOW;
启动:STICKLINE(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) AND REF(VOL,2)<REF(资金异动线,2))),0,VOL,3,0),COLORGREEN;
V1:=CLOSE/REF(CLOSE,3)>=1.1;
V2:=BACKSET(V1,2);
V3:=REF(CLOSE,3)*1.1;
V4:=CROSS(C,V3);
OK:STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,5,0),COLORRED;
COND:(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)))
OR (主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) OR REF(VOL,2)<REF(资金异动线,2))))
OR (V2 AND COUNT(V2,2)=1),LINETHICK0;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长期线:=A+100;
短期线:=B+100;
中期线:=D+100;
见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线));
顶部区域:=(中期线=80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4;
顶部:=FILTER(顶部区域,4);
STICKLINE( {见顶 OR} 顶部,VOL,VOL*1.1,20,1 ),COLORBLUE,LINETHICK2;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
STICKLINE( CROSS(84,VAR7),VOL,VOL*1.05,20,1 ),COLOR0099FF,LINETHICK2;
均势一:=(((((((((CLOSE + REF(CLOSE,1)) + REF(CLOSE,2)) + REF(CLOSE,3)) + REF(CLOSE,4)) + REF(CLOSE,5)) + REF(CLOSE,6)) + REF(CLOSE,7)) + REF(CLOSE,8)) / 9);
均势二:=((((CLOSE + REF(CLOSE,1)) + REF(CLOSE,2)) + REF(CLOSE,3)) / 4);
趋势一:=((((均势一 – REF(均势一,1)) / REF(均势一,1)) * 1000) + 50);
趋势二:=((((均势二 – REF(均势二,1)) / REF(均势二,1)) * 1000) + 50);
波段高位:=(CROSS(趋势一,趋势二) AND (COUNT((CLOSE > REF(HIGH,1)),12) > 5));
STICKLINE(波段高位,VOL,VOL*1.08,20,1 ),COLORGREEN,LINETHICK2;
选股公式:XG:(BACKSET(CLOSE/REF(CLOSE,3)>=1.1,2) AND
COUNT(BACKSET(CLOSE/REF(CLOSE,3)>=1.1,2),2)=1);

大智慧准确率极高的成交量指标公式

 

大智慧第二天必涨停指标公式

LONG:=26;
SHORT:=12;
M:=9;
DIF:EMA(CLOSE,SHORT) – EMA(CLOSE,LONG);
DEA:EMA(DIF,M),COLORBLUE,LINETHICK3;
MACD:2*(DIF-DEA),COLORSTICK;
A4:=BARSLAST(ref(cross(dif,dea),1));
B1:=ref(c,A4+1)>c and ref(dif,A4+1)<dif and cross(dif,dea);
DRAWTEXT(FILTER(B1>0,5),dif+0.2,’背离‘),COLORyellow;
VAR1C:=(HIGH – MIN(OPEN,CLOSE));
VAR2C:=(CLOSE – OPEN);
VAR3C:=(MIN(OPEN,CLOSE) – LOW);
VAR4C:=(HIGH – LOW);
VAR5C:=((VOL * VAR1C) / VAR4C);
VAR6C:=((VOL * VAR2C) / VAR4C);
VAR7C:=((VOL * VAR3C) / VAR4C);
VAR8C:=((VAR5C – VAR6C) – VAR7C);
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 10),4) / SUM((VOL * 200),4));
VARB:=(INTPART((VARA * 10)) / 10);
VARC:=(SUM(((CLOSE * VOL) * 10),7) / SUM((VOL * 200),7));
VARD:=(INTPART((VARC * 10)) / 10);
VARE:=(SUM(((CLOSE * VOL) * 10),28) / SUM((VOL * 200),28));
VARF:=(INTPART((VARE * 10)) / 10);
短线趋势:(EMA(CLOSE,5) – EMA(CLOSE,10)),COLORMAGENTA,LINETHICK2;
中线趋势:EMA(短线趋势,9),COLORMAGENTA,LINETHICK3;
VAR10:=((0 – ((10 * (HHV(CLOSE,5) – CLOSE)) / (HHV(CLOSE,5) – LLV(LOW,5)))) + 10);
VAR11:=((0 – ((10 * (HHV(CLOSE,10) – CLOSE)) / (HHV(CLOSE,10) – LLV(LOW,10)))) + 10);
VAR12:=((0 – ((10 * (HHV(CLOSE,20) – CLOSE)) / (HHV(CLOSE,20) – LLV(LOW,20)))) + 10);
VAR13:=((0 – ((10 * (HHV(CLOSE,30) – CLOSE)) / (HHV(CLOSE,30) – LLV(LOW,30)))) + 10);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 – VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 – VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
短线指标:IF(((((CROSS(短线趋势,中线趋势) AND (短线趋势 < 0)) AND (中线趋势 < (0 – 0.2))) AND (VAR11 > 45)) AND (VAR16 > 0)),0.3,0.1),COLOR66FF00;

大智慧第二天必涨停指标公式

 

大智慧个股与指数对比指标公式

bb:=1000*(c-ref(c,1))/ref(c,1);
DD:=1000*(O-REF(O,1))/REF(O,1);
aa:=1000*(indexc-ref(indexc,1))/ref(indexc,1);
EE:=1000*(INDEXO-REF(INDEXO,1))/REF(INDEXO,1);
cc:=(bb-aa);
ff:=(dd-ee);
b1:=sum(cc,0);
stickline(cc>0,ref(b1,1),b1,7,1),colorred;
stickline(cc<0,ref(b1,1),b1,7,1),colorgreen;
开盘价:ff,LINETHICK0;
收盘价:cc,LINETHICK0;
涨幅:(收盘价-REF(收盘价,1))/REF(收盘价,1)*100%,LINETHICK0;

大智慧个股与指数对比指标公式

 

大智慧长线波段主图指标公式

40,POINTDOT;
80,POINTDOT;
{Var1:=IF(DATE<1031230 AND DATE>900101,1,0);}
Var2:=1/WINNER(CLOSE);
Var3:=MA(CLOSE,13);
Var4:=100-ABS((CLOSE-Var3)/Var3*100);
Var5:=LLV(LOW,75);
Var6:=HHV(HIGH,75);
Var7:=(Var6-Var5)/100;
Var8:=SMA((CLOSE-Var5)/Var7,20,1);
Var9:=SMA((OPEN-Var5)/Var7,20,1);
VarA:=3*Var8-2*SMA(Var8,15,1);
VarB:=3*Var9-2*SMA(Var9,15,1);
VarC:=100-VarB;
VarD:=REF(LOW,1)*0.9;
VarE:=LOW*0.9;
VarF:=(VarE*VOL+VarD*(CAPITAL-VOL))/CAPITAL;
Var10:=EMA(VarF,30);
Var11:=CLOSE-REF(CLOSE,1);
Var12:=MAX(Var11,0);
Var13:=ABS(Var11);
Var14:=SMA(Var12,7,1)/SMA(Var13,7,1)*100;
Var15:=SMA(Var12,13,1)/SMA(Var13,13,1)*100;
Var16:=BARSCOUNT(CLOSE);
Var17:=SMA(MAX(Var11,0),6,1)/SMA(ABS(Var11),6,1)*100;
Var18:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var1A:=SMA((SMA(Var19,4,1)-50)*2,3,1);
Var1B:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var1C:=SMA(Var1B,4,1);
Var1D:=SMA(Var1C,3,1);
Var1E:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var1F:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
Var20:=REVERSE(Var1F);
Var21:=SMA(Var1F,3,1);
移动平均: SMA(Var21,3,1){*Var1}, COLORRED;
参考线: SMA(移动平均,3,1){*Var1},colorcyan;
买入: IF(CROSS(移动平均,参考线) AND 移动平均<30,33,0){*Var1},COLORcyan,LINETHICK2;
清仓: IF(CROSS(参考线,移动平均) AND 参考线>75,68,100){*Var1} ,COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(移动平均,参考线) AND 移动平均<20,33,’☆–底位金叉‘) , COLORWHITE;
XG:if(CROSS(移动平均,参考线) AND 移动平均<40,48,0),stick,linethick2,colorff00ff;
DRAWTEXT(xg,47,’☆←快,主升浪‘),LINETHICK2,COLORff00ff;
aG:if(CROSS(移动平均,参考线) AND 移动平均<70 AND 移动平均>40,移动平均*1.1,0),stick,linethick2,colorred;
DRAWTEXT(ag,移动平均*1.1,’☆←快,二次起飞’),LINETHICK2,COLORred;

大智慧长线波段主图指标公式

 

大智慧今来股套追买主图指标公式

今来:=EMA(C,3);
股套:=EMA(C,5);
今来S13:EMA(股套,5),COLORWHITE;
股套S13:HHV(MA(H,13),13),COLORRED,LINETHICK2;
金来股套S13:LLV(MA(H,13),1),COLORGREEN,LINETHICK2;
varA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
varB:=EMA(0.667*REF(varA,1)+0.333*varA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(varA>=varB AND varA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,’买入‘);
varC:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),HIGH,2);
var1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
var2:=REF(var1,1);
var3:=SMA(MAX(var1-var2,0),10,1)/SMA(ABS(var1-var2),10,1)*100;
var4:=FILTER(IF(COUNT(var3<20,5)>=1 AND COUNT(var1=LLV(var1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
DRAWICON(var4,LOW,1);
var5:=FILTER(今来S13>REF(今来S13,1) AND 股套S13<REF(C,1),11);
DRAWTEXT(var5,L*0.98,’追涨‘);
var6:=REF(CLOSE,1);
var7:=SMA(MAX(CLOSE-var6,0),6,1)/SMA(ABS(CLOSE-var6),6,1)*100;
DRAWTEXT(CROSS(84,var7),H*1.03,’逃顶‘),COLORYELLOW ;

大智慧今来股套追买主图指标公式

 

大智慧天潭主图指标公式

cyc8:CYC(8),COLORFF00FF,LINETHICK3,LAYER0;
cyc21:=cyc(21);
cyc60:=cyc(60);
cyc0:MAXCYC,COLORCYAN,LINETHICK3;
VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
主力吸筹:=VARBQ AND C>O AND H>=C AND L<=O;
VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
TYX3:=MA(REF(HHV((C+L+O+H)/4,40),1),3);
VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
绿买:varcQ,LINETHICK0;
VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
蓝抛:vardQ,LINETHICK0;
上轨:MA(REF(HHV(C,30),1),2),COLORWHITE;
下轨:MA(REF(LLV(C,30),1),2),COLORGRAY;
A1:=C=HHV(C,13);
A2:=BARSLAST(A1);
A3:=IF(A2>0,REF(C,A2),REF(C,A2));
A4:=CROSS(C,REF(A3,1));
一号旗:=A4 AND COUNT(A4,5)=1;
DRAWTEXT(一号旗=1,L-0.3,’蓝旗’),COLORBLUE;
B1:=C=HHV(C,21);
B2:=BARSLAST(B1);
B3:=IF(B2>0,REF(C,B2),REF(C,B2));
B4:=CROSS(C,REF(B3,1));
二号旗:=B4 AND COUNT(B4,5)=1;
DRAWTEXT(二号旗=1,L-0.4,’黄旗’),COLORYELLOW;
C1:=C=HHV(C,34);
C2:=BARSLAST(C1);
C3:=IF(C2>0,REF(C,C2),REF(C,C2));
C4:=CROSS(C,REF(C3,1));
三号旗:=C4 AND COUNT(C4,5)=1;
DRAWTEXT(三号旗=1,L-0.5,’粉旗’),COLORMAGENTA;
D1:=C=HHV(C,89);
D2:=BARSLAST(D1);
D3:=IF(D2>0,REF(C,D2),REF(C,D2));
D4:=CROSS(C,REF(D3,1));
四号旗:=D4 AND COUNT(D4,5)=1;
DRAWTEXT(四号旗=1,L-0.7,’五面八面彩旗’),COLORRED;
DRAWTEXT(CLOSE>上轨,LOW,’金’),COLORYELLOW;
STICKLINE(REF(count(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,5,0),COLORYELLOW;
TYX2:=MA(REF(HHV((C+L+O+H)/4,10),1),3);
STICKLINE(REF(count(C<TYX2,5)=5,1) AND C>TYX2 AND C>O,C,O,5,0),COLORBLUE;
TYX1:=MA(REF(HHV((C+L+O+H)/4,3),1),3);
STICKLINE(REF(count(C<TYX1,5)=5,1) AND C>TYX1 AND C>O,C,O,5,0), COLORE66878;
TYX4:=MA(REF(HHV((C+L+O+H)/4,1),1),3);
STICKLINE(REF(count(C<TYX4,5)=5,1) AND C>TYX4 AND C>O,C,O,5,0), COLORWHITE;
DRAWTEXTREL(600,975,’证券代码: ‘+STKLABEL+’ 证券名称: ‘+STKNAME+”),ColorFFAA00;
DRAWTEXTREL(0.00,120,’蓝旗,是指股票突破13天短期盘整趋势买入信号,是牛股的特征’),COLORblue,LINETHICK1;
DRAWTEXTREL(0.00,60,’粉旗,是指股票突破34天短期盘整趋势的买入信号,是牛股的特征’),COLORFF00FF,LINETHICK1;
DRAWTEXTREL(0.00,90,’黄旗,是指股票突破21天短期盘整趋势的买入信号,是牛股的特征’),COLORYELLOW,LINETHICK1;
DRAWTEXTREL(0.00,30,’红旗,是指股票突破89天长期盘整趋势的买入信号,是大牛股的主要特征’),COLORRED,LINETHICK1;

大智慧天潭主图指标公式

 

大智慧个股叠加大盘指标公式

INPUT:N(120,10,9999);
LL:=IF(BACKSET(BARSTATUS=2,N),INDEXL,HHV(INDEXH,N)*10);
T:=BACKSET(BARSTATUS=2,BARSLAST(LLV(LL,N)=LL )+1);{以大盘N天内的最低点作为叠加起点}
B:=BARSLAST(CROSS(T,0.5) );
CC:=REF(INDEXO,B)/REF(O,B);
DD1:=INDEXO/CC;
DD2:=INDEXH/CC;
DD3:=INDEXL/CC;
DD4:=INDEXC/CC;
STICKLINE( C>=O,H ,L , 0, 0),COLOR3344AA;
STICKLINE( C>=O,C ,O , 8, 0),COLOR3344AA;
STICKLINE( C<O,H ,L , 0, 0),COLOR338800;
STICKLINE( C<O,C ,O , 8, 0),COLOR338800;
STICKLINE(T AND DD1<DD4,DD1,DD4,6,0),COLORmagenta;
STICKLINE(T AND DD1<DD4,DD2,DD3,0,0),COLORmagenta;
STICKLINE(T AND DD1>=DD4,DD1,DD4,6,0),COLORFFAA66;
STICKLINE(T AND DD1>=DD4,DD2,DD3,0,0),COLORFFAA66;

大智慧个股叠加大盘指标公式

 

大智慧风雷九州指标公式

MSD:EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLORWHITE;
风险区:80,COLORFF85FF;
安全区:20,COLORYELLOW;
天线:100,COLORFFFF00,LINETHICK2;
地线:=0;
强弱线:50,COLORGREEN,POINTDOT;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60));
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF(VAR9>100,VAR9-100,0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6-VAR8)/(VAR11-VAR8)*100,13);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2);
趋势值:VAR13,COLORRED;
STICKLINE(VAR12-VAR13>0,VAR12,VAR13,8,0),COLORRED;
STICKLINE(VAR12-VAR13<0,VAR12,VAR13,8,0),COLOR00FF0F;
VARK1:=EMA(HHV(HIGH,500),21);
VARK2:=EMA(HHV(HIGH,250),21);
VARK3:=EMA(HHV(HIGH,90),21);
VARK4:=EMA(LLV(LOW,500),21);
VARK5:=EMA(LLV(LOW,250),21);
VARK:=EMA(LLV(LOW,90),21);
VARK7:=EMA((VARK4*0.96+VARK5*0.96+VARK*0.96+VARK1*0.558+VARK2*0.558+VARK3*0.558)/6,21);
VARK8:=EMA((VARK4*1.25+VARK5*1.23+VARK*1.2+VARK1*0.55+VARK2*0.55+VARK3*0.65)/6,21);
VARK9:=EMA((VARK4*1.3+VARK5*1.3+VARK*1.3+VARK1*0.68+VARK2*0.68+VARK3*0.68)/6,21);
VARKA:=EMA((VARK7*3+VARK8*2+VARK9)/6*1.738,21);
VARKB:=REF(LOW,1);
VARKC:=SMA(ABS(LOW-VARKB),3,1)/SMA(MAX(LOW-VARKB,0),3,1)*100;
VARKD:=EMA(IF(CLOSE*1.35<=VARKA,VARKC*10,VARKC/10),3);
VARKE:=LLV(LOW,30);
VARKF:=HHV(VARKD,30);
VARK10:=IF(MA(CLOSE,58),1,0);
火焰山: EMA(IF(LOW<=VARKE,(VARKD+VARKF*2)/2,0),3)/618*VARK10;
火焰: STICKLINE(火焰山>0,0,火焰山,4,1);
今量: 火焰山;
STICKLINE(火焰山>0,0,今量*1.2,8,0), COLOR0000FF;
STICKLINE(火焰山>0,0,今量*0.8,8,0), COLOR0066FF;
STICKLINE(火焰山>0,0,今量*0.6,8,0) ,COLOR0099FF;
STICKLINE(火焰山>0,0,今量*0.4,8,0) ,COLOR00CCFF;
STICKLINE(火焰山>0,0,今量*0.2,8,0) ,COLOR00FFFF;

大智慧风雷九州指标公式

 

大智慧有庄则灵主图指标公式

ma5:MA(CLOSE,5),colorf00ff0;
ma13:MA(CLOSE,13),colorwhite;
ma60:MA(CLOSE,60),linethick1,colorred;
ma90:ma(c,90),linethick2,colorf0f000;
ma120:MA(CLOSE,120),color00ff00;
aa:=cross(ma(c,5),ma(c,20)) and cross(ma(c,5),ma(c,30)) and cross(ma(c,5),ma(c,60));
bb:=ma(c,60)>ma(c,10) and cross(ma(c,10),ma(c,30)) and ma(c,30)>ma(c,20) and abs(ma(c,60)-ma(c,20))/ma(c,20)<0.05;
cc:=ma(c,30)>ma(c,5) and cross(ma(c,5),ma(c,20)) and ma(c,20)>ma(c,10);
dd:=abs((ma(c,5)-ma(c,10))+(ma(c,10)-ma(c,20))+(ma(c,20)-ma(c,30)))<0.02 and ma(c,5)>ref(ma(c,5),1) and ma(c,10)>ref(ma(c,10),1);
ee:=ma(c,20)>ma(c,5) and cross(ma(c,5),ma(c,10)) and ma(c,10)>ma(c,60) and abs(ma(c,20)-ma(c,60))/ma(c,60)<0.05;
ff:=aa or bb or cc or dd or ee ;
天堂星雷达:=ff and FILTER( ff,8);
drawicon(天堂星雷达,l,1);
drawtext(天堂星雷达,l*0.958,’庄现’),colorwhite;
stickline(天堂星雷达,h,l,0.5,0),colorred;
stickline(天堂星雷达,o,c,6,0),linethick2,colorred;
aa1:=AMOUNT/vol;
bb1:=l<aa1*0.9;
cc1:=(c-ref(c,1))/ref(c,1)*100>1.2;
dd1:=l<ma(c,5)*0.921;
ee1:=vol<ma(v,5)*1.5;
ff1:bb1 and cc1 and dd1 and ee1;
drawtext(ff1,l*0.99,’庄影’),COLORyellow;
stickline(ff1,h,l,0.5,0),COLORyellow;
stickline(ff1,o,c,6,0),linethick2,COLORyellow;

大智慧有庄则灵主图指标公式