大智慧海底寻宝指标公式

Var1:=100*(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21));
Var2:=100*(INDEXC-LLV(INDEXL,21))/(HHV(INDEXH,21)-LLV(INDEXL,21));
海面情况: SMA(Var1,3,1), COLORB0FFFF,linethick0;
下潜深度: SMA(Var2,3,1),LINETHICK1 ,COLORGREEN;
有暗礁:IF(CROSS(93,海面情况),97,100),COLOR55AAFF,linethick1;
DRAWGBKLAST(c>0,STRIP(RGB(50,10,0),RGB(10,60,0),0));
DRAWTEXT(CROSS(93,海面情况),90,’▲有暗礁。转航’), LINETHICK2 ,colorf0f000;
STICKLINE(下潜深度<12 , 0,16 ,8 , 0),COLOR55AAFF;
海底宝物:IF(CROSS(12,下潜深度),3,0),color00cccc,linethick0;
DRAWTEXT( 海底宝物=3, 32,’有宝物’),ALIGN1;
drawicon(海底宝物,43,12),ALIGN1;
a:=c/ref(c,1)>=1.099;
b:=o=l and h=c;
d:=v < ma(v,5) and v < ref(v,1);
印钞机:IF((a and b and d and count(a and b and d,20)=1),100,0),stick,color00cccc,linethick3;

大智慧海底寻宝指标公式

 

大智慧就是不一样MACD指标公式

SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLORWHITE;
DEA:EMA(DIFF,7),COLORYELLOW;
MACD:(DIFF-DEA)*2,COLORSTICK;
PARTLINE(CROSS(DIFF,DEA) AND DIFF<-0.1,15),COLORYELLOW,LINETHICK4,CROSSDOT;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,0),COLORYELLOW,LINETHICK0;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
PARTLINE(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28),COLORFF00FF,LINETHICK4,CROSSDOT;
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,0),COLORFF00FF,LINETHICK0;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
PARTLINE(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40),COLORRED,LINETHICK4,CROSSDOT;
背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40,0),COLORRED,LINETHICK0;
势: DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORGREEN;{,COLORRED;}
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
PARTLINE(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66),COLORF08000,LINETHICK4,CROSSDOT;
顶背离_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66,0),COLORF08000,LINETHICK0;
压: DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFBB99;
A3:=CROSS(DIFF,DEA) AND DEA<0;
PARTLINE(FILTER(COUNT(A3,21)=2,10),53),COLORWHITE,LINETHICK4,CROSSDOT;
零下二次金叉_:IF(FILTER(COUNT(A3,21)=2,10),53,0),COLORWHITE,LINETHICK0;
DRAWICON(CROSS(DIFF,DEA) ,DIFF,7),ALIGN1;
DRAWICON(CROSS(DEA,DIFF) , DEA,8),ALIGN1;
金叉:if(CROSS(DIFF,DEA),diff,0),color00ff00,stick,linethick1;
{死叉:if(CROSS(DEA,DIFF),diff,0),colorff0099,stick,linethick1;}
选股:二次金叉>0 or 低位金叉>0 or 底背离>0;
0,colorgray;
DRAWICON(二次金叉>0 or 低位金叉>0 or 底背离>0,1,10);

大智慧就是不一样MACD指标公式

 

大智慧一个非常直观的成交量指标公式

虚拟量:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,MAX(VOL,DYNAINFO(17)*REF(MA(VOL,5),1)),0);
STICKLINE(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VOL,MAX(VOL,DYNAINFO(17)*REF(MA(VOL,5),1)),7,-21),COLOR00C0C0,DOTLINE,LAYER7;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交量:VOL,POINTDOT,COLORYELLOW;
买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
卖盘:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
成交量比:买盘/VOL*100,COLORWHITE;
VAR22:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
获利盘: WINNER(CLOSE)*100;
VAR33:=SMA(VAR22,3,1);
VAR44:=SMA(VAR33,9,1);
VAR55:=3*VAR33-2*VAR44;
VAR66:=VOL;
量比: DYNAINFO(17);
涨幅: (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
换手: VOL/CAPITAL*100;
VAR77:=SUM(换手,30);
VAR88:=LLV(INDEXL,5);
VAR99:=HHV(INDEXH,5);
VARAA:=EMA((INDEXC-VAR88)/(VAR99-VAR88)*100,4);
VARBB:=MA(EMA(0.667*REF(VARAA,1)+0.333*VARAA,2),9);
VARCC:=MA(VARBB,30);
VARDD:=EMA(获利盘,4);
本盘亿股: CAPITAL/1000000;
VARF:=(涨幅>VARDD AND 角度<-30 AND 涨幅>3);
CROSS(VARBB,VARCC) AND VARCC<29;
CROSS(VARCC,VARBB) AND VARCC>58;
STICKLINE(VOL AND VAR33>VAR44,0,VOL,7,1),COLORRED;
STICKLINE(VOL AND VAR33<=VAR44,0,VOL,7,1),COLORCYAN;
STICKLINE(买盘>0,0,买盘,6,0),COLORRED;
STICKLINE(卖盘>0,0,卖盘,5.5,0),COLOR00FF00;

大智慧一个非常直观的成交量指标公式

 

大智慧强势主升选股指标公式

{站上上轨}
上轨:=IF(1.1>SMA(CLOSE,2,1)/SMA(CLOSE,13,2)>1.05,SMA(HIGH,21,5)*1.05,SMA(HIGH,21,2)*1.05);
站上上轨:=C>上轨;
{PP超级资金流}
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
强势:=ZZLKP >ZSHTL;
去掉停牌:=DYNAINFO(17)>0;
XG:站上上轨 AND 强势 AND 去掉停牌;

大智慧强势主升选股指标公式

 

大智慧夹心MACD指标公式

SHORT:=12;
LONG:=26;
M:=9;
DIFF : EMA(CLOSE,SHORT) – EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD : 2*(DIFF-DEA), COLORSTICK;
STICKLINE(DEA>REF(DEA,1),-0.03,0.03,20,501),COLORRED;
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIFF-DEA);
UP:IF(DIFF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLOR33FF33,LINETHICK2;
DN:IF(DIFF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2),COLORAA00AA,LINETHICK2;

大智慧夹心MACD指标公式

 

大智慧金成五能指标公式

AA2:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量2:=IF(CLOSE>OPEN,AA2*(HIGH-LOW),IF(CLOSE<OPEN,AA2*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖量2:=IF(CLOSE>OPEN,0-AA2*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA2*(HIGH-LOW),0-VOL/2));
DDX2:=(买量2+卖量2)/(买量2-卖量2);
d12:=ema(abs(DDX2),60); {ddx绝对值60日指数平滑移动平均}
d22:=max(DDX2/d12+7.5,7.5);
d32:=min(DDX2/d12,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}
K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
DT:=VOL*K1/(K1+K2);
KT:=VOL-DT;
买量:=SUM(DT,1);
卖量:=SUM(KT,1);
DDX3:=EMA(买量-卖量,5)*VOL/sum(vol,60)*0.001;
d11:=ema(abs(DDX3),60); {ddx绝对值60日指数平滑移动平均}
d21:=max(DDX3/d11+7.5,7.5);
d31:=min(DDX3/d11,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}
TT:=(OPEN+HIGH+LOW+CLOSE)/4;
AA:=IF(BETWEEN(C,TT,H) OR C=O,VOL,0);
BB:=IF(BETWEEN(C,TT,L),VOL,0);
CC:=IF(AA AND BB,0,VOL/3);DDXJ:=10*(AA-(BB+CC))/IF(CAPITAL<1,SUM(VOL,13),CAPITAL);
jj:=(HIGH+LOW+CLOSE)/3;qj0:=vol/IF(HIGH=LOW,4,HIGH-LOW);
qj1:=IF(CAPITAL=0,qj0*(jj-MIN(CLOSE,OPEN)),qj0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
qj2:=IF(CAPITAL=0,qj0*(MIN(OPEN,CLOSE)-LOW),qj0*IF(HIGH=LOW,1,(jj-MIN(CLOSE,OPEN))));
qj3:=IF(CAPITAL=0,qj0*(HIGH-MAX(OPEN,CLOSE)),qj0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
qj4:=IF(CAPITAL=0,qj0*(MAX(CLOSE,OPEN)-jj),qj0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-jj)));
DDXQJ:=((qj1+qj2)-(qj3+qj4))/sum(vol,60);
dJ11:=ema(abs(DDXQJ),60); {ddx绝对值60日指数平滑移动平均}
dJ21:=max(DDXQJ/dJ11+7.5,7.5);
dJ31:=min(DDXQJ/dJ11,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}
dJ1:=ema(abs(DDXJ),60); {ddx绝对值60日指数平滑移动平均}
dJ2:=max(DDXJ/dJ1+7.5,7.5);
dJ3:=min(DDXJ/dJ1,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}
d1:=ema(abs("ddx.ddx"),60); {ddx绝对值60日指数平滑移动平均}
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10); {能量级别:当日ddx与60日平均值的比值,最高10.0}
能量启爆点1:IF(cross(d3,1.5) ,50 ,0),COLORRED,POINTDOT,LINETHICK0;
STICKLINE(能量启爆点1,0,30,4,0),COLORRED;
能量启爆点2:IF(cross(dJ3,1.5),50,0),COLORBROWN,POINTDOT,LINETHICK0;
STICKLINE(能量启爆点2,0,30,4,0),COLORBROWN;
能量启爆点3:IF(cross(dJ31,1.5),50,0),COLORYELLOW,POINTDOT,LINETHICK0;
STICKLINE(能量启爆点3,0,30,4,0),COLORYELLOW;
能量启爆点4:IF(cross(d31,9),50,0),COLORGREEN,POINTDOT,LINETHICK0;
STICKLINE(能量启爆点4,0,30,4,0),COLORGREEN;
能量启爆点5:IF(cross(d32,1.5),50,0),COLORBLUE,POINTDOT,LINETHICK0;
STICKLINE(能量启爆点5,0,30,4,0),COLORBLUE;

大智慧金成五能指标公式

 

大智慧K线形态主图指标公式

P1:=30;
P2:=6;
P3:=3;
P4:=250;
DRAWGBKLAST(CLOSE>0,’a008′);
if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
ee:=hhv(h,ddd);
TJTS:=BARSTATUS=2;
早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
i:=0;
IF 倾盆大雨 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’倾盆大雨,见顶信号‖’),ALIGN2; i:=i+0.03; END
IF 大阴烛 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’大阴烛,后市向淡,发生逆转‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 好友反攻 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’好友反攻,跌势已尽,要展开一段反弹行情‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 跳空缺口 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’跳空缺口,突破长期盘整,向上跳空,上涨行情开始;向下跳空,下跌行情开始‖’),COLORWHITE,ALIGN2; i:=i+0.03; END
IF 光脚阴线 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’光脚阴线,下跌信号‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 光头阳线 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’光头阳线,多方积极上攻态势,后市看涨‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 三只乌鸦 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’三只乌鸦站枝头,可能见顶回落‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 分离 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’分离,注意看涨分离和看跌分离‖’),COLORWHITE,ALIGN2; i:=i+0.03; END
IF 长下影 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 长上影 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’长上影,表明行情上档压力沉重,升势受阻‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 下跌三部曲 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’下跌三部曲,下跌信号‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 上升三部曲 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’上升三部曲,上涨信号‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 早晨之星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’早晨之星,见底回升‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 黄昏之星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’黄昏之星,见顶回落‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 十字星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’十字星,重要的警告信号,原趋势停顿或反转‖’),COLORWHITE,ALIGN2; i:=i+0.03; END
IF 长十字 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’长十字,重要的警告信号,原趋势停顿或反转‖’),COLORWHITE,ALIGN2; i:=i+0.03; END
IF 垂死十字 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’垂死十字,下跌信号‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 早晨十字星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’早晨十字星,上涨信号,见底回升‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 黄昏十字星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’黄昏十字星,趋势停顿或反转,下跌信号,见顶回落‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 射击之星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’射击之星,出现在短期的上升趋势,表明市场顶部就在眼前,可能见顶回落,可靠性低‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 倒转锤头 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’倒转锤头构成一个看涨信号,可能见底回升‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 锤头 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’锤头,可能见底回升,如有量配合,信号强烈‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 吊颈 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’吊颈,上升行情中见顶回落,顶部出现,见顶信号‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 平顶 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’平顶,意味行情摸高见顶,股价行将反转。但反转下跌力度较小‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 穿头破脚 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’穿头破脚,顶部出现,见顶回落信号‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 乌云盖顶 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’乌云盖顶,见顶回落信号‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 曙光初现 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’曙光初现,行情将演化为V型反转或止跌横盘趋势。后市见底回升‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 身怀六甲 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 十字胎 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’十字胎‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 平底 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’平底,行情探低见底,股价行将反转上升,但力度较小‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 大阳烛 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’大阳烛,在上升行情中出现,则意味着行情剧烈地向上攀升。在下跌行情中出现,则意味着行情剧烈地向上反弹‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 三个白武士 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’三个白武士,每日收盘价上移,表示可能见底回升‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 双飞乌鸦 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’双飞乌鸦,行情开始疲软将见顶回落‖’),COLORCYAN,ALIGN2; i:=i+0.03; END
IF 孕育线 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’孕育线,注意股价位置‖’),COLORWHITE,ALIGN2; i:=i+0.03; END
IF 多方炮 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’多方炮,在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号‖’),COLORRED,ALIGN2; i:=i+0.03; END
IF 出水芙蓉 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),’出水芙蓉,阳线穿过20、40、60日季均线,上攻势头初现‖’),COLORRED,ALIGN2; i:=i+0.03; END;
Var1:=(C+L+H)/3;
Var2:=eMA(Var1,6);
Var3:=eMA(Var2,5);
Var4:=eMA(Var3,12);
Var5:=eMA(Var4,5);
生命线:eMA(Var3,30),COLORRED,POINTDOT;
DRAWICON(C>=生命线,生命线,9);
DRAWICON(C<生命线,生命线,10);
a:=HHV(MA((L+H+C)/3,3),3);
b:=llv(MA((L+H+C)/3,3),10);
STICKLINE(DISPSTATUS=2,a,a,20,0),Coloryellow,linethick3;
DRAWTEXT(DISPSTATUS=2 ,a,NUMTOSTRN(a,3)),colorYELLOW;
STICKLINE(DISPSTATUS=2,b,b,20,0),ColorDB3FDD,linethick3;
DRAWTEXT(DISPSTATUS=2,b,NUMTOSTRN(b,3)),ColorDB3FDD;
k1:=llv(l,barslast(DISPSTATUS=1)+1);
aa1:=cost(95);
aa2:=cost(5);
ly:=(aa1-aa2)*100/(aa1+aa2);
DRAWTEXT(ly>ref(ly,1),k1,’▲’),Color0000FF;
N:=p1;{原码 N:=3;}
A1:=REF(H,N)=HHV(H,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR DISPSTATUS=2 OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR DISPSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
R1:=BACKSET(DISPSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(DISPSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
DRAWLINE(S2,H,S1,H,1),Color80FFFF; {★压力1:}
DRAWLINE(U2,L,U1,L,1),POINTDOT,Color00FFFF,linethick2;{★支撑1:}
DRAWLINE(S3,H,S2,H,1),ColorFF8000; {★压力2:}
DRAWLINE(U3,L,U2,L,1),POINTDOT,ColorFF8000;{★支撑2:}
DRAWLINE(S4,H,S3,H,1),Color0000FF;{★压力3:}
DRAWLINE(U4,L,U3,L,1),POINTDOT,Color0000FF;{★支撑3:};
DRAWICON(S2,H*1.01,9); DRAWICON(S3,H*1.01,9);
DRAWTEXT(S2,H*1.02,NUMTOSTRN(H,2)),COLORMAGENTA;
DRAWTEXT(S1,H*1.02,NUMTOSTRN(H,2)),COLORMAGENTA;
DRAWTEXT(S3,H*1.02,NUMTOSTRN(H,2)),COLORMAGENTA;
DRAWICON(U1,L*0.99,10); DRAWICON(U2,L*0.99,10);
DRAWICON(U3,L*0.99,10);DRAWICON(U4,L*0.99,10);
DRAWTEXT(U1,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;
DRAWTEXT(U2,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;
DRAWTEXT(U3,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;
DRAWTEXT(U4,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;
STICKLINE(open>=close ,close ,open,0,0 ),COLOR00FF00;
STICKLINE(open>=close ,close ,open,8,0 ),COLOR008800;
STICKLINE(open>=close ,close ,open,7,0 ),COLOR009900;
STICKLINE(open>=close ,close ,open,6,0 ),COLOR00AA00;
STICKLINE(open>=close ,close ,open,5,0 ),COLOR00BB00;
STICKLINE(open>=close ,close ,open,4,0 ),COLOR00CC00;
STICKLINE(open>=close ,close ,open,3,0 ),COLOR00DD00;
STICKLINE(open>=close ,close ,open,2,0 ),COLOR00EE00;
STICKLINE(open>=close ,close ,open,1,0 ),COLOR00FF00;
STICKLINE(close>open,close,open,0,0) ,COLORFFBBFF;
STICKLINE(close>open,close,open,8,0) ,COLORFF00FF;
STICKLINE(close>open,close,open,7,0) ,COLORFF22FF;
STICKLINE(close>open,close,open,6,0) ,COLORFF44FF;
STICKLINE(close>open,close,open,5,0) ,COLORFF66FF;
STICKLINE(close>open,close,open,4,0) ,COLORFF88FF;
STICKLINE(close>open,close,open,3,0) ,COLORFF99FF;
STICKLINE(close>open,close,open,2,0) ,COLORFFAAFF;
STICKLINE(close>open,close,open,1,0) ,COLORFFBBFF;

大智慧K线形态主图指标公式

 

大智慧金线不破主图指标公式

IF(FINANCE2(37)/10000>=100) THEN BEGIN
DRAWTEXTREL(0,950,’【超大盘0.7%】 流通A股’+FINANCE2(37)/10000+’亿股’),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<100 and FINANCE2(37)/10000>=10) THEN BEGIN
DRAWTEXTREL(0,950,’【大盘股9.0%】 流通A股’+FINANCE2(37)/10000+’亿股’),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<10 and FINANCE2(37)/10000>=5) THEN BEGIN
DRAWTEXTREL(0,950,’【中盘股12.7%】 流通A股’+FINANCE2(37)/10000+’亿股’),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<5 and FINANCE2(37)/10000>=1) THEN BEGIN
DRAWTEXTREL(0,950,’【小盘股55.3%】 流通A股’+FINANCE2(37)/10000+’亿股’),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<1) THEN BEGIN
DRAWTEXTREL(0,950,’【超小盘22.3%】 流通A股’+FINANCE2(37)/10000+’亿股’),LINETHICK2,ColorFF00FF; end;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(ff1,(LOW* 0.99),’I鼠’),Color4080FF;
STICKLINE(ff1,O,C,6,0),COLORyellow;
STICKLINE(ff1,O,C,2.5,0),COLORred;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(filter(买=1,5),LOW-0.08,’I低’) ,COLORAAAAFF;
STICKLINE(filter(买=1,5),O,C,6,0),COLORyellow;
STICKLINE(filter(买=1,5),O,C,2.5,0),COLORred;
cc:=(h-c)/(c-o)<0.33;
dd:=(c/ref(c,1)-1)>=0.0502 and c>ref(c,1) and (o-l)/(c-o)>=1.48 and l<ref(l,1) and l<ref(l,2);
ee:=(c/ref(c,1)-1)>=0.08;
aa:=VOL>REF(VOL,1)*1.9 and c>ref(c,1) and c/ref(c,1)-1>=0.049 and cc;
bb:=(c/ref(c,1)-1)>=0.0502 and c>ref(c,1) and v>ref(v,1) and VOL>REF(VOL,1)*2.5 and cc;
DRAWTEXT(FILTER(aa or bb or dd or ee,34),l,’I异动’),COLOrffff00;
STICKLINE(FILTER(aa or bb or dd or ee,34),O,C,6,0),COLORyellow;
STICKLINE(FILTER(aa or bb or dd or ee,34),O,C,2.5,0),COLORRED;
AAA:=(3*C+H+L+O)/6;
VAR41:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR41;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.97,’I立桩量’),COLORYELLOW;
VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST (VAR2222)),0.5,1),COLOREA91B5,LINETHICK1;
STICKLINE(CLOSE<OPEN and ref(CLOSE,1)>ref(OPEN,1),ref(close,1),ref(close,1),33,0),COLORwhite,LINETHICK1;
DD:=FINANCE2(35);
SS:=FINANCE2(37);
GG:=FINANCE2(3);
TH:=DYNAINFO(39);
DRAWTEXTREL(0,70,’总股本:’+NUMTOSTRn(DD,0)+’万股’ +’ 流通A股:’+NUMTOSTRn(SS,0)+’万股’+’ 市盈率:’+NUMTOSTRn(TH,2)+’ 倍’+’ 每股收益:’+NUMTOSTRn(GG,3)+’ 元’),ColorFFFF00;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,20,0),Color0000FF;
STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,20,0),Color00FF00;
STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,20,0),ColorFF00FF;
STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,20,0),ColorFF9900;
DRAWTEXTREL(850,890,’今日支撑:’+NUMTOSTRN(今日支撑 ,2 )),Colorred;
DRAWTEXTREL(850,950,’今日阻力:’+NUMTOSTRN(今日阻力 ,2 )),ColorGREEN;
DRAWTEXTREL(0,20,’所属板块:’+BKNAME),ColorRED;
DRAWTEXTREL(0,120,’每股收益:’+NUMTOSTRN(FINANCE2(3),3)+’元’+’ 市盈率:’+NUMTOSTRN(DYNAINFO(39),2)+’元’+’ 市净率:’+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+’元’+’ 净资产:’+NUMTOSTRN(FINANCE2(4),2)+’元’),Color00C0FF;
DRAWTEXTREL(0,270,’历史最高价:’+HHV(HIGH,0)),Colorred;
DRAWTEXTREL(160,270,’历史最低价:’+LLV(LOW,0)),ColorAFFF00;
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
DRAWTEXTREL(0,170,’销售毛利率:’+NUMTOSTRN(销售毛利率,2)+’%’),LINETHICK1,COLORff00ff;
DRAWTEXTREL(180,170,’主营收入同比增长:’+NUMTOSTRN(主营收入同比,2)+’%’),LINETHICK1,ColorYELLOW;
DRAWTEXTREL(0,220,’净利润同比增长:’+NUMTOSTRN(净利润同比增长,2)+’%’),LINETHICK1,COLOR00FF00;
LJL07:=(3*C+L+O+H)/6;
金钱:(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORgreen,LINETHICK4;
银线:EMA(CLOSE,6),COLORff00ff,LINETHICK4;

大智慧金线不破主图指标公式