大智慧九九归一主图指标公式

N:=5;
bc:=(IF(C>(H+L+C)/3,(H*0.618+L*0.382)*0.382,(H*0.382+L*0.618)*0.382)+(O*0.382+C*0.618)*0.618);
市场的价格:=AMOUNT/VOL;
MX:=if(INDEXC=C,BC,市场的价格);
M1:=MA(MX,N);
M2:=EMA(M1,N*2);
M3:=EMA(M2,n*3);
M4:=EMA(M3,n*4);
M5:=EMA(M4,n*5);
M6:=EMA(M5,n*6);
M7:=EMA(M6,n*7);
M8:=EMA(M7,n*8);
M9:=EMA(M8,n*9);
六顺:EMA((M1+M2+M3+M4+M5+M6)/6,6)/100,COLORYELLOW,LINETHICK2;
归一:EMA((M1+M2+M3+M4+M5+M6+M7+M8+M9)/9,9)/100,COLOR6600FF,LINETHICK2;
partline(六顺,六顺<归一),colorgray,linethick2;
partline(归一,六顺<归一),colorblue,linethick2;
涨幅宽度:=ma(六顺/归一,13);
空仓日:=if(六顺<归一,1,0);
持仓日:=if(六顺>归一,1,0);
长线买入:if(count(空仓日,777)>555 and 持仓日=1 and 涨幅宽度<1.03,1,0),linethick0;
长线买入:if(count(空仓日,337)>211 and count(持仓日,177)<66 and 持仓日=1 and 涨幅宽度<1.03,1,0),linethick0;
partline(六顺*1.15,超长线买入>0),colorred,linethick7;
partline(六顺*1.15,长线买入>0),coloryellow,linethick7;

大智慧九九归一主图指标公式

 

大智慧KDJ的MACD指标公式

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DIFF:EMA(J,8) – EMA(J,16),COLOR00FF00,LAYER0;;
DEA:EMA(DIFF,5),COLORFF9900,LAYER0;;
MACD:2*(DIFF-DEA), COLORSTICK;;
0,COLORff9900,DOTLINE;
FILLRGN(DIFF,DEA,DIFF>DEA,RGB(80,0,80),DIFF<DEA,RGB(0,120,60)),LAYER7;
TYP:FORCAST(((2*C+H+L)/4*0.618+C*0.382),3),color00FFFF,linethick0;{FORCAST}
AAX:=(TYP-ma(TYP,9))/ma(TYP,9)*100;
VARM:=MIN(COUNT(TYP,0),9);
AAX1:=EMA(AAX,VARM) *VARM;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
卖:AAX3>10 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1),linethick0;
减仓:filter(卖,5) ,PRECIS0,linethick0;
VERTLINE(减仓>0,2),LAYER0,COLOR00ffFF;
drawtext(减仓,10*1.6,’◆’),ALIGN2,colorcyan;
drawtext(减仓,10*1.5,’◇’),ALIGN1,color00FF00;
drawtext(减仓,10*1.59,’◆’),ALIGN0,colorcyan;
DRAWTEXTABS(5,5,’■现在KDJ的参数是:N=9,M1=3,M2=3;’),COLOR00FFFF,LINETHICK3,LAYER0;
DRAWTEXTABS(5,25,’■【KDJ】的【MACD】的参数是:LONG=8,LONG=16,M=5;’),COLOR0099FF,LINETHICK3,LAYER0;

大智慧KDJ的MACD指标公式

 

流通盘大小:=FINANCE2(37)/10000;
DRAWTEXTABS(20,25,’流通盘大小:’+流通盘大小+’亿 ‘),LINETHICK1,Colorffffff;
净资产收益率:=FINANCE2(5);
DRAWTEXTABS(220,25,’净资产收益率:’+净资产收益率+’% ‘),LINETHICK1,Colorffffff;
上证指数:=indexc;
DRAWTEXTABS(360,25,’上证指数:’+上证指数),LINETHICK1,Colorffffff;
DRAWGBKLAST(L,STRIP(RGB(0,0,205),RGB(47,79,79),0));
n:=20;
n1:=7;
n2:=49;
Var1:=(CLOSE+HIGH+LOW)/3;
Var2:=EMA(Var1,10);
Var3:=REF(Var2,1);
PARTLINE(Var2,Var2>Var3),pointdot,linethick7, COLORYELLOW;
PARTLINE(Var3,Var2<Var3),pointdot,linethick7 , COLORBLUE;
终极黄金: if(Var2>Var3,Var2,0), pointdot,linethick0, COLORYELLOW;
一卸千里: if(Var2<Var3,Var3,0),pointdot,linethick0 , COLORBLUE;
M1: EMA(CLOSE,5);
M2: EMA(CLOSE,8);
M3: EMA(M2,10);
M4: EMA(M2,55);
Var4:=EMA(M3,55);
M5: EMA(M4,81);
M6: EMA(Var4,144), colorff00ff;
Var5:=(REF(HIGH,1)+REF(LOW,1))/2;
Var6:=MA(CLOSE,N)+2*STD(CLOSE,N);
Var7:=REF(CLOSE,1);
Var8:=SMA(MAX(CLOSE-Var7,0),N1,1)/SMA(ABS(CLOSE-Var7),N1,1)*100;
Var9:=CROSS(N2,Var8);
VarA:=FILTER(Var9,4);
VarB:=(2*CLOSE+HIGH+LOW)/4;
VarC:=LLV(LOW,34);
VarD:=HHV(HIGH,34);
VarE:=EMA((VarB-Var4)/(Var5-Var4)*100,7);
VarF:=EMA(0.667*REF(VarE,1)+0.333*VarE,5);
PARTLINE(HIGH*1.02,IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.6 AND VOL>=1.5*MA(VOL,5) AND COUNT(VarE>=VarF,3) AND REF(LOW,1)=LLV(LOW,120),1,0)) , COLORYELLOW;
PARTLINE(HIGH*1.02,IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>0.6 AND COUNT(VarE>VarF,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND OPEN>REF(CLOSE,1),1,0)), COLORf00ff0;
买进1:if(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.6 AND VOL>=1.5*MA(VOL,5) AND COUNT(VarE>=VarF,3) AND REF(LOW,1)=LLV(LOW,120),1,0),HIGH*1.02,0) , COLORYELLOW,LINETHICK0;
买进2:if(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>0.6 AND COUNT(VarE>VarF,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND OPEN>REF(CLOSE,1),1,0),HIGH*1.02,0), COLORf00ff0,LINETHICK0;
Var10:=MA(CLOSE,80)-MA(CLOSE,10)/3;
PARTLINE(HIGH*1.02,IF(CLOSE<Var10 AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0)), COLORred;
抄底 :if(IF(CLOSE<Var10 AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),HIGH*1.02,0), COLORred,LINETHICK0;

 

大智慧超级波指标公式

A1:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
ZYD: SMA(A1,6,1),ColorRED;
ZZD: SMA(ZYD,2,1),colorwhite;
ZBD: SMA(ZYD,4,1),colorBLUE;
ZAD: SMA(A1,20,1),color444444;
ZD: SMA(A1,1,1),colorBlack;
ZD1:SUM(ZD,2)/2,colorBlack;
ZD2:SUM(ZD,6)/6,COLOR444444;
DRAWTEXT(CROSS(ZYD,ZZD)AND REF(ZBD,10)*1>ZYD AND REF(ZAD,10)>ZAD AND ZYD<40 ,ZYD ,’←加’),COLOR888888,linethick1;
DRAWTEXT(CROSS(ZZD,ZYD)AND REF(ZBD,10)*1<ZYD AND REF(ZAD,10)<ZAD AND ZYD>60 ,ZYD ,’←减’),COLOR888888,linethick1;
DRAWTEXT(CROSS(ZD1,ZD2) AND ZYD<40 ,ZD1,’←▲’),COLOR666666,linethick1;
DRAWTEXT(CROSS(ZD2,ZD1) AND ZYD>60 ,ZD1 ,’←△’),COLOR666666,linethick1;
DRAWTEXTABS(10,30,’ ‘+MONTH+’月’+DAY+’日’+’.星期’+WEEKDAY),LINETHICK2,COLOR00b5ff;
危险: 80, COLOR666666;
安全: 20, COLOR666666;

大智慧超级波指标公式

 

大智慧买入就有赚指标公式

LONG:=26;
SHORT:=12;
M:=9;
DIF:EMA(CLOSE,SHORT) – EMA(CLOSE,LONG);
DEA:EMA(DIF,M),COLORBLUE,LINETHICK3;
MACD:2*(DIF-DEA),COLORSTICK;
A4:=BARSLAST(ref(cross(dif,dea),1));
B1:=ref(c,A4+1)>c and ref(dif,A4+1)<dif and cross(dif,dea);
DRAWTEXT(FILTER(B1>0,5),dif+0.2,’背离‘),COLORyellow;
VAR1C:=(HIGH – MIN(OPEN,CLOSE));
VAR2C:=(CLOSE – OPEN);
VAR3C:=(MIN(OPEN,CLOSE) – LOW);
VAR4C:=(HIGH – LOW);
VAR5C:=((VOL * VAR1C) / VAR4C);
VAR6C:=((VOL * VAR2C) / VAR4C);
VAR7C:=((VOL * VAR3C) / VAR4C);
VAR8C:=((VAR5C – VAR6C) – VAR7C);
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 10),4) / SUM((VOL * 200),4));
VARB:=(INTPART((VARA * 10)) / 10);
VARC:=(SUM(((CLOSE * VOL) * 10),7) / SUM((VOL * 200),7));
VARD:=(INTPART((VARC * 10)) / 10);
VARE:=(SUM(((CLOSE * VOL) * 10),28) / SUM((VOL * 200),28));
VARF:=(INTPART((VARE * 10)) / 10);
短线趋势:(EMA(CLOSE,5) – EMA(CLOSE,10)),COLORMAGENTA,LINETHICK2;
中线趋势:EMA(短线趋势,9),COLORMAGENTA,LINETHICK3;
VAR10:=((0 – ((10 * (HHV(CLOSE,5) – CLOSE)) / (HHV(CLOSE,5) – LLV(LOW,5)))) + 10);
VAR11:=((0 – ((10 * (HHV(CLOSE,10) – CLOSE)) / (HHV(CLOSE,10) – LLV(LOW,10)))) + 10);
VAR12:=((0 – ((10 * (HHV(CLOSE,20) – CLOSE)) / (HHV(CLOSE,20) – LLV(LOW,20)))) + 10);
VAR13:=((0 – ((10 * (HHV(CLOSE,30) – CLOSE)) / (HHV(CLOSE,30) – LLV(LOW,30)))) + 10);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 – VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 – VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
短线指标:IF(((((CROSS(短线趋势,中线趋势) AND (短线趋势 < 0)) AND (中线趋势 < (0 – 0.2))) AND (VAR11 > 45)) AND (VAR16 > 0)),0.3,0.1),COLOR66FF00;

大智慧买入就有赚指标公式

 

大智慧竖向排列日干支指标公式

T:=DATETOD1970(DATE );
X:MOD(T+7,10)+1,LINETHICK0;
Y:MOD(T+5,12)+1,LINETHICK0;
天干:=IFS(X=1,’甲’,IFS(X=2,’乙’,IFS(X=3,’丙’,IFS(X=4,’丁’,IFS(X=5,’戊’,IFS(X=6,’已’,IFS(X=7,’庚’,IFS(X=8,’辛’,IFS(X=9,’壬’,IFS(X=10,’癸’,”))))))))));
地支:=IFS(Y=1,’子’,IFS(Y=2,’丑’,IFS(Y=3,’寅’,IFS(Y=4,’卯’,IFS(Y=5,’辰’,IFS(Y=6,’巳’,IFS(Y=7,’午’,IFS(Y=8,’未’,IFS(Y=9,’申’,IFS(Y=10,’酉’,IFS(Y=11,’戌’,’亥’)))))))))));
DRAWTEXT(x,1,天干);
DRAWTEXT(Y,0.8,地支);
1.5,COLOR000000;0,COLOR000000;

大智慧竖向排列日干支指标公式

 

大智慧RSICCIKD指标公式

N:=9;M:=14;N1:=6;
100,POINTDOT;
-100,POINTDOT;
{input:N(9,2,100),M(14,1,100),N1(6,2,100);}
TYP := (HIGH + LOW + CLOSE)/3;
CC1:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),ColorFF00FF;
C1:=SMA(CC1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
CB2:=REF(CB1,1);
FILLRGN(CC1,100,CC1>100),Color38FF00;
FILLRGN(CC1,-100,CC1<-100),COLOR00AAFF;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
DRAWTEXTABS(5,5,”),linethick1,COLOR00EEff;
RSI:(RSI1-50)*5,LINETHICK2,ColorFFFFFF;
R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
K1:(K-50)*5,ColorFFFF00;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
买入:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,LINETHICK0;
DRAWICON(买入,-200,7),ALIGN0;
卖出:REF(RR,1)=1 AND NOT(RR) AND CB1>100,LINETHICK0;
DRAWICON(卖出,200,8),ALIGN0;

大智慧RSICCIKD指标公式

 

大智慧短线牛主图指标公式

input:n(5,1,100,1);
MA5:MA(C,5),color000099;
MA10:MA(C,10),color006600;
MA20:MA(C,20),color005555;
STICKLINE(c>=ref(c,1),o,c,7,0),colorwhite;
STICKLINE(c<ref(c,1),o,c,7,0),colorgreen;
A1:=EMA(CLOSE,5)>EMA(CLOSE,6) and EMA(CLOSE,6)>EMA(CLOSE,7) and EMA(CLOSE,7)>EMA(CLOSE,8) and EMA(CLOSE,8)>EMA(CLOSE,9)
and EMA(CLOSE,9)>EMA(CLOSE,10) and EMA(CLOSE,10)>EMA(CLOSE,11) and EMA(CLOSE,11)>EMA(CLOSE,12)
and EMA(CLOSE,12)>EMA(CLOSE,13) and EMA(CLOSE,13)>EMA(CLOSE,14) and EMA(CLOSE,14)>EMA(CLOSE,15)
and EMA(CLOSE,15)>EMA(CLOSE,20) and EMA(CLOSE,20)>EMA(CLOSE,30) and EMA(CLOSE,30)>EMA(CLOSE,60) and EMA(CLOSE,60)>EMA(CLOSE,90)
and EMA(CLOSE,90)>EMA(CLOSE,120) and EMA(CLOSE,120)>EMA(CLOSE,250);
A2:=EMA(CLOSE,5)>EMA(CLOSE,6) and EMA(CLOSE,6)>EMA(CLOSE,7) and EMA(CLOSE,7)>EMA(CLOSE,8) and EMA(CLOSE,8)>EMA(CLOSE,9)
and EMA(CLOSE,9)>EMA(CLOSE,10) and EMA(CLOSE,10)>EMA(CLOSE,11) and EMA(CLOSE,11)>EMA(CLOSE,12)
and EMA(CLOSE,12)>EMA(CLOSE,13) and EMA(CLOSE,13)>EMA(CLOSE,14);
B1:=IF(a1,1,2);
VAR1:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR2:=((REF(VAR1,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
STICKLINE((((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC),C,REF(C,1),7,0),Color0000DD;
STICKLINE((((((((((((VAR1 OR VAR2) OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC),L,H,0.7,0),Color0000DD;
MTM:=C-REF(C,1);
DX1:=100*EMA(EMA(MTM,N),N)/EMA(EMA(ABS(MTM),N),N);
买1:=IF(LLV(DX1,2)=LLV(DX1,7) AND COUNT(DX1<0,2) AND CROSS(DX1,MA(DX1,2)),1,0);
卖1:=IF(HHV(DX1,2)=HHV(DX1,7) AND COUNT(DX1>50,2) AND CROSS(MA(DX1,2),DX1),1,0);
DRAWTEXT(filter(卖1=1,5),high*1.02, ‘ ‘),color00ff00,ALIGN1;
DRAWTEXT(filter(买1=1,5),low*0.99, ‘ ‘),colorRED,ALIGN1;
DRAWICON(filter(买1=1,5),low*0.99,7),ALIGN1;
DRAWICON(filter(卖1=1,5),high*1.04, 8),ALIGN1;
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
HY1:=REF(EMA(V1,3),1);
DRAWTEXT(CROSS(CLOSE,HY1),LOW,’B’),LINETHICK2,COLORYELLOW;
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
DRAWTEXT(CROSS(CLOSE,TT1)AND J<55,LOW,’买’),COLORRED;
DRAWTEXT(CROSS(88,RSI),HIGH * 1.02,’顶’),COLOR00FFFF;
DRAWTEXT(CROSS(80,RSI),HIGH * 1.02,’逃’),COLOR00FFFF;
{老鼠仓}AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:BB1 AND CC1 AND DD1 AND EE1,linethick0;
DRAWTEXT(老鼠仓,(LOW* 0.99),’老鼠仓’),Color40CCFF;
DIFF:=EMA(CLOSE,12) – EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWICON(FILTER(B1>0,5),L*0.94,10);
DRAWTEXT(FILTER(B1>0,5),L*0.96,’M底’),COLOR0055ff;{MACD底背离}
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
DRAWICON(FILTER(B2>0,5),L*0.96,10);
DRAWTEXT(FILTER(B2>0,5),L*0.98,’K底’),COLORff00ff;{KDJ底背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWICON(FILTER(B3>0,5),L*0.98,10);
DRAWTEXT(FILTER(B3>0,5),L*0.97,’R底’),COLORyellow;{RSI底背离}
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
DRAWICON(FILTER(D1>0,5),H*1.07,12);
DRAWTEXT(FILTER(D1>0,5),H*1.02,’M顶’),COLORwhite;{MACD顶背离}
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
DRAWICON(FILTER(D2>0,5),H*1.05,12);
DRAWTEXT(FILTER(D2>0,5),H*1.03,’K顶’),COLORf0f000;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
DRAWICON(FILTER(D3>0,5),H*1.03,12);
DRAWTEXT(FILTER(D3>0,5),H*1.01,’R顶’),COLOR00ff00;{RSI顶背离};
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,’短进’),COLORFF00FF;
DRAWTEXT((MA(CLOSE,13) > MA(CLOSE,18)) AND CROSS(CLOSE,MA(CLOSE,4)) AND (MA(CLOSE,4) < MA(CLOSE,13)),(LOW)*(0.97),’赢’),COLOR00FF00;
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;

大智慧短线牛主图指标公式

 

大智慧清晰的趋势及买卖点指标公式

Var1:=1;
趋势线:((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50),COLORRED;
Var2:=(2*CLOSE+HIGH+LOW+OPEN)/5;
Var3:=LLV(LOW,34);
Var4:=HHV(HIGH,34);
SK:EMA((Var2-Var3)/(Var4-Var3)*100,13)*Var1,colorwhite;
SD:EMA(SK,2),coloryellow;
Var5:=EMA(CLOSE,12)-EMA(CLOSE,26);
Var6:=EMA(Var5,9);
Var7:=Var1*CLOSE*1.236<MA(CLOSE,60);
Var8:=CLOSE/REF(CLOSE,1)>1.021;
Var9:=(HIGH-CLOSE)*1.36<=CLOSE-OPEN;
VarA:=(MA(CLOSE,120)-CLOSE)/CLOSE*100;
VarB:=ABS(Var5-Var6);
VarC:=STD(CLOSE,90)*10;
VarD:=COUNT((REF(CLOSE,15)-CLOSE)/CLOSE*100>45,5);
买:IF(Var1*Var7 AND Var8 AND Var9 AND VarC<25 AND CLOSE<8 AND VarA<114 AND VarB<=0.23*40,55,0),colorred;
VarE:=SLOPE(CLOSE,40);
VarF:=COUNT((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<-0.098,90);
Var10:=(MA(CLOSE,120)-CLOSE)/CLOSE*100;
Var11:=STD(CLOSE,63)*10;
Var12:=(MA(CLOSE,76)-MA(CLOSE,13)/3);
Var13:=MA((CLOSE-Var12)/Var12,1);
Var14:=MA(CLOSE,5);
Var15:=MA(CLOSE,10);
Var16:=MA(CLOSE,20);
Var17:=MA(CLOSE,30);
Var18:=MA(CLOSE,60);
Var19:=MA(CLOSE,150);
Var1A:=MA(CLOSE,250);
Var1B:=VOL/CAPITAL*100;
Var1C:=(CLOSE-Var1A)/Var1A*100;
Var1D:=(CLOSE/REF(CLOSE,1)-1)*100;
Var1E:=PWINNER(1,CLOSE);
Var1F:=IF(Var1>0.75 AND Var1<0.901,0.618,1);
牛:IF(Var14>Var15 AND Var15>Var16 AND Var16>Var17 AND Var16>Var18 AND Var19>Var1A AND (Var1E>=0.9 OR Var1E>0.76 AND Var1E<0.901 AND Var1D>5 AND Var1B>5) AND Var1D>1.8 AND Var1C<40 AND CLOSE>3 AND (CLOSE-Var18)/Var18<0.25 AND Var1B<=6 AND Var4*Var1B>=1 AND CLOSE<18.5,35,0),colorf00f00;
Var20:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
Var21:=(MA(CLOSE,48)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
Var22:=Var1*(MA(CLOSE,12)+MA(CLOSE,24)+MA(CLOSE,48)+MA(CLOSE,96))/4;
Var23:=Var1*MA(CLOSE,250);
Var24:=MA(CLOSE,125);
Var25:=CLOSE/MA(CLOSE,3)>=1.05 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
Var26:=REF(CLOSE,1);
Var27:=SMA(MAX(CLOSE-Var26,0),5,1)/SMA(ABS(CLOSE-Var26),5,1)*100;
Var28:=Var1*COUNT(Var27<25,20)>=1;
Var29:=(HIGH-LOW)/HIGH*100+(CLOSE-Var26)/Var26*100;
Var2A:=EMA(MA(Var29,41),6);
Var2B:=Var2A>LLV(Var2A,6)*1.02 AND REF(Var2A,1)<REF(LLV(Var2A,6),1)*1.02 AND LLV(Var2A,29)=LLV(Var2A,6);
Var2C:=Var1*LLV(LOW,6)=LLV(LOW,41) AND LLV(LOW,6)<HHV(LOW,41)*71/100;
Var2D:=HIGH>LOW*1.033;
涨势确立:Var1*(Var2C>0 AND Var2D*16+81.5)*Var1,Color80FFFF;
买入:IF(CROSS(趋势线,21),50,18.5),linethick1,coloraaa0ff;
卖出:IF(CROSS(87,趋势线),60,81.5),colorFFAA00;
DRAWTEXT(Var2C>0 AND Var2D,88,’↑’),colorwhite;
Var2E:=IF(CROSS(SK,SD),25,18.5);
Var2F:=IF(CROSS(SD,SK),75,81.5);
卖线:Var2F,colorwhite;
买线:Var2E,colorred;
Var13<0.06*(-10)+81.5,colorwhite;
Var30:0-SQRT(SQRT(FLOOR(SQRT(MA(1/WINNER(CLOSE)*100,4)/10000))))*5;
STICKLINE(Var30<-2,0,Var30,1.5,1);
drawtext(买入>var2E,61,’短买’),coloraaaaff;
drawtext(卖出<Var2F,58,’短卖’),colorffaa00;
drawtext(买>1.0,65,’长买’),colorred;
drawtext(牛>1.0,40,’长牛’),colorf00f00;

大智慧清晰的趋势及买卖点指标公式

 

大智慧波段踏浪指标公式

input: P1(10,5,20,1),P2(30,10,50,1),N(6,1,10,1),N2(6,1,10,1),N3(-23,-50,10,1),N4(75,50,100,10);
STICKLINE(C>0,0,100,100,0),COLOR8BA410;
VAR2:=(((CLOSE – REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3:=(((CLOSE – LLV(LOW,18)) / (HHV(HIGH,18) – LLV(LOW,18))) * 100);
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:((3 * VAR4) – (2 * VAR5));VAR6:=(J > (1 * REF(J,1)));
VAR7:=LLVBARS(LOW,50);
VAR8:=SUM(VOL,VAR7);
VAR9:=HHVBARS(HIGH,50);
VAR10:=SUM(VOL,VAR9);
VAR11:=(((CLOSE – REF(OPEN,VAR9)) / REF(OPEN,VAR9)) * 100);
VAR12:=((VAR10 / CAPITAL) * 100);
VAR13:=(((CLOSE – REF(OPEN,VAR7)) / REF(OPEN,VAR7)) * 100);
VAR14:=((VAR8 / CAPITAL) * 100);
VAR15:=(MA(WINNER(CLOSE),N) * 100);
VAR16:=EMA(VAR4,N);
A2:EMA(VAR4,N),COLORFFDDCC;A3:=EMA(A2,N);
A4:=EMA(A3,N);A5:=EMA(A4,N);
A6:=EMA(A5,N);A7:=EMA(A6,N);
VAR17:=EMA(A7,N);
VAR18:=EMA(VAR17,N);VAR19:=EMA(VAR18,N);
AA:=EMA(A5,N2);中期大底:LLV(J,AA),LINETHICK2,COLOR0000FF;
上:=((EMA((MA(HIGH,3) * 1.05),30) * 10) – AA);下:=((EMA((MA(LOW,3) * 0.96),30) * 2) / 中期大底);
上上:=EMA((MA(HIGH,3) * 1.05),30);电:=J;DRAWTEXT((CROSS(A4,AA) AND (VAR11 < N3)),AA,’●底’),COLOR00FF00;
DRAWTEXT((CROSS(A2,J) AND (A2 > N4)),(A2 + 4.04),’●峰’),COLORFF00FF;
DRAWTEXT(((((CROSS(J,A2) AND VAR6) AND (A2 < 20)) AND (VAR2 > 9)) OR (((A2 > (1 * REF(A2,1))) AND (VAR2 > 4)) AND (A2 < 60))),A2,’●拉’),COLORFFFFCC;STICKLINE((J >= A2),A2,J,8,0),COLOR0000FF;
STICKLINE((J <= A2),J,A2,8,0),COLOR00FF00;压力:HHV(J,60),COLOR00FFFF;
支持:=LLV(AA,13);STICKLINE((((J <= 中期大底) AND ((上上 – REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),1,88,3,0),COLOR00FF00;
DRAWICON((((J <= 中期大底) AND ((上上 – REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),88,0);DRAWTEXT((((J <= 中期大底) AND ((上上 – REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),85,’-肯定底部‘);
STICKLINE(FILTER((CROSS(上,中期大底) AND ((上上 – REF(上上,1)) >= 0)),3),中期大底,70,3,0),COLOR0000FF;DRAWICON(FILTER((CROSS(上,中期大底) AND ((上上 – REF(上上,1)) >= 0)),3),70,0);DRAWTEXT(FILTER((CROSS(上,中期大底) AND ((上上 – REF(上上,1)) >= 0)),3),64,’-买了不输’),COLORFFFFFF;STICKLINE((CROSS(上,下) AND (CLOSE >= OPEN)),中期大底,60,2,0),COLORFF0000;DRAWICON((CROSS(上,下) AND (CLOSE >= OPEN)),60,0);DRAWTEXT((CROSS(上,下) AND (CLOSE >= OPEN)),55,’-短线‘);DRAWTEXT((((J >= 压力) AND ((压力 – REF(压力,6)) > 25)) AND (CLOSE < OPEN)),(压力 + 4.22),’●头部’),COLOR00FF00;MA1:=MA(CLOSE,P1);MA2:=MA(CLOSE,P2);N15HIGH:=REF(HIGH,15);N1LOW:=REF(LOW,1);FF:=(((N15HIGH – N1LOW) / N1LOW) > 0.15);STICKLINE((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH – N1LOW) / N1LOW) < 0.15)) AND (LOW <= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (CLOSE >= OPEN)),中期大底,60,0,1),LINETHICK3,COLOR0000FF;
DRAWICON((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH – N1LOW) / N1LOW) < 0.15)) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA(CLOSE,P1))) AND (CLOSE >= OPEN)),60,1);
DRAWTEXT((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH – N1LOW) / N1LOW) < 0.15)) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA(CLOSE,P1))) AND (CLOSE >= OPEN)),60,’★^回头望月’),COLORFF0000;
X:=(CLOSE – REF(MA(CLOSE,20),11));LGL:=IF((((((EMA(CLOSE,5) / EMA(EMA(CLOSE,9),16)) <= 0.85) AND ((CLOSE / REF(CLOSE,1)) > 0.905)) AND ((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),50,0);
WR1:=((0 – ((100 * (HHV(HIGH,34) – CLOSE)) / (HHV(HIGH,34) – LLV(LOW,34)))) + (100 * X));
WR2:=((0 – ((100 * (HHV(HIGH,50) – CLOSE)) / (HHV(HIGH,50) – LLV(LOW,50)))) + 100);
WR3:=((0 – ((100 * (HHV(HIGH,70) – CLOSE)) / (HHV(HIGH,70) – LLV(LOW,70)))) + (100 * X));
BIAS1:=(((((CLOSE – MA(CLOSE,34)) / MA(CLOSE,34)) * 100) + 10) * 5);
BIAS2:=(((((CLOSE – MA(CLOSE,50)) / MA(CLOSE,50)) * 100) + 10) * 5);
BIAS3:=(((((CLOSE – MA(CLOSE,70)) / MA(CLOSE,70)) * 100) + 10) * 5);
S1:=(((((((WR1 + WR2) + WR3) + BIAS1) + BIAS2) + BIAS3) / 6) * X);
S2:=EMA(S1,3);S3:=ABS((BIAS1 – BIAS3));SX:=((S1 + S3) / 2);
XC1:=(((0 – 1) * (EMA((100 * (1 – WINNER(CLOSE))),1) – 50)) + 50);CCC:=(XC1 + SX);
ZJZ:=(IF (XC1>0 AND CCC<0,200,0))*X;
LXL:=IF((((((SX < 0) AND (CLOSE = LLV(CLOSE,5))) AND ((CLOSE / REF(CLOSE,1)) > 0.905)) AND ((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),(0 – 50),0);
JBJ:=(IF(((CCC < 0) AND (LXL = (0 – 50))),100,0) * X);
MA3:=MA(CLOSE,3);C0:=(REF(CLOSE,2) * 0.865);
C1:=(REF(CLOSE,13) * 0.772);BOT:=MIN(C0,C1);
HSL:=(((100 * VOL) / CAPITAL) * X);
MA13:=(MA(CLOSE,13) * X);
CXC:=IF(((((CLOSE – BOT) / CLOSE) < (3 / 100)) AND ((SUM(HSL,5) / 5) < 1.8)),1,0);
VMC:=IF(((CXC > 0) AND ((LXL < 0) OR (LGL > 0))),10,0);
满仓:IF((VMC > 0),60,中期大底),COLOR0000FF;DRAWTEXT((满仓 >= 60),59,’-满仓’),COLOR0000FF;
半仓:IF((((((ZJZ > 0) AND (JBJ > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR ((CXC > 0) AND ((REF(CLOSE,1) / REF(CLOSE,2)) > 0.902))) OR ((((((ZJZ > 0) AND (JBJ > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR (CXC > 0)) AND ((LXL < 0) OR (LGL > 0))) AND (VMC < 10))),50,中期大底),COLORCC99FF;
DRAWTEXT((半仓 >= 50),49,’-半仓’),COLORCC99FF;
B0:=MA(CLOSE,3);B01:=MA(CLOSE,4);
B1:=(((HIGH + LOW) + CLOSE) / 3);
B2:=HHV(B1,15);B3:=LLV(B1,15);
B4:=(B2 – B3);
B5:(MA(((B1 – B3) / B4),2) * 100);
B6:=HHV(B1,(4 * 15));
B7:=LLV(B1,(4 * 15));
B8:=(B6 – B7);
B9:(MA(((B1 – B7) / B8),2) * 100);
BA:=HHV(B1,(16 * 15));
BB:=LLV(B1,(16 * 15));
BC:=(BA – BB);
BD:(MA(((B1 – BB) / BC),2) * 100);
顶线:98;底线:1;
STICKLINE((((CROSS(B5,底线) AND ((B0 – REF(B0,1)) > 0)) AND ((J – REF(J,1)) > 0)) AND (CLOSE >= OPEN)),中期大底,50,2,0),COLOR0000FF;
DRAWICON((((CROSS(B5,底线) AND ((B0 – REF(B0,1)) > 0)) AND ((J – REF(J,1)) > 0)) AND (CLOSE >= OPEN)),50,0);
DRAWTEXT((((CROSS(B5,底线) AND ((B0 – REF(B0,1)) > 0)) AND ((J – REF(J,1)) > 0)) AND (CLOSE >= OPEN)),45,’-开花一’),COLORCC99FF;
STICKLINE(((CROSS(B5,底线) AND CROSS(B9,底线)) AND ((B01 – REF(B01,1)) > 0)),中期大底,64,2,0),COLOR00FF00;
DRAWICON(((CROSS(B5,底线) AND CROSS(B9,底线)) AND ((B01 – REF(B01,1)) > 0)),64,0);DRAWTEXT(((CROSS(B5,底线) AND CROSS(B9,底线)) AND ((B01 – REF(B01,1)) > 0)),58,’-开花二’);
DRAWTEXT((CROSS(98,B5) AND (CLOSE < (HIGH / 1.03))),98,’-出局’),COLOR00FF00;DRAWICON((CROSS(98,B5) AND (CLOSE < (HIGH / 1.03))),98,7);STICKLINE(((CROSS(BD,1) AND ((上上 – REF(上上,1)) > 0)) AND ((B5 – REF(B5,2)) > 0)),1,80,3,0);
DRAWICON(((CROSS(BD,1) AND ((上上 – REF(上上,1)) > 0)) AND ((B5 – REF(B5,2)) > 0)),80,0);DRAWTEXT(((CROSS(BD,1) AND ((上上 – REF(上上,1)) > 0)) AND ((B5 – REF(B5,2)) > 0)),73,’-开花三’),COLOR00FFFF;
STICKLINE(((((CROSS(J,AA) AND (A2 >= A3)) AND ((上上 – REF(上上,1)) > 0)) AND (CLOSE >= OPEN)) AND (A3 >= A4)),中期大底,60,2,0),COLORFFFFFF;DRAWTEXT(((((CROSS(J,AA) AND (A2 >= A3)) AND ((上上 – REF(上上,1)) > 0)) AND (CLOSE >= OPEN)) AND (A3 >= A4)),60,’●买’),COLOR00FFFF;均线:=MA(CLOSE,5);
DRAWICON(((CROSS(B5,A2) AND ((上上 – REF(上上,1)) > 0)) AND ((均线 – REF(均线,1)) > 0)),98,6);DRAWTEXT(((CROSS(B5,A2) AND ((上上 – REF(上上,1)) > 0)) AND ((均线 – REF(均线,1)) > 0)),98,’ 重视’),COLOR0000FF;
VARW2:=((((CLOSE – MA(CLOSE,6)) / MA(CLOSE,6)) * 100) AND ((上上 – REF(上上,1)) > 0));VARW3:=((((CLOSE – MA(CLOSE,12)) / MA(CLOSE,12)) * 100) AND ((上上 – REF(上上,1)) > 0));
VARW4:=(((CLOSE – MA(CLOSE,24)) / MA(CLOSE,24)) * 100);VARW5:=(((VARW2 + (2 * VARW3)) + (3 * VARW4)) / 6);VARW6:=MA(VARW5,3);犀牛王:=((70 * VARW6) <= (0 – 8));

大智慧波段踏浪指标公式