大智慧特色OBV指标公式

input:N1(13,1,1000,1),N2(34,1,1000,1),N3(144,1,1000,1);
OBV:SUM(IF(ISUP,VOL,IF(ISDOWN,-VOL,0)),0),layer1;
{Q6:=ATAN((ma5/REF(ma5,1)-1)*100)*180/3.1416;}
MAOBV1:MA(OBV,N1),layer1;
MAOBV2:MA(OBV,N2),layer1;
新高:OBV=HHV(OBV,N3),LINETHICK0;
新高1:OBV=HHV(OBV,N2),LINETHICK0;
新高2:OBV=HHV(OBV,N1),LINETHICK0;
FILLRGN(OBV,MAOBV1,
OBV>MAOBV1 and (NOT(新高) and NOT(新高1) and NOT(新高2)),RGB(88,0,0),
OBV>MAOBV1 and (NOT(新高) and NOT(新高1) and 新高2),RGB(88,88,88),
OBV>MAOBV1 and (NOT(新高) and 新高1),RGB(255,88,0),
OBV>MAOBV1 and (新高),RGB(255,0,0),
OBV<MAOBV1,RGB(0,255,0)),layer2;

大智慧特色OBV指标公式

 

大智慧趋势突破指标公式

input:N(10,1,500);
HH:=HHV(HIGH,N);
LL:=LLV(LOW,N);
HH1:=BARSLAST((HH > REF(HH,1)));
LL1:=BARSLAST((LL < REF(LL,1)));
if HH1< LL1 then
L1:LL,colorred,linethick2;
if HH1>LL1 then
H1:HH,LINETHICK2,color1B8800;
STICKLINE((HH1 < LL1),CLOSE,OPEN,9,0),colorred;
STICKLINE((HH1 < LL1),HIGH,LOW,0,0),coloryellow;
STICKLINE((HH1 > LL1),CLOSE,OPEN,9,0),colorgreen;
STICKLINE((HH1 > LL1),HIGH,LOW,0,0),colorwhite;
DRAWICON(CROSS(HH1,LL1),HH,11);
DRAWICON(CROSS(LL1,HH1),LL,12);
DRAWTEXT(CROSS(HH1,LL1),HH,’卖’);
DRAWTEXT(CROSS(LL1,HH1),LL,’买’);
DRAWTEXT(FILTER(((HH1 < REF(HH1,1)) AND (HH1 < LL1)),90),LOW,’♂加’);
DRAWTEXT(FILTER(((LL1 < REF(LL1,1)) AND (HH1 > LL1)),90),HIGH,’♀减’);

大智慧趋势突破指标公式

 

大智慧金牌买卖指标公式

VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
趋势: IF(VAR6>45,VAR6-45,0);
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),5,0),colorff00ff;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),5,0),color00ff00;
强弱分界:50,POINTDOT,Colorffffcc;
0,Color00Ffff;
20,POINTDOT,COlORFFAA66,linethick1;
80,POINTDOT,COlORFFAA66,linethick1;
100,Colorffff33;
v1:=llv(low,10);
v2:=hhv(h,25);
价位线:=ema((c-v1)/(v2-v1)*4,4);
DRAWTEXT(CROSS(价位线,0.3),7,’●’),ColorFFFfff;
DRAWTEXT(CROSS(3.5,价位线),102,’●’),ColorFFFfff;
Var2q:=REF(LOW,1);
Var3q:=SMA(ABS(LOW-Var2q),3,1)/SMA(MAX(LOW-Var2q,0),3,1)*100;
Var4q:=EMA(IF(CLOSE*1.3,Var3q*10,Var3q/10),3);
Var5q:=LLV(LOW,30);
Var6q:=HHV(Var4q,30);
Var7q:=IF(MA(CLOSE,58),1,0);
Var8q:=EMA(IF(LOW<=Var5q,(Var4q+Var6q*2)/2,0),3)/618*Var7q;
Var9q:=IF(Var8q>100,100,Var8q);
吸筹:STICKLINE(Var9q>-120,0,Var9q,6,1),coloryellow;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
卖临界:STICKLINE(走势-AA6>85,103,100,15,1),Color0000ff,linethick2;

大智慧金牌买卖指标公式

 

大智慧腾天通道主图指标公式

N:=13;
ZC:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v)/100);
『重心』:IF(VOL>0,zc,C),LINETHICK0,colorred;
{大通道}
KB713:=MA(HHV(MA(CLOSE,3),77),3);
KB75:=MA(LLV(MA(CLOSE,3),77),7);
『目标』:MA(HHV(MA(CLOSE,3),77),7),COLORffaacc,DOTLINE;
中线』:EMA(((KB713 + KB75) / 2),5),COLORffaacc,DOTLINE;
『防线』:MA(LLV(MA(CLOSE,3),77),3),COLORffaacc,DOTLINE;
{boll部分}
『M20』:MA(C,20),color00FF00;
『上轨』: 『M20』+ 2*STD(CLOSE,20),color00cccc,linethick2;
『下轨』: 『M20』- 2*STD(CLOSE,20),color00cccc,linethick2;
{黄金分割线}
lhnh:=BARSLAST(DISPSTATUS=1)+1;
hh:=HHV(h ,lhnh);
ll:=llV(l ,lhnh);
『金38』:(ll+(hh-ll)*0.618),coloryellow,linethick0;
『金50』:(ll+(hh-ll)*0.5),coloryellow,linethick0;
『金62』:(ll+(hh-ll)*0.382),coloryellow,linethick0;
DRAWTEXT(DISPSTATUS=2,ll+(hh-ll)*0.618,’ 38%’),coloryellow;
DRAWTEXT(DISPSTATUS=2,ll+(hh-ll)*0.5,’ 50%’),coloryellow;
DRAWTEXT(DISPSTATUS=2,ll+(hh-ll)*0.382,’ 62%’),coloryellow;
FILLRGN(ll+(hh-ll)*0.60182,ll+(hh-ll)*0.63418,c>0,995599),layer7;
FILLRGN(ll+(hh-ll)*0.48382,ll+(hh-ll)*0.51618,c>0,995599),layer7;
FILLRGN(ll+(hh-ll)*0.39818,ll+(hh-ll)*0.36582,c>0,995599),layer7;
hh,colorff00ff,pointdot,layer7;
ll,colorff00ff,pointdot,layer7;
X:=『重心』>=MA(『重心』,n);
{k线部分}
{1、多头市场}
stickline(x,h,l,0,1),COLOR0000FF;
stickline(x and c>=o,O,C,5,0),COLOR0000FF;
stickline(x and c<o,O,C,5,1),COLOR0000FF;
{2、空头市场}
stickline(not(x),H,L,1,0),COLORFFBB00;
stickline(not(x) and c<o,O,C,5,0),COLORFFBB00;
stickline(not(x) and c>=o,O,C,5,1),COLORFFBB00;

大智慧腾天通道主图指标公式

 

大智慧主控战略K线主图指标公式

平顶:=h=ref(h,1) or (h=ref(h,2) and h>ref(h,1));
drawtext(平顶,h*1.01,’平顶’),colorgreen;
partline(平顶,h),colorgreen;
平底:=l=ref(l,1) or (l=ref(l,2) and l<ref(l,1));
drawtext(平底,l*0.99,’平底’),colorgreen;
partline(平底,l),colorgreen;
阳子母:=c>ref(max(c,o),1) and h>ref(h,1) and l<ref(l,1) and c>o and ref(max(c,o),1)/ref(min(c,o),1)>1.01 and (o<>l or c<>h);
drawtext(阳子母,l*0.99,’阳子母’),coloryellow;
阴子母:=c<ref(min(c,o),1) and h>ref(h,1) and l<ref(l,1) and c<o and ref(max(c,o),1)/ref(min(c,o),1)>1.01 and (o<>h or c<>l);
drawtext(阴子母,h*1.01,’阴子母’),colorblue;
阴母子:=c>ref(min(c,o),1) and h<ref(h,1) and l>ref(l,1) and c<o and c/o<0.99;
drawtext(阴母子,h*1.01,’阴母子’),colorblue;
阳母子:=c<ref(max(c,o),1) and h<ref(h,1) and l>ref(l,1) and c>o and c/o>1.01;
drawtext(阳母子,l*0.99,’阳母子’),coloryellow;
乌云盖顶:=ref(c,1)/ref(o,1)>1.03 and c<o and h>ref(h,1) and c>ref(o,1) and l>ref(l,1) and o>ref(h,1) and c<(ref(c,1)+ref(o,1))/2;
drawtext(乌云盖顶,h*1.01,’乌云盖顶’),colorblue;
曙光初现:=ref(o,1)/ref(c,1)>1.03 and c>o and h<ref(h,1) and c<ref(o,1) and l<ref(l,1) and o<ref(l,1) and c>(ref(c,1)+ref(o,1))/2;
drawtext(曙光初现,l*0.99,’曙光初现’),coloryellow;
空戳多:=c<ref(c,1) and ref(c,1)/ref(o,1)>1.03 and c<o and h>ref(h,1) and c>ref(o,1) and l>ref(l,1) and o>ref(h,1) and c>(ref(c,1)+ref(o,1))/2;
drawtext(空戳多,h*1.01,’空戳多’),colorblue;
多戳空:=c>ref(c,1) and ref(o,1)/ref(c,1)>1.03 and c>o and h<ref(h,1) and c<ref(o,1) and l<ref(l,1) and o<ref(l,1) and c<(ref(c,1)+ref(o,1))/2;
drawtext(多戳空,l*0.99,’多戳空’),coloryellow;
空头反攻:=c=ref(c,1) and ref(c,1)/ref(o,1)>1.03 and c<o and h>ref(h,1) and c>ref(o,1) and l>ref(l,1) and o>ref(h,1);
drawtext(空头反攻,h*1.01,’空头反攻’),colorblue;
多头反攻:=c=ref(c,1) and ref(o,1)/ref(c,1)>1.03 and c>o and h<ref(h,1) and c<ref(o,1) and l<ref(l,1) and o<ref(l,1);
drawtext(多头反攻,l*0.99,’多头反攻’),coloryellow;
玉柱:=c>ref(max(c,o),1) and h>ref(h,1) and l<ref(l,1) and c>o and ref(max(c,o),1)/ref(min(c,o),1)>1.01 and o=l and c=h;
drawtext(玉柱,l*0.99,’玉柱’),coloryellow;
危楼:=c<ref(min(c,o),1) and h>ref(h,1) and l<ref(l,1) and c<o and ref(max(c,o),1)/ref(min(c,o),1)>1.01 and o=h and c=l;
drawtext(危楼,h*1.01,’危楼’),colorblue;
{3根k线组合}
红三兵:=count(h/c<1.02,3)=3 and count(c/o>1.01,3)=3 and count(c>ref(c,1),2)=2 and count(h>ref(h,1),2)=2 and count(l>ref(l,1),2)=2 and abs(ref(c,2)/ref(o,2)-ref(c,1)/ref(o,1))<0.02 and abs(ref(c,1)/ref(o,1)-c/o)<0.02;
drawtext(红三兵,l*0.99,’红三兵’),coloryellow;
黑三兵:=count(c/l<1.02,3)=3 and count(o/c>1.01,3)=3 and count(c<ref(c,1),2)=2 and count(h<ref(h,1),2)=2 and count(l<ref(l,1),2)=2 and abs(ref(c,2)/ref(o,2)-ref(c,1)/ref(o,1))<0.02 and abs(ref(c,1)/ref(o,1)-c/o)<0.02;
drawtext(黑三兵,h*1.01,’黑三兵’),colorblue;
大敌当前:=count(c/o<1.03,2)=2 and count(h/c>1.015,2)=2 and count(c>o,3)=3 and count(c>ref(c,1),2)=2 and count(h>ref(h,1),2)=2 and count(l>ref(l,1),2)=2 and ref(c,2)/ref(o,2)>1.03 and ref(c,2)/ref(o,2)>ref(c,1)/ref(o,1) and ref(c,2)/ref(o,2)>c/o and h/c>ref(h/c,2) and ref(h/c,1)>ref(h/c,2);
drawtext(大敌当前,l*0.99,’大敌当前’),colorblue;
步步为营:=count(c>o,3)=3 and count(c>ref(c,1),2)=2 and count(h>ref(h,1),2)=2 and count(l>ref(l,1),2)=2 and (ref(c/o,2)>1.03 or ref(c/o,1)>1.03) and c/o<ref(c/o,2) and c/o<ref(c/o,1 and h/c>ref(h/c,2) and h/c>ref(h/c,1)) and h/c>1.02;
drawtext(步步为营,l*0.99,’步步为营’),colorblue;
离黑战车:=ref(c/o,2)>1.01 and ref(o/c,1)>1.01 and c/o>1.01 and ref(h/c,2)<1.02 and ref(h/o,1)<1.02 and h/c<1.02 and ref(o,1)>ref(c,2) and c>ref(o,1) and count(h>ref(h,1),2)=2 and count(l>ref(l,1),2)=2 and abs(ref(c/o,2)-ref(o/c,1))<0.02 and abs(ref(o/c,1)-c/o)<0.02 and ref(c,1)>ref(o,2);
drawtext(离黑战车,l*0.99,’离黑战车’),coloryellow;
离白战车:=ref(o/c,2)>1.01 and ref(c/o,1)>1.01 and o/c>1.01 and ref(h/o,2)<1.02 and ref(h/c,1)<1.02 and h/o<1.02 and (ref(c,1)=ref(o,2) or ref(c,1)<ref(o,2)) and o<ref(c,1) and c<ref(o,1) and count(h<ref(h,1),2)=2 and count(l<ref(l,1),2)=2 and abs(ref(c/o,2)-ref(o/c,1))<0.02 and abs(ref(o/c,1)-c/o)<0.02;
drawtext(离白战车,h*1.01,’离白战车’),colorblue;
晨星:=(ref(c/o,2)<0.97 and abs(ref(c/o,1)-1)<0.015 and c/o>1.025 and ref(max(c,o),1)<ref(c,2) and o>ref(max(c,o),1))
or (ref(c/o,3)<0.97 and abs(ref(c/o,1)-1)<0.02 and abs(ref(c/o,2)-1)<0.02 and c/o>1.025 and ref(max(c,o),2)<ref(c,3) and ref(max(c,o),1)<ref(c,3) and o>ref(max(c,o),1) and o>ref(max(c,o),2));
drawtext(晨星,l*0.99,’晨星’),coloryellow;
夜星:=(ref(o/c,2)<0.97 and abs(ref(c/o,1)-1)<0.015 and o/c>1.025 and ref(min(c,o),1)>ref(c,2) and o<ref(min(c,o),1))
or (ref(o/c,3)<0.97 and abs(ref(c/o,1)-1)<0.02 and abs(ref(c/o,2)-1)<0.02 and o/c>1.025 and ref(min(c,o),2)>ref(c,3) and ref(min(c,o),1)>ref(c,3) and o<ref(min(c,o),1) and o<ref(min(c,o),2));
drawtext(夜星,h*1.01,’夜星’),colorblue;
双鸦:=ref(c/o,2)>1.03 and ref(o/c,1)-1<0.015 and ref(c,1)>ref(c,2) and ref(o,1)>ref(c,2) and o/c>1.025 and o<ref(o,1) and o>ref(c,1) and h<ref(h,1) and c<ref(c,2);
drawtext(双鸦,h*1.01,’双鸦’),colorblue;
双鸦耀空:=ref(c/o,2)>1.03 and ref(o/c,1)<1.015 and o/c<1.015 and ref(c,1)>ref(c,2) and c>ref(c,2) and c<o and ref(c,1)<ref(o,1);
drawtext(双鸦耀空,h*1.01,’双鸦耀空’),colorblue;
上肩缺口:=ref(h,1)=ref(hhv(h,20),1) and count(ma(c,10)>ref(ma(c,10),1),13)>10 and ref(c/o,2)>1.03 and ref(c/o,1)>1.02 and ref(l,1)>ref(h,2) and h<ref(h,1) and o<ref(c,1) and l<ref(l,1) and c<ref(o,1) and o/c>1.02 and c>ref(h,2);
drawtext(上肩缺口,l*0.99,’上肩缺口’),coloryellow;
下肩缺口:=ref(l,1)=ref(llv(l,20),1) and count(ma(c,10)<ref(ma(c,10),1),13)>10 and ref(o/c,2)>1.03 and ref(o/c,1)>1 and ref(h,1)<ref(l,2) and l>ref(l,1) and c>ref(o,1) and h>ref(h,1) and o>ref(c,1) and c/o>1.02 and c<ref(l,2);
drawtext(下肩缺口,h*1.01,’下肩缺口’),colorblue;
{4根k线组合}
上扬三法:=ref(c/o,3)>1.03 and ref(h,2)>ref(h,3) and ref(c,2)<ref(c,3) and ref(o,2)>ref(c,3) and ref(h,1)<ref(h,2) and ref(l,1)<ref(l,2) and h<ref(h,1) and l<ref(l,1) and ref(c,1)<ref(c,2) and c<ref(c,1) and l>ref(o,3) and count(o/c>1.03,3)<2 and count(o/c>1.01,3)>1 and count(c<o,3)=3;
drawtext(上扬三法,l*0.99,’上扬三法’),coloryellow;
下跌三法:=ref(o/c,3)>1.03 and ref(l,2)<ref(l,3) and ref(c,2)>ref(c,3) and ref(o,2)<ref(c,3) and ref(h,1)>ref(h,2) and ref(l,1)>ref(l,2) and h>ref(h,1) and l>ref(l,1) and ref(c,1)>ref(c,2) and c>ref(c,1) and h<ref(o,3) and count(c/o>1.03,3)<2 and count(c/o>1.01,3)>1 and count(c>o,3)=3;
drawtext(下跌三法,h*1.01,’下跌三法’),colorblue;
宝塔翻白:=ref(count(c>ref(c,1),3),1)=0 and ref(count(c<o,3),1)=3 and l<ref(l,1) and o<ref(c,1) and h>ref(hhv(h,3),1) and c>ref(hhv(c,3),1);
drawtext(宝塔翻白,l*0.99,’宝塔翻白’),coloryellow;
宝塔翻黑:=ref(count(c<ref(c,1),3),1)=0 and ref(count(c>o,3),1)=3 and h>ref(h,1) and o>ref(c,1) and l<ref(llv(l,3),1) and c<ref(hhv(o,3),1);
drawtext(宝塔翻黑,h*1.01,’宝塔翻黑’),colorblue;
{多根k线组合}
离黑:=ma(c,13)>ref(ma(c,13),1) and ref(count(hhv(c,10)/llv(o,10)<1.15,10),1)=10 and o/ref(max(c,o),1)>1.01 and c/ref(h,1)>1.05 and h=hhv(h,15) and h/c<1.02;
drawtext(离黑,l*0.99,’离黑’),coloryellow;
离白:=ma(c,13)<ref(ma(c,13),1) and ref(count(hhv(c,10)/llv(o,10)<1.15,10),1)=10 and o/ref(min(c,o),1)<0.99 and c/ref(l,1)<0.95 and l=llv(l,15) and l/c<1.02;
drawtext(离白,h*1.01,’离白’),colorblue;

大智慧主控战略K线主图指标公式

 

大智慧夺权专家主图指标公式

INPUT: M(1,0,12),N(21,3,60),N1(3,3,5),ZZ(1,1,3),M10(5,1,20);
{上面这个是具体参数。}
c1:=(C+2*H+L+O)/5;
a1:=EMA((EMA(c1,1)+EMA(c1,3)+EMA(c1,5))/3,3);
a2:=EMA((EMA(c1,6)+EMA(c1,8)+EMA( c1,10))/3,3);
a3:=EMA((EMA(c1,10)+EMA(c1,12)+EMA( c1,14))/3,3);
a4:=EMA((EMA(c1,14)+EMA(c1,16)+EMA( c1,18))/3,3);
a5:=EMA((EMA(c1,18)+EMA(c1,20)+EMA( c1,22))/3,3);
a6:=EMA((EMA(c1,22)+EMA(c1,24)+EMA(c1,26))/3,3);
a:=EMA((EMA(c1,29)+EMA(c1,31)+EMA(c1,33))/3,3);
tj:=c1>a;
tj2:=c1>OPEN or c1=OPEN and c1>REF(c1,1);
STICKLINE(tj2,H,L,0.5,0),colorred;
STICKLINE(tj,O,C,8,0),color102088;
STICKLINE(tj,O,C,7,0),color102099;
STICKLINE(tj,O,C,6,0),color1020aa;
STICKLINE(tj,O,C,5,0),color1020bb;
STICKLINE(tj,O,C,4,0),color1020cc;
STICKLINE(tj,O,C,3,0),color1020dd;
STICKLINE(tj,O,C,2,0),color1020ee;
STICKLINE(tj,O,C,1,0),color1020ff;
STICKLINE(NOT(tj),O,C,8,0),colorff7700;
STICKLINE(NOT(tj),O,C,7,0),colorff8800;
STICKLINE(NOT(tj),O,C,6,0),colorff9900;
STICKLINE(NOT(tj),O,C,5,0),colorffaa00;
STICKLINE(NOT(tj),O,C,4,0),colorffbb00;
STICKLINE(NOT(tj),O,C,3,0),colorffcc00;
STICKLINE(NOT(tj),O,C,2,0),colorffdd00;
STICKLINE(NOT(tj),O,C,1,0),colorffee00;
Var2:=LLV(L,11);
Var3q:=HHV(H,25);
警戒线:= 1 ;
减仓线:= 2 ;
卖出线:= 3 ;
空头线:=1;
动力线:= EMA((C-Var2)/(Var3q-Var2)*4,4);
DRAWICON(CROSS(动力线,警戒线),h+0.01,1);
DRAWICON(CROSS(动力线,减仓线),h+0.01,3);
DRAWICON(CROSS(动力线,卖出线),H+0.01,4);
c11:=REF(C,1);
c2:=HHV(c11,2);
c3:=LLV(c11,1);
et:=HHV(c11,2);
et1:=REF(et,1);
xb:=LLV(c11,1);
xb1:=REF(xb,1);
s:=BARSLAST(C<xb and c11>=xb1);
m1q:=REF(m,1);
n9:=BARSLAST(C>et and c11<=et1);
s1:=REF(n9,1);
m2:=BARSLAST(m-n9>0 and m1q<=n1)+1;
n2:=BARSLAST(n9-m>0 and n1<=m1q)+1;
et2:=HHV(et,m2);
xb2:=LLV(xb,n2);
app:=IF(m-n9>0 and m1q<=n1,1,IF(n9-m>0 and n1<=m1q,0,2));
h11:=IF(m-n9>0,C,et2);
h2:=IF(app=1,C,c2);
h3:=IF(m-n9<0,C,xb2);
h4:=IF(app=1,C,xb2);
关键位:=IF(m-n9>0 or app=1 ,CLOSE,h3);
m1:=MA(C,3);
多空线:MA(C,8),Color00FFFF;
生命线:MA(C,21),Color00FF00;
均线变异:=IF(m1>生命线,生命线,m1);
PARTLINE(多空线,多空线<ref(多空线,1),RGB(255,0,255)),ColorFF00FF,linethick2;
PARTLINE(均线变异,均线变异>REF(均线变异,1) and 均线变异=生命线,RGB(255,0,0)),Color00FF00,linethick2;
WW:=(MA(C,3)+MA(C,8)+MA(C,15)+MA(C,34))/4;
DRAWICON(CROSS(C,WW),LOW-0.02,4);
DRAWICON(CROSS(WW,C),HIGH+0.04,5);
DRAWTEXT(CROSS(C,WW),LOW-0.02,’ 开多’),Color0000FF;
DRAWTEXT(CROSS(WW,C),HIGH+0.06,’ 多平’),Color8080FF;
STICKLINE(C<OPEN and REF(C,1)>REF(O,1),REF(C,1),REF(C,1),20,0),COLORFFFFFF;
DRAWTEXT(FILTER(EMA(C,40)-EMA(C,8)>0 AND EMA(C,8)/L>1.16,3),LOW-0.02,’●’),linethick3 , COLORMAGENTA;
DRAWTEXT(FILTER(EMA(C,8)-EMA(C,40)>0 AND HIGH/EMA(C,8)>1.16,3),HIGH+0.02,’●’),linethick3 ,color99ff00;

大智慧夺权专家主图指标公式

 

大智慧风险评估指标公式

n:=55;
活期存款利率:=0.81*1.0;
一年期存款利率:=3.87*1.0;
三年期存款利率:=5.22*1.0;
名义无风险利率:=一年期存款利率;
风险补偿率:=0.03986;
投资期望收益率:=名义无风险利率+风险补偿率;
风险补偿率二:=0.03986;
名义无风险利二:=三年期存款利率;
i2:=名义无风险利二+风险补偿率二;
v0:=1/(1+投资期望收益率);
x0:=1/(1+i2);
m2:=1;
k1:=0.68;
k11:=0.75;
v1:=(POW(1+投资期望收益率,K1)-1)/投资期望收益率;
x1:=(POW(1+i2,K11)-1)/i2;
g:=0.03;
m:=2;
g2:=0.05;
v2:=1-POW((1+g)/(1+投资期望收益率),m-1);
x2:=1-POW((1+g2)/(1+i2),m2-1);
v3:=(1+g)*v2/(投资期望收益率-g);
x3:=(1+g2)*x2/(i2-g2);
v4:=POW(v0,k1+(m-1))/投资期望收益率;
x4:=POW(x0,k11+(m2-1))/i2;
v5:=(v1+v3);
x5:=(x1+x3);
每股收益:=FINANCE2(3);
预期每股收益:=0.278;
预期每股收益二:=0.29;
股息分配比例:=0.35;
股息分配比例二:=0.42;
红股折算股息:=0.12;
红股折算股息二:=0.09;
现金股息:=预期每股收益*股息分配比例;
现金股息二:=预期每股收益二*股息分配比例二;
基准股息:=现金股息+红股折算股息;
基准股息二:=现金股息二+红股折算股息二;
d:=基准股息;
d2:=基准股息二;
上证指数平均价:="SH000001$AMOUNT"/"SH000001$VOL"/100;
深圳成指平均价:="SZ399001$AMOUNT"/"SZ399001$VOL"/100;
沪深个股平均价:=("SH000001$AMOUNT"+"SZ399001$AMOUNT")/("SH000001$VOL"+"SZ399001$VOL")/100;
股票平均成交价:=AMOUNT/(VOL*100);
股票理论价格:=d*POW(V0,K1)*v5+d*POW(1+g,m-1)*v4;
股票理论价格二:=d2*POW(x0,K11)*x5+d2*POW(1+g2,m2-1)*x4;
股价泡沫率估算:=100*(股票平均成交价-股票理论价格)/股票理论价格/1000;
泡沫估算二:=100*(股票平均成交价-股票理论价格二)/股票理论价格二;
今成交均价:=股票平均成交价;
理论价估算:=股票理论价格;
理论价二:=股票理论价格二;
每股市盈率:=DYNAINFO(39);
股票合理市赢率:=股票理论价格/预期每股收益*100;
股票合理市赢二:=股票理论价格二/预期每股收益二;
合理市赢二:=股票合理市赢二;
十日均价泡沫估:=100*(ma(股票平均成交价,10)-股票理论价格)/股票理论价格/1000;
{趋势+逃顶 参数n:40 100 55 }
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
个股升降坐标:IF(VAR6>n,VAR6-n,0),PRECIS2,colorf00ff0;
STICKLINE(REF(个股升降坐标,1)<个股升降坐标,个股升降坐标,REF(个股升降坐标,1),5,0),colorf00ff0;
STICKLINE(REF(个股升降坐标,1)>个股升降坐标,个股升降坐标,REF(个股升降坐标,1),5,0),color00ff00;
历史最高成交价:=HHV(HIGH,0);
历史最低成交价:=LLV(LOW,0);
H1:=INDEXA;
大盘短线压力:=(((INDEXC + INDEXL) + INDEXH) / 3);
XHH:=((INDEXA / INDEXV) / 100);
短线支撑:=(IF((INDEXC > 200),大盘短线压力,XHH) – INDEXL);
大盘短线支撑:=(INDEXC – 短线支撑);
VAR193:=(INDEXC + 短线支撑);
DRAWTEXTABS(20,5,’■活期存款利率:’+NUMTOSTRN(活期存款利率,2)+’%’),Color00FFFF;
DRAWTEXTABS(170,5,’■一年期存款利率:’+NUMTOSTRN(一年期存款利率,2)+’%’),Color00FFFF;
DRAWTEXTABS(325,5,’■三年期存款利率:’+NUMTOSTRN(三年期存款利率,2)+’%’),Color00FFFF;
DRAWTEXTABS(490,5,’■存款名义无风险利率:’+NUMTOSTRN(名义无风险利率,2)+’%’),Color00FFFF;
DRAWTEXTABS(20,20,’■存款风险补偿率:’+NUMTOSTRN(风险补偿率,2)+’%’),Color00FFFF;
DRAWTEXTABS(170,20,’■个股股息分配比例:’+NUMTOSTRN(股息分配比例,2)+’%’),Color00FFFF;
DRAWTEXTABS(325,20,’■个股分红折算股息:’+NUMTOSTRN(红股折算股息,2)+’元’),Color00FFFF;
DRAWTEXTABS(490,20,’■持有个股基准股息:’+NUMTOSTRN(基准股息,2)+’元/股’),Color00FFFF;
DRAWTEXTABS(20,75,’■当前每股收益:’+NUMTOSTRN(每股收益,2)+’元’),Color00FF00;
DRAWTEXTABS(175,75,’■理想预期每股收益:’+NUMTOSTRN(预期每股收益,2)+’元’),Color00FF00;
DRAWTEXTABS(345,75,’■当前每股市盈率:’+NUMTOSTRN(每股市盈率,1)+’倍’),Color00FF00;
DRAWTEXTABS(520,75,’■个股合理市赢率:’+NUMTOSTRN(股票合理市赢率,2)+’倍’),Color00FF00;
DRAWTEXTABS(680,75,’■投资期望收益率:’+NUMTOSTRN(投资期望收益率,2)+’%’),Color00FF00;
DRAWTEXTABS(20,90,’■上证指数均价:’+NUMTOSTRN(上证指数平均价,2)+’元’),ColorFFFFFF;
DRAWTEXTABS(175,90,’■深圳成指均价:’+NUMTOSTRN(深圳成指平均价,2)+’元’),ColorFFFFFF;
DRAWTEXTABS(345,90,’■沪深个股平均价:’+NUMTOSTRN(沪深个股平均价,2)+’元’),ColorFFFFFF;
DRAWTEXTABS(520,90,’■个股对应大盘平均成交价:’+NUMTOSTRN(股票平均成交价,2)+’元’),ColorFFFFFF;
DRAWTEXTABS(20,105,’■对应经济周期【股价泡沫率】估算:’+NUMTOSTRN(股价泡沫率估算,0)+’% →’),ColorFFFF00;
DRAWTEXTABS(265,105,’当前个股成交均价:’+NUMTOSTRN(今成交均价,2)+’元 →’),ColorFFFF00;
DRAWTEXTABS(440,105,’对应经济周期十日【均价泡沫率】估算:’+NUMTOSTRN(十日均价泡沫估,0)+’%’),ColorFFFF00;
DRAWTEXTABS(20,120,’■历史最高成交价:’+NUMTOSTRN(历史最高成交价,2)+’元’),Color0000FF;
DRAWTEXTABS(200,120,’■历史最低成交价:’+NUMTOSTRN(历史最低成交价,2)+’元’),Color0000FF;
DRAWTEXTABS(370,120,’■大盘短线压力: ‘+NUMTOSTRN(大盘短线压力,2)+’点’),Color0000FF;
DRAWTEXTABS(540,120,’■大盘短线支撑: ‘+NUMTOSTRN(大盘短线支撑,2)+’点’),Color0000FF;

大智慧风险评估指标公式

 

大智慧庄走我走指标公式

主仓:EMA(85*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3) ,stick,PRECIS0;
散仓:EMA(85*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORFFAA66,stICK,PRECIS0;
散筹:(WINNER(C*1.1)-WINNER(C*0.9))*80, colorgreen ,stick,PRECIS0;
庄筹:WINNER(C)*85, colorred ,stick,LINETHICK1,PRECIS0;
界: 65,coloryellow,PRECIS0;
0,coloryellow,PRECIS0;
JJ2:=REF(LOW,1);
JJ3:=((SMA(ABS((LOW – JJ2)),3,1) / SMA(MAX((LOW – JJ2),0),3,1)) * 100);
JJ4:=EMA(IF((CLOSE * 1.3),(JJ3 * 10),(JJ3 / 10)),3);
JJ5:=LLV(LOW,30);
JJ6:=HHV(JJ4,30);
JJ8:=((EMA(IF((LOW <= JJ5),((JJ4 + (JJ6 * 2)) / 2),0),3) / 6180) * 2.5);
JJ9:=IF((JJ8 > 15),15,JJ8);
增减力度:=(((MA(CLOSE,40) – CLOSE) / MA(CLOSE,40)) * 10);
小主力:if((JJ9 > 0),JJ9,0),STICK,LINETHICK2,colorFFFFff,PRECIS0;
if((JJ9 < 5),JJ9,0),STICK,LINETHICK2,colorgreen,PRECIS0;
J22:=REF(LOW,1);
J23:=((SMA(ABS((LOW – J22)),3,1) / SMA(MAX((LOW – J22),0),3,1)) * 100);
J24:=EMA(IF((CLOSE * 1.3),(J23 * 10),(J23 / 10)),3);
J25:=LLV(LOW,30);
J26:=HHV(J24,30);
低:=(((CLOSE – MA(CLOSE,40)) / MA(CLOSE,40)) * 100);
FILLRGN((低 < 0),0,(0 – 低)),colorgreen;
J1:=(((((3 * CLOSE) + LOW) + OPEN) + HIGH) / 6);
J2:=(((((((((((((((((((((20 * J1) + (19 * REF(J1,1))) + (18 * REF(J1,2))) + (17 * REF(J1,3))) + (16 * REF(J1,4))) + (15 * REF(J1,5))) + (14 * REF(J1,6))) + (13 * REF(J1,7))) + (12 * REF(J1,8))) + (11 * REF(J1,9))) + (10 * REF(J1,10))) + (9 * REF(J1,11))) + (8 * REF(J1,12))) + (7 * REF(J1,13))) + (6 * REF(J1,14))) + (5 * REF(J1,15))) + (4 * REF(J1,16))) + (3 * REF(J1,17))) + (2 * REF(J1,18))) + REF(J1,20)) / 211);
J3:=MA(J2,10);
有:=((J2 – J3) * 22);
J4:=IF(((REF(有,1) > 有) AND (有 > 0)),1,0);
J5:=((J4 AND (REF(J4,1) = 0)) AND (有 > 2));
J6:=HHV(CLOSE,115);
J7:=LLV(CLOSE,115);
J8:=(J6 – J7);
J9:=(MA((((CLOSE – J7) / J8) – 0.5),14) * 20);
JA:=REF(HHV(CLOSE,66),2);
JB:=IF(((J9 < 0) AND (有 < 0)),ABS((有 + J9)),0);
主力:IF((JB > 20),(1.28 * JB),0),STICK,LINETHICK2,colorFFFFff,PRECIS0;
FILLRGN((JB > 20),JB,(1.28 * JB)),colorFFFFff;
吸筹:JB,STICK,LINETHICK2,colorred,PRECIS0;
进场吸:IF(((0 – J9) > 0),(0 – J9),0),STICK,LINETHICK2,colorFFFF00,PRECIS0;
洗盘吸:IF(((0 – 有) > 0),(0 – 有),0),STICK,LINETHICK4,coloryellow,PRECIS0;
A1:=BARSLAST(ref(cross("macd.diff","macd.dea"),1));
MACD:ref(c,A1+1)>c and ref("macd.diff",A1+1)<"macd.diff" and cross("macd.diff","macd.dea"),colorgreen;
STICKLINE(FILTER(MACD>0,5),0,10,6,0),COLORgreen;
DRAWTEXT(FILTER(MACD>0,5),10,’DI1′),COLORgreen;
A2:=BARSLAST(ref(cross("kdj.k","kdj.d"),1));
KDJ:ref(c,A2+1)>c and ref("kdj.k",A2+1)<"kdj.k" and cross("kdj.k","kdj.d"),colorred;
STICKLINE(FILTER(KDJ>0,5),0,10,6,0),COLORred;
DRAWTEXT(FILTER(KDJ>0,5),10,’DI2′),COLORred;
A3:=BARSLAST(ref(cross("RSI.RSI1","RSI.RSI2"),1));
RSI:ref(c,A3+1)>c and ref("RSI.RSI1",A3+1)<"RSI.RSI1" and cross("RSI.RSI1","RSI.RSI2"),coloryellow;
STICKLINE(FILTER(RSI>0,5),0,10,6,0),COLORyellow;
DRAWTEXT(FILTER(RSI>0,5),10,’DI3′),COLORyellow;
A5:=REF(LLVBARS(LOW,120),5);
底:(LOW=LLV(LOW,120) AND "MACD.DIFF">REF("MACD.DIFF",A5+3) AND "MACD.DIFF">REF("MACD.DIFF",1))*15,color009900;

大智慧庄走我走指标公式

 

大智慧满仓主图指标公式

指导: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick2,colorwhite;
界: MA(CLOSE,27),linethick2,Coloryellow;
stickline(指导>界,指导,界,5,0),color000082;
stickline(指导<界,指导,界,5,0),COLORFFBB00;
A0:=AMOUNT/VOL/100;
A1:=(EMA(A0,3)>EMA(A0,7) AND EMA(A0,7)>EMA(A0,13) AND EMA(A0,13)>EMA(A0,21))*6;
DRAWICON(A1,界,8);
顶: COST(95),linethick2,Colorred;
Var11:=(2*CLOSE+HIGH+LOW)/4;
底: EMA(Var11,99)*0.91, linethick2,colorgreen ;
{立体K线}
STICKLINE(CLOSE>OPEN,H,LOW,0.3,0 ),COLOR9933FF;
STICKLINE(OPEN>=CLOSE,L,HIGH,0.3,0 ),COLOR66CC33;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.5,0),COLOR33FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0),COLOR66FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0 ),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0 ),COLOR0033FF;
aa:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(aa,open,close,5,0),coloryellow;
STICKLINE(aa,low,HIGH,0.5 ,0 ),coloryellow;
STICKLINE(aa,open,close,5,0),coloryellow;
STICKLINE(aa,low,HIGH,0.5 ,0 ),coloryellow;
MA1:=MA(CLOSE,8);
MA2:=MA(CLOSE,13);
MA3:=MA(CLOSE,21);
FFF:=(LOW<=MA1 AND LOW<=MA2 AND LOW<=MA3 AND CLOSE>=MA1 AND
CLOSE>=MA2 AND CLOSE>=MA3 AND CLOSE>REF(CLOSE,1));
STICKLINE(fff,CLOSE,OPEN,5,0),COLORff00ff;
STICKLINE(fff,h,l,0,0 ),COLORff00ff;
Var1a:=CROSS(MA(CLOSE,5),MA(CLOSE,30));
DRAWTEXT(Var1a AND CLOSE>MA(CLOSE,250),LOW-LOW*0.01,’少量买 ‘),colorWHITE;
DRAWTEXT(Var1a AND CLOSE>=MA(CLOSE,60) AND CLOSE<=MA(CLOSE,250),LOW-LOW*0.02,’半仓买’),coloryellow;
DRAWTEXT(Var1a AND CLOSE<MA(CLOSE,60),LOW-LOW*0.04,’全仓买 ‘),colorFF00FF;
Var1:=REF(CLOSE,1);
Var3:=SMA(MAX(CLOSE-Var1,0),12,1)/SMA(ABS(CLOSE-Var1),12,1)*100;
Var4:=MA(Var3,4);
Var5:=IF(CROSS(Var4,REF(Var4,2)) AND Var4<32,80,IF(CROSS(REF(Var4,2),Var4) AND Var4>62,20,50));
DRAWTEXT(Var5>50,LOW,’–买入‘),coloryellow ;
DRAWTEXT(Var5<50,HIGH*1.008,’卖出’),colorgreen;
DRAWTEXT(Var5>50,LOW*0.985,’机会!’),colorRED ;
DRAWTEXT(Var5<50,HIGH*1.03,’小心!’),colorWHITE;
DRAWTEXT(Var1a AND CLOSE<MA(CLOSE,60),LOW-LOW*0.04,’全仓买 ‘);

大智慧满仓主图指标公式

 

大智慧换手和板块主图指标公式

{参数设置 年:最小1990,最大3000,缺省年2014 月:1,12,1 (缺省月7)日:1,31,1(缺省日17)}
年:=2015;
月:=2;
日:=26;
时间:=(年-1900)*10000+月*100+日;
DRAWTEXT(BARSLAST(DATE>=时间),L*0.94,’换手起点’),COLORRED;
DRAWICON(BARSLAST(DATE>=时间),L*0.98,1);
HSL:100*VOL/(capital),linethick0;
上市日期:(FINANCE2(2)-19000000),linethick0;
{天数:BARSLAST(DATE<=1140101);
累积换手:=SUM(HSL,5);}
HS100:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=100,0),linethick0;
HS200:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=200,0),linethick0;
HS300:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=300,0),linethick0;
HS400:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=400,0),linethick0;
HS500:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=500,0),linethick0;
HS600:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=600,0),linethick0;
HS700:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=700,0),linethick0;
HS800:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=800,0),linethick0;
HS900:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=900,0),linethick0;
HS1000:IF(DATE>=时间,SUM(HSL,if(上市日期<=时间,BARSLAST(DATE<=时间),0))>=1000,0),linethick0;
DRAWTEXT(CROSS(HS100,0.99),L*0.94,’换100′),COLORYELLOW;
DRAWICON(CROSS(HS100,0.99),L*0.98,1);
DRAWTEXT(CROSS(HS200,0.99),L*0.94,’换200′),COLORGREEN;
DRAWICON(CROSS(HS200,0.99),L*0.98,1);
DRAWTEXT(CROSS(HS300,0.99),L*0.94,’换300′),COLORWHITE;
DRAWICON(CROSS(HS300,0.99),L*0.98,1);
DRAWTEXT(CROSS(HS400,0.99),L*0.97,’换400′),COLORWHITE;
DRAWTEXT(CROSS(HS500,0.99),L*0.97,’换500′),COLORWHITE;
DRAWTEXT(CROSS(HS600,0.99),L*0.97,’换600′),COLORWHITE;
DRAWTEXT(CROSS(HS700,0.99),L*0.97,’换700′),COLORWHITE;
DRAWTEXT(CROSS(HS800,0.99),L*0.97,’换800′),COLORWHITE;
DRAWTEXT(CROSS(HS900,0.99),L*0.97,’换900′),COLORWHITE;
DRAWTEXT(CROSS(HS1000,0.99),L*0.97,’换1000′),COLORWHITE;
X1:=STRFIND(BKNAME,’自选股,’,1); x2:=STRFIND(BKNAME,’自选股1底部,’,1);
x3:=STRFIND(BKNAME,’自选股2平台,’,1); x4:=STRFIND(BKNAME,’自选股A绩优,’,1);
x5:=STRFIND(BKNAME,’自选股B绩优增仓,’,1);
x:=max(1,x1,x2,x3,x4,x5);
x1:= if(x=x1,7,if(x=x2 or x=x3 or x=x4,12,if(x=x5,16,0)));
{BK1:=STRMID(BKNAME,x+x1,8); X6:=if(STRFIND(BK1,’,’,1)<>0,STRFIND(BK1,’,’,1),9);
BK:=STRMID(BKNAME,x+x1,x6-1);}
BK:=STRMID(BKNAME,x+x1,200);
DRAWTEXTABS(0,10,’板块名称:’+BK),Color9DFFFF;

大智慧换手和板块主图指标公式