大智慧骄生冠养主图指标公式

jjx:=ABS(OPEN+HIGH+LOW+CLOSE)/4;
生命:MA(jjx,5),ColorYELLOW;
VL:=REF(LOW,1); VH:=REF(H,1);
Var1:=SMA(ABS(H-Vh),13,1)/SMA(MAX(H-Vh,0),13,1)*100;
Var2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;
Var3:=MA(Var1,13);
Var4:=MA(Var2,13);
Var5:=LLV(L,34);
Var6:=HHV(H,34);
Var7:=EMA(IF(H>=Var6,Var3,0),3);
Var8:=EMA(IF(L<=Var5,Var4,0),3);
var9:=(SMA(SMA((((CLOSE – LLV(LOW,54)) / (HHV(HIGH,54) – LLV(LOW,54))) * 100),7,1),5,1));
var10:=((SMA(((CLOSE – LLV(LOW,54)) / (HHV(HIGH,54) – LLV(LOW,54)) * 100),7,1)) * 16.18) – (var9* 10.9);
Var11:=FILTER(IF(var10<=var9 AND Var8>REF(Var8,1),Var8*8,0),55);
Var21:=LLV(LOW,60);
Var31:=HHV(HIGH,60);
Var41:=EMA((CLOSE-Var21)/(Var31-Var21)*100,13);
Var51:=EMA(0.667*REF(Var41,1)+0.333*Var41,21);
varl2:=FILTER(CROSS(Var51,Var41) AND Var41>84,13);
{K线}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,4,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),color00ff00;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,4,0),color00ff00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3.5,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.5,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.5,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.5,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0) ,COLORFFBBFF;
持股线:MA(C,26),LINETHICK2,COLOR6600FF;
DRAWTEXT(var11,L*0.98,’手机锁定’),ColorFFFF00;
STICKLINE(var11,H,L,1,1),COLORRED;
STICKLINE(var11,OPEN,CLOSE,4.5,0),COLOR000099;
STICKLINE(var11,OPEN,CLOSE,3,0),COLOR0000BB;
STICKLINE(var11,OPEN,CLOSE,2,0),COLOR0000FF;
DRAWTEXT(varl2,H*1.04,’维修电脑’),ColorYELLOW;
STICKLINE(varl2,H,L,1,1),COLORYELLOW;
STICKLINE(varl2,OPEN,CLOSE,4.5,0),COLOR00CCCC;
STICKLINE(varl2,OPEN,CLOSE,3,0),COLOR33FFCC;
STICKLINE(varl2,OPEN,CLOSE,2,0),COLOR00FFFF;

大智慧骄生冠养主图指标公式

 

大智慧分时涨板主图指标公式

M:=20;
N:=480;
P1:=240;
P2:=30;
分时顶:HHV(H,N),COLORRED,LINETHICK2;
现价:C,COLORWHITE,LINETHICK2;
W1:=C=HHV(C,M);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
均线5:MA(C,5),LINETHICK1,COLORCYAN;
均价线:SUM(现价*V,P1)/SUM(V,P1),COLORYELLOW;
分时压力:MA(REF(HHV(C,P2),1),2),COLORMAGENTA;
分时支撑:MA(REF(LLV(C,P2),1),2),COLORBLUE;
DRAWICON(W4 AND COUNT(W4,5)=1,分时压力,7);
STICKLINE(FILTER(CROSS(C,REF(分时顶,1)),10) AND C>REF(分时顶,1),C*0.99,C,4,0),COLORMAGENTA;

大智慧分时涨板主图指标公式

 

大智慧鳄鱼出山主图指标公式

Y:=(H+L)/2;
BLUE:=SMA(Y,13,1);
RED:=SMA(Y,8,1);
GREEN:=SMA(Y,5,1);
B2:=REF(BLUE,8);
R2:=REF(RED,5);
G2:=REF(GREEN,3);
KU1:=IF(H=HHV(H,3),1,0);
KD1:=IF(L=LLV(L,3),1,0);
UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0,REF(H,2),REF(H,2+BARSLAST(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0)));
DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(L,2),REF(L,2+BARSLAST(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0)));
KU:=IF(C>B2 AND C>R2 AND C>G2,1,0);
KD:=IF(C<B2 AND C<R2 AND C<G2,-1,0);
KK:=IF(BARSLAST(KU=1 AND REF(KU,1)=0)<BARSLAST(KD=-1 AND REF(KD,1)=0),1,-1);
AO:=MA(Y ,5 )-MA(Y ,34 );
AC:=AO-MA( AO,5);
ac1:=ref(AC,1);
ao1:=ref(ao,1);
AOz:(170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29,linethick0;
AOl:(165*ma(Y,33)-136*ma(Y,4))/29,linethick0;
ACz:(5*34*5*AO-5*34*5*MA(AO,5)+5*34*4*MA(AO,4)+5*4*33*MA(Y,33)-4*34*4*MA(Y,4))/116,linethick0;
ACl:(5*34*MA(AO,4)-34*4*MA(Y,4)+5*33*MA(Y,33))/29,linethick0;
KAC:=IF(AC>ac1 AND Ao>ao1,1,0);
KAO:=IF(AC<ac1 AND Ao<ao1,-1,0);
蓝:SMA(Y,13,1),COLORBLUE;
红:SMA(Y,8,1),COLORRED;
绿:SMA(Y,5,1),COLORGREEN;
上碎:IF(H>=R2,UL,REF(UL,BARSLAST(H>R2))),COLORMAGENTA,linethick0;
下碎:IF(L<=R2,DL,REF(DL,BARSLAST(L<=R2))),COLORCYAN,linethick0;
STICKLINE(BARSLAST(ABS(上碎-REF(上碎,1)))<BARSLAST(c>上碎 AND REF(c,1)<REF(上碎,1)),上碎,上碎,3,1),COLORMAGENTA;
STICKLINE(BARSLAST(ABS(下碎-REF(下碎,1)))<BARSLAST(c<下碎 AND REF(c,1)>REF(下碎,1)),下碎,下碎,3,1),COLORCYAN;
OL:=(170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29;
CL:=(165*ma(y,33)-136*ma(y,4)+170*(4*MA(AO,4)+5*(REF(AO,4)-MA(REF(AO,4),5)))/4)/29;
H1:=REF(H,4);
H2:=REF(H,3);
H3:=REF(H,2);
H4:=REF(H,1);
H5:=H;
L1:=REF(L,4);
L2:=REF(L,3);
L3:=REF(L,2);
L4:=REF(L,1);
L5:=L;
DRAWICON(c>上碎 AND REF(c,1)<REF(上碎,1),H*1.015,4);
DRAWICON(c<下碎 AND REF(c,1)>REF(下碎,1),L*0.99,5);
DRAWICON(KU=1 AND REF(KU,1)=0 and c<0,L,4);
DRAWICON(KD=-1 AND REF(KD,1)=0 and c<0,H*1.01,5);
DRAWICON(KU=0 AND REF(KU,1)=1 and c<0,H*1.01,7);
DRAWICON(KD=0 AND REF(KD,1)=-1 and c<0,L,6);
STICKLINE(KAC=1 AND C>=O,O,C,8,1),COLORRED;
STICKLINE(KAO=-1 AND C>=O,O,C,8,1),COLORGREEN;
STICKLINE(KAO=0 AND KAC=0 AND C>=O,O,C,8,1),COLORGRAY;
STICKLINE(C>=O,H,C,0.4,1),COLORRED;
STICKLINE(C>=O,O,L,0.4,1),COLORRED;
STICKLINE(KAC=1 AND C<O,O,C,8,0),COLORRED;
STICKLINE(KAO=-1 AND C<O,O,C,8,0),COLORGREEN;
STICKLINE(KAO=0 AND KAC=0 AND C<O,O,C,8,0),COLORGRAY;
STICKLINE(O>C,H,O,0.4,1),COLORCYAN;
STICKLINE(O>C,C,L,0.4,1),COLORCYAN;
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
型:IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3)),COLORYELLOW;
JDU0:=REF(C,1)<=REF(型,1) AND C>型 AND TDU0<TUD0;
JUD0:=REF(C,1)>=REF(型,1) AND C<型 AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
DRAWTEXT(JDU2,L*0.9,'<=空转多’);
DRAWTEXT(JUD2,H*1.2,'<=多转空’);
DRAWTEXT(JDU3,L*0.9,'<=多续多’);
DRAWTEXT(JUD3,H*1.2,'<=空续空’);
yy:=(h+l+c)/3;
均价:STICKLINE(yy>0.05,yy,yy,9,0),COLORBLUE;{当天成交重心};
VA:=CROSS(EMA(c,6),EMA(C,21));
VB:=EMA(C,6)>EMA(C,17);
DRAWICON(VA and VB,EMA(c,17),1);
VarA:=IF(CLOSE and MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);
VarB:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND VarA>0, 91, 0);
STICKLINE(VarB>90,L*0.99,L*0.98,5,0),COLORYELLOW;
DRAWTEXT(VarB>90,LOW*0.98,’●追涨‘),COLORYELLOW;
V1:=EMA(EMA(EMA(CLOSE,8),13),55);
V2:=(REF(HIGH,1)+REF(LOW,1))/2;
V3:=MA(CLOSE,20)+2*STD(CLOSE,20);
DRAWICON(CROSS(V2,V3),HIGH*1.035,10);
DRAWTEXT(CROSS(V2,V3),HIGH*1.02,’→卖’),COLORblue;
V4:=REF(CLOSE,1);
V5:=SMA(MAX(CLOSE-V4,0),7,1)/SMA(ABS(CLOSE-V4),7,1)*100;
V6:=CROSS(79,V5);
V7:=FILTER(V6,4);
DRAWICON(V7,HIGH*1.035,10);
DRAWTEXT(V7,HIGH*1.02,’↓卖出’),COLORgreen;

大智慧鳄鱼出山主图指标公式

 

大智慧布林通道主图指标公式

N:=10;
P:=3;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
DWN:BBI-P*STD(BBI,N),linethick2;
UPR:BBI+P*STD(BBI,N),linethick2;
MA5:ma(c,5),COLORFF50FF,linethick2;
partline(MA5,MA5>=ref(MA5,1),rgb(255,0,0),MA5<ref(MA5,1),rgb(0,250,0)),linethick3;
DRAWGBKLAST(MA5>=ref(MA5,1),STRIP(RGB(0,150,0),RGB(150,0,0),1));
DRAWGBKLAST(MA5<=ref(MA5,1),STRIP(RGB(150,0,0),RGB(0,150,0),1));
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
DRAWTEXT(VAR327>90,LOW*0.99,’追’),COLORYELLOW;
STICKLINE(VAR327>90,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(VAR327>90,LOW,HIGH,0,0 ),COLORYELLOW;
{45度异动}
x1:=(C+L+H)/3;
bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
ema8:=ema(c,8);
DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),
ema8,’∠45上升’),coloryellow;
AAA:=(3*C+H+L+O)/6;
VAR41:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR41;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,’立桩量’),COLORYELLOW;
var1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
var2:=REF(var1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var3:=REF(var2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var4:=REF(var3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var5:=REF(var4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var6:=REF(var5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var7:=REF(var6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var8:=REF(var7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var9:=REF(var8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
varA:=REF(var9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
varB:=REF(varA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
varC:=REF(varB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
varD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
varE:=REF(varD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
varF:=REF(varE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var10:=REF(varF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var11:=REF(var10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var12:=REF(var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var13:=REF(var12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var14:=REF(var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var15:=REF(var14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var16:=REF(var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var17:=REF(var16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var18:=REF(var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
var19:=REF(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR
var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;
var1A:=REF(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR
var8 OR var9 OR varA OR varB OR varC,1) AND varD;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),8,0),COLOR00FFFF;{黄色}
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),8,0),COLORFF00FF;{粉红色}
黄底买入:var19,linethick0,COLOR00ffff;
粉顶卖出:var1A,linethick0,COLORFF50FF;
红色持股:0,linethick0,COLORRED;
绿色持币:0,linethick0,COLOR00d900;
DRAWICON(var19,REF(CLOSE,1)*0.99,7),ALIGN1;
DRAWICON(var1A,REF(CLOSE,1)*1.02,8),ALIGN1;
DRAWTEXTABS(2,5,’所属板块:’+BKNAME),COLORFF50FF,linethick1;
流通盘大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(2,20,’流通盘大小:’+NUMTOSTRN(流通盘大小,2)+’亿’+’ 电子盲制作’),LINETHICK1,COLORRED;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
DRAWTEXTABS(160,35,’每股收益:’+NUMTOSTRN(每股收益,2)+’元’),COLOR00FF00;
DRAWTEXTABS(160,50,’每股市盈率:’+NUMTOSTRN(每股市盈率,1)+’倍’),COLORRED;
DRAWTEXTABS(160,65,’每股净资产:’+NUMTOSTRN(每股净资产,2)+’元’),COLORRED;
DRAWTEXTABS(2,35,’销售毛利率:’+NUMTOSTRN(销售毛利率,2)+’%’),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(2,50,’主营收入同比增长:’+NUMTOSTRN(主营收入同比,2)+’%’),LINETHICK1,ColorYELLOW;
DRAWTEXTABS(2,65,’净利润同比增长:’+NUMTOSTRN(净利润同比增长,2)+’%’),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(3,80,’历史最高价:’+HHV(HIGH,0)),Colorred;
DRAWTEXTABS(3,95,’历史最低价:’+LLV(LOW,0)),ColorAFFF00;
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 – 10)) + IF(A6,10,(0 – 10))) + IF(A7,10,(0 – 10))) + IF(A8,10,(0 – 10))) + IF(A9,10,(0 – 10))) + IF(A11,10,(0 – 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
阻力位:=IF((CLOSE > 200),(CLOSE * 1.01),(CLOSE * 1.07));
阻力位1:=IF((CLOSE < 10),(CLOSE * 1.05),阻力位);
止损位:=IF((CLOSE > 200),(CLOSE * 0.99),(CLOSE * 0.93));
止损位1:=IF((CLOSE < 10),(CLOSE * 0.95),止损位);
TJTS1:=BARSTATUS=2 and c<200;
TJTS2:=BARSTATUS=2 and c>200;
k2:=hhv(h,barslast(DISPSTATUS=1)+1);
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,’该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 ‘),ALIGN2,colorDC143C;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,’该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 ‘),ALIGN2,colorDC143C;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) ,k2*0.99,’该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 ‘),ALIGN2,colorDC143C;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) ,k2*0.99,’该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 ‘),ALIGN2,color0000FF;

大智慧布林通道主图指标公式

 

大智慧资金多空指标公式

洗钱A:=(CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE;
洗钱B:=SMA(洗钱A,13,1);
洗钱C:SMA(洗钱B,5.5,1.5),POINTDOT;
洗钱D:3*洗钱B-2*洗钱C;
洗钱E:4*洗钱C-3*洗钱B;
量1:=EMA(洗钱A,3);
量2:=EMA(洗钱A,5);
量3:=EMA(洗钱A,7);
STICKLINE(量1>量2,量3,量1,8,1),COLORRED;
STICKLINE(量1<量2,量3,量1,8,1);T2:=量2<量3 AND 量1>REF(量1,1);
T1:=量2>量3 AND 量1<REF(量1,1);
STICKLINE(T1,量1,量3,5,0),COLORFF00FF;
STICKLINE(T2,量1,量3,5,0),COLORGREEN;

大智慧资金多空指标公式

 

大智慧成交量更直观指标公式

M1:=5;
M2:=10;
M3:=60;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:VOL,POINTDOT,COLORYELLOW;
主买:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主卖:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
STICKLINE(VOL>0,VOL,0,6,0),COLORYELLOW;
STICKLINE(主买>0,0,主买,6,0),COLORRED;
STICKLINE(主卖>0,0,主卖,2,0),COLOR00FF00;
MA1:MA(VOL,M1);
MA2:MA(VOL,M2);
MA3:MA(VOL,M3);

大智慧成交量更直观指标公式

 

大智慧主力进出货指标公式

VAR0:=DYNAINFO(5);
VAR1:=BARSCOUNT(HIGH);
VAR2:=(SMA((HIGH / HHV(CLOSE,120)),3,1) * 100);
低位金叉跟进:=IF((VAR1 > 20),VAR2,0);
VAR11:=IF((HIGH < VAR0),0,IF((LOW > VAR0),1,(((VAR0 – HIGH) + 0.009) / ((LOW – HIGH) + 0.009))));
AAA:=(DMA(VAR11,(VOL /SUM(VOL,90))) * 60);
BBB:=(DMA(VAR11,(VOL / CAPITAL)) * 60);
VAR12:=IF(C>1000,AAA,BBB);
VAR3:=IF((((VAR12 > 0) AND (VAR12 > REF(VAR12,1))) AND (低位金叉跟进 >= 88)),VAR2,0);
VAR4:=((3 * SMA((((CLOSE – HHV(HIGH,27)) / (LLV(LOW,27) – HHV(HIGH,27))) * 100),5,1)) – (2 * SMA(SMA((((HIGH – HHV(HIGH,27)) / (LLV(LOW,27) – HHV(HIGH,27))) * 100),5,1),3,1)));
VAR5:=EMA(VAR4,8);
VAR6:=((3 * SMA((((HIGH – HHV(HIGH,55)) / (LLV(LOW,55) – HHV(HIGH,55))) * 100),5,1)) – (2 * SMA(SMA((((HIGH – HHV(HIGH,55)) / (LLV(LOW,55) – HHV(HIGH,55))) * 100),5,1),3,1)));
VAR7:=(EMA(VAR6,3) – 10);
A:=1.1*C;
B:=0.9*C;
B1:=100*(WINNER(A)-WINNER(B));
C1:=MA(C,13)<REF(MA(C,13),1);
D1:=IF(C>1000,CROSS(VAR3,22),CROSS(VAR3,24));
锁定筹码:=100-B1;
锁定区:STICKLINE(锁定筹码>70 AND C1,0,锁定筹码-65,8,0),COLOR0000FF;
出仓区:STICKLINE(((VAR3>0) AND ((VAR7 < 20) OR ((VAR7 > REF(VAR7,1)) AND (VAR7 < 50)))),0,VAR3,8,0),COLORGREEN;
明天买:IF(CROSS(锁定筹码,90)AND C1,锁定筹码-50,0),COLORBBEEFF,LINETHICK2;
明天卖:IF(D1,VAR3+10,0),COLORFFAA00,LINETHICK2;

大智慧主力进出货指标公式

 

大智慧金盆聚宝指标公式

VARA:=LLV(LOW,35);
VARB:=HHV(HIGH,30);
VARC:=EMA(((H+L)/2-VARA)/(VARB-VARA)*4,4)*25;
QS:=VARC;
STICKLINE(VARC<10 AND 100*(HHV(HIGH,14)-(HIGH+LOW)/2)/(HHV(HIGH,14)-LLV(LOW,14))>97,0,25,3,1),COLORYELLOW;
STICKLINE(VARC>90,100,85,3,1),COLOR120156;
VARD:=87.5;
VARE:=(VARC-LLV(VARC,4))/(HHV(VARC,4)-LLV(VARC,4))*4*25;
VAR6:=(HIGH+LOW)/2;
VAR8:=LLV(LOW,30);
VARAA:=HHV(HIGH,30);
B:=EMA((VAR6-VAR8)/(VARAA-VAR8)*100,8);
B1:=EMA(B,5);
STICKLINE(B>0 AND B-B1>=0,79,80,3,0),COLOR0000FF;
STICKLINE(B>0 AND B-B1<0,79,80,3,0),COLOR00FF00;
STICKLINE(B>0 AND B-B1>=0,49,50,3,0),COLORRED;
STICKLINE(B>0 AND B-B1<0,49,50,3,0),COLOR00FF00;
STICKLINE(B>0 AND B-B1>=0,19,20,3,0),COLOR0000FF;
STICKLINE(B>0 AND B-B1<0,19,20,3,0),COLOR00FF00;
STICKLINE(B-B1>0,B,B1,8,0),COLOR110295;
STICKLINE(B-B1>0,B,B1,5.8,0),COLOR1402B9;
STICKLINE(B-B1>0,B,B1,4,0),COLOR1802DF;
STICKLINE(B-B1>0,B,B1,0.5,0),COLOR301AFD;
STICKLINE(B-B1<0,B,B1,8,0),COLOR037E10;
STICKLINE(B-B1<0,B,B1,5.8,0),COLOR039C12;
STICKLINE(B-B1<0,B,B1,4,0),COLOR03B114;
STICKLINE(B-B1<0,B,B1,0.5,0),COLOR03D117;
V1:=(HIGH+LOW)/2;
V2:=LLV(LOW,21);
VA:=HHV(HIGH,34);
FB:=EMA((V1-V2)/(VA-V2)*100,13);
FBB:=EMA((0.667*REF(FB,1)+0.333*FB),2);
ZLX:=EMA(0.382*REF(FB,2)+0.618*FB,12);
VAR61:=(HIGH+LOW)/2;
VAR81:=LLV(LOW,35);
VARB1:=HHV(HIGH,35);
BB:=EMA((VAR61-VAR81)/(VARB1-VAR81)*100,9);
金盆聚宝指标:EMA(0.667*REF(BB,1)+0.333*BB,2),linethick0;
GC1:=BB;
RSV1:=((HIGH+LOW)/2-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
GC2:=EMA(D1,3);
DRAWTEXT(FILTER(CROSS(BB,金盆聚宝指标)AND BB<30 AND 金盆聚宝指标>REF(金盆聚宝指标,1)AND BB>=金盆聚宝指标,5),35,’减空’);
DRAWTEXT(FILTER(CROSS(BB,金盆聚宝指标)AND BB<30 AND 金盆聚宝指标>REF(金盆聚宝指标,1)AND BB<=金盆聚宝指标,5),35,’追多’);
DRAWTEXT(FILTER(BB<REF(BB,1)AND BB>70 AND BB>REF(BB,4)AND C>MA(C,15),7)AND BB>金盆聚宝指标,55,’减多’);
DRAWTEXT(FILTER(BB<REF(BB,1)AND BB>92.5 AND BB>REF(BB,4)AND C>MA(C,15),7)AND BB<金盆聚宝指标,55,’追空’);
GC3:=LLV(BB,198);
GC4:=HHV(BB,188);
DRAWTEXT(FILTER(GC4>REF(GC4,1),7),LLV(BB-5,5),’将见顶’);
CC:=(BB-金盆聚宝指标<0.3)
AND (BB<25)AND (HIGH+LOW)/2<MA((HIGH+LOW)/2,13)*0.98 AND (HIGH+LOW)/2>REF((HIGH+LOW)/2,1);
DD:=FILTER(CC,10);
DRAWTEXT(DD,15,’还有一跌’);
{DRAWICON(DD,19,9);}
GG:=(BB-金盆聚宝指标<0.6)AND (BB<30)AND (HIGH+LOW)/2<MA(C,13)*0.996 AND (HIGH+LOW)/2>REF((HIGH+LOW)/2,1);
HH:=FILTER(GG,10);
DRAWTEXT(HH AND QS<20,25,’逃底点’),COLOR43D0FA;
{DRAWICON(HH,20,10);}
EE:=(BB-金盆聚宝指标>0.55)AND (BB>70) AND (HIGH+LOW)/2>MA((HIGH+LOW)/2,13)*0.96 AND (HIGH+LOW)/2<REF((HIGH+LOW)/2,1);
FF:=FILTER(EE,10);
DRAWTEXT(FF AND QS>80,70,’逃高点’),COLOR43D0FA;
DRAWTEXT(FILTER(GC3>REF(GC3,1),5)AND BB<40 AND 金盆聚宝指标>REF(金盆聚宝指标,1),LLV(BB-5,5),’将见底’);
DRAWTEXT(CROSS(B,ZLX) AND (B>ZLX) AND B<80 ,LLV(BB-5,5),’多攻’);
DRAWTEXT(CROSS(ZLX,B)AND (B<ZLX) AND B>20 ,HHV(BB+5,5),’空攻’),COLORGREEN;
0;100;

大智慧金盆聚宝指标公式

 

大智慧主力仓位指标公式

P:=5;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主卖:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2));
主力买入量:=(主买*0.5+主卖*0.1)/2;
ZL:sum(主力买入量,P)/sum(v,P)*1000,LINETHICK1;
dt:=ZL-ref(ZL,1);
STICKLINE(DT>0,ZL,ZL+DT,5,0),COLORRed;
STICKLine(DT<0,ZL+DT,ZL,5,0),COLORGreen;
DRAWTEXTABS(0,0,’【主力仓位】’),colorffffff,LINETHICK1;

大智慧主力仓位指标公式

 

大智慧最新操盘线主图指标公式

bu:=cross(high,SAR(3,1,20));
sel:=cross(SAR(3,1,20),low);
var1:=last(high<SAR(3,1,20));
var2:=last(low>sar(3,1,20));
drawflagtext(bu,high,’买入‘);
drawflagtext(sel,low,’卖出’);
drawtext(bu,LOW,’B’),valign0,align1,coloryellow,linethick2;
drawtext(sel,HIGH,’S’),valign2,align1,colorgreen,linethick2;
STICKLINE(low>SAR(3,1,20) and isdown,high,open,0.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,open,7.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,low,0.5,1),colorred;
STICKLINE(high<SAR(3,1,20) and isup,high,close,0.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,close,open,7.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,open,low,0.5,1),colorcyan;
drawflagtext(high<SAR(3,1,20) and high>=ref(high,1),high,’明日突破’+forcast(sar(3,1,20),max(var1,2))+’建议关注’);
drawflagtext(high<SAR(3,1,20) and high<ref(high,1),high,’持币观望’);
drawflagtext(low>SAR(3,1,20) and low<=ref(low,1),low,’明日跌破’+forcast(sar(3,1,20),max(var2,2))+’注意止盈’);
drawflagtext(low>SAR(3,1,20) and low>ref(low,1),low,’继续持股‘);

大智慧最新操盘线主图指标公式